#SAYI/0! hatasını düzeltme

Bir sayı sıfıra (0) veya değer içermeyen bir hücreye bölünürse, Excel #SAYI/0! hatasını görüntüler.

Belirti

Excel çalışma sayfasındaki bir veya birden çok hücrede #SAYI/0! hatasını görüntülüyor.

Nedenler

  • Açık olarak sıfırla (0) bölme gerçekleştiren bir formül girme - örneğin, =5/0.
  • Bölme işlemi yapan bir formül veya işlevde, bölen olarak boş veya sıfır içeren bir hücreye yönelik başvuru kullanma
  • #SAYI/0! hatasını veren bir işlevi veya formülü kullanan bir makroyu çalıştırma

Örnek

Örnek verilerini boş bir çalışma sayfasına kopyaladığınızda, A3, A4 ve A5 hücrelerindeki formüllerin tümü #SAYI/0! hatası döndürür.

GösterÖrneği nasıl kopyalayabilirim?

  1. Bu makaledeki örneği seçin. Örneği Excel Web App'a kopyalıyorsanız, bir kerede tek bir hücreyi kopyalayıp yapıştırın.

 Önemli   Satır veya sütun başlıklarını seçmeyin.

Yardım'dan örnek seçme

Yardım'dan örnek seçme
  1. CTRL+C tuşlarına basın.
  2. Boş bir çalışma kitabı veya çalışma sayfası oluşturun.
  3. Çalışma sayfasında A1 hücresini seçin ve CTRL+V tuşlarına basın. Excel Web App'ta çalışıyorsanız, örnekteki her hücre için kopyalama ve yapıştırma işlemini yineleyin.

 Önemli   Örneğin düzgün çalışması için, bunu çalışma sayfasının A1 hücresine yapıştırmalısınız.

  1. Sonuçları görüntüleme ve sonuçları döndüren formülleri görüntüleme arasında geçiş yapmak için, CTRL+` (kesme işareti) tuşlarına basın veya Formül Denetimi grubundaki Formüller öğesinde Formülleri Göster düğmesini tıklatın.

Örneği boş çalışma sayfasına kopyaladıktan sonra, bunu gereksinimlerinize göre uyarlayabilirsiniz.


 
1
2
3
4
5
A
1
0
=A1/0
=A1/A2
=BÖLÜM(A1,A2)

Çözüm

  • İşlevdeki veya formüldeki bölenin sıfır (0) veya boş olmadığından emin olun.
  • Formüldeki hücre başvurusunu sıfır veya boş değer içermeyen başka bir hücreyle değiştirin.
  • Formülde bölen olarak başvuruda bulunulan hücreye #YOK değerini girin.

#YOK değerinin girilmesi bölen değerinin bulunmadığını belirtmek için #SAYI/0! olan formülün sonucu #YOK olarak değiştirilir.

  • EĞER çalışma sayfası işlevini kullanarak hata değerinin görüntülenmesini engelleyin. Bundan sonra, sonuç olarak 0 veya başka bir dize görüntüleyebilirsiniz.

Örneğin, =A1/A2 formülü hata üretiyorsa, boş dize döndürmek için =EĞER(A2=0,"",A1/A2) formülünü veya 0 döndürmek için =EĞER(A2=0,0,A1/A2) formülünü kullanın.

 
 
Uygulandığı uygulamalar:
Excel 2007