DÜŞEYARA

Tablo dizisinin ilk sütununda belirli bir değeri arar ve tablo dizisindeki başka bir sütundan aynı satır değerini döndürür.

Karşılaştırma değerleriniz bulmak istediğiniz verinin solundaki sütundaysa, YATAYARA fonksiyonu yerine DÜŞEYARA fonksiyonunu kullanın.

Sözdizimi

DÜŞEYARA(bakılan_değer,tablo_dizisi,sütun_indis_sayısı,aralık_bak)

Bakılan_değer    Tablo dizisinin (dizi: Birden çok sonuç veren veya satırlar ve sütunlar halinde düzenlenmiş bir grup bağımsız değişken üzerinde işlem yapan tek formüller oluşturmak için kullanılır. Bir dizi aralığı ortak bir formülü paylaşır; bir dizi sabiti bağımsız değişken olarak kullanılan bir sabitler grubudur.) ilk sütununda aranacak değer. Bakılan_değer bir değer veya başvuru olabilir. Bakılan_değer, tablo_dizisinin ilk sütunundaki en küçük değerden daha küçükse, DÜŞEYARA fonksiyonu #YOK hata değerini döndürür.

Tablo_dizisi    İki veya daha çok veri sütunu. Aralığa veya aralık adına bir başvuru kullanır. Tablo_dizisinin ilk sütunundaki değerler, bakılan_değer tarafından aranan değerlerdir. Bu değerler metin, sayı veya mantıksal değerler olabilir. Büyük harf ve küçük harfle yazılmış metinler eşdeğerdir.

Sütun_indis_sayısı    İçinden uyan değerin döndürülmesi gereken tablo_dizisindeki sütun sayısı. Sütun_indis_sayısı 1, tablo_dizisindeki ilk sütunun değerini verir; sütun_indis_sayısı tablo_dizisindeki ikinci sütunun değerini verir ve böyle devam eder. Sütun_indis_sayısı:

  • 1'den küçükse, DÜŞEYARA fonksiyonu #DEĞER! hata değerini döndürür.
  • Tablo_dizisinin sütun sayısından büyükse, DÜŞEYARA fonksiyonu #BAŞV! hata değerini döndürür.

Aralık_bak    DÜŞEYARA fonksiyonunun tam eşleşme mi yoksa yaklaşık eşleşme mi bulmasını istediğinizi belirten mantıksal değer:

  • DOĞRU'ysa veya belirtilmemişse, tam veya yaklaşık eşleşme döndürülür. Tam eşleşme bulunamazsa, bakılan_değerden küçük olan sonraki en büyük değer döndürülür.

Tablo_dizisinin ilk sütunundaki değerler, artan sıralama düzeninde yerleştirilmelidir; böyle yapılmazsa DÜŞEYARA doğru değeri vermeyebilir. Veri menüsünde Sırala komutunu tıklatıp Artan'ı seçerek değerleri artan düzende sıralayabilirsiniz. Daha fazla bilgi için bkz: Varsayılan sıralama düzenleri.

  • YANLIŞ'sa, DÜŞEYARA fonksiyonu yalnızca tam eşleşmeyi bulur. Bu durumda, tablo_dizisinin ilk sütunundaki değerlerin sıralanması gerekmez. Tablo_dizisinin ilk sütununda bakılan_değerle eşleşen iki veya daha çok değer varsa, bulunan ilk değer kullanılır. Tam eşleşme bulunamazsa, #YOK hata değeri döndürülür.

Açıklamalar

  • Tablo_dizisinin ilk sütunundaki metin değerleri aranırken, tablo_dizisinin ilk sütunundaki verilerde başta ve sonda boşluk olmamasına, düz (' veya " ) ve kıvrımlı ( ‘ veya “) tırnak işaretlerinin tutarsız kullanılmamasına ve yazdırılamayan karakterler bulunmamasına dikkat edin. Bunlar olursa, DÜŞEYARA yanlış veya beklenmeyen bir değer verebilir. Metin verilerini temizlemek için kullanabileceğiniz fonksiyonlar hakkında daha fazla bilgi için bkz: Metin ve Veri fonksiyonları.
  • Sayı veya tarih değerlerini ararken, tablo_dizisinin ilk sütunundaki verilerin metin değerleri olarak depolanmamış olmasına dikkat edin. Böyle bir durumda, DÜŞEYARA yanlış veya beklenmeyen bir değer verebilir. Daha fazla bilgi için bkz: Metin olarak depolanmış sayıları sayıya dönüştürme.
  • Aralık_ara YANLIŞ ve bakılan_değer metin olduğunda, bakılan_değerde joker karakterler, soru işareti (?) ve yıldız işareti (*) kullanabilirsiniz. Soru işareti tek bir karakter bulurken, yıldız işareti bir dizi karakter bulur. Gerçek soru işaretini veya yıldız işaretini bulmak istiyorsanız, karakterin önüne bir tilde işareti (~) koyun.

Örnek 1

Boş bir çalışma sayfasına kopyalarsanız örneği anlamanız daha kolay olabilir.

GösterÖrneği kopyalama

  • Boş bir çalışma kitabı veya çalışma sayfası oluşturun.
  • Yardım konusundaki örneği seçin.

 Not   Satır veya sütun başlıklarını seçmeyin.

Yardım'dan bir örnek seçme

Yardım'dan bir örnek seçme
  • CTRL+C tuş bileşimine basın.
  • Çalışma sayfasında, A1 hücresini seçin ve CTRL+V tuş bileşimine basın.
  • Sonuçları görüntüleme ile bu sonuçları döndüren formülleri görüntüleme arasında geçiş yapmak için CTRL+` (aksan) tuş bileşimine basın veya Formüller sekmesindeki Formül Denetimi grubunda Formülleri Göster düğmesini tıklatın.

Bu örnekte, atmosfer özellikleri tablosunda ilişkili Akışkanlık ve Sıcaklık sütunlarını bulmak amacıyla Yoğunluk sütunu aranır. (Değerler, deniz düzeyinde 0 derece Celcius veya 1 atmosfer içindir.)

 
1
2
3
4
5
6
7
8
9
10
A B C
Yoğunluk Akışkanlık Sıcaklık 
0,457 3,55 500
0,525 3,25 400
0,616 2,93 300
0,675 2,75 250
0,746 2,57 200
0,835 2,38 150
0,946 2,17 100
1,09 1,95 50
1,29 1,71 0
Formül Açıklama (sonuç)
=DÜŞEYARA(1,A2:C10,2) Yaklaşık eşleşme kullanarak A sütununda 1 değerini arar, A sütununda 1'den küçük veya buna eşit en büyük değeri (0,946) bulur ve B sütununun aynı satırındaki değeri döndürür. (2,17)
=DÜŞEYARA(1,A2:C10,3,DOĞRU) Yaklaşık eşleşme kullanarak A sütununda 1 değerini arar, A sütununda 1'den küçük veya buna eşit en büyük değeri (0,946) bulur ve C sütununun aynı satırındaki değeri döndürür. (100)
=DÜŞEYARA(0,7,A2:C10,3,YANLIŞ) Tam eşleşme kullanarak A sütununda 0,7 değerini arar. A sütununda tam eşleşme bulunmadığından hata döndürür. (#YOK)
=DÜŞEYARA(0,1,A2:C10,2,DOĞRU) Yaklaşık eşleşme kullanarak A sütununda 0,1 değerini arar. 0,1 değeri A sütunundaki en küçük değerden bile küçük olduğundan hata döndürür. (#YOK)
=DÜŞEYARA(2,A2:C10,2,DOĞRU) Yaklaşık eşleşme kullanarak A sütununda 2 değerini arar, A sütununda 2'den küçük veya buna eşit en büyük değeri (1,29) bulur ve B sütununun aynı satırındaki değeri döndürür. (1,71)

Örnek 2

Boş bir çalışma sayfasına kopyalarsanız örneği anlamanız daha kolay olabilir.

GösterÖrneği kopyalama

  • Boş bir çalışma kitabı veya çalışma sayfası oluşturun.
  • Yardım konusundaki örneği seçin.

 Not   Satır veya sütun başlıklarını seçmeyin.

Yardım'dan bir örnek seçme

Yardım'dan bir örnek seçme
  • CTRL+C tuş bileşimine basın.
  • Çalışma sayfasında, A1 hücresini seçin ve CTRL+V tuş bileşimine basın.
  • Sonuçları görüntüleme ile bu sonuçları döndüren formülleri görüntüleme arasında geçiş yapmak için CTRL+` (aksan) tuş bileşimine basın veya Formüller sekmesindeki Formül Denetimi grubunda Formülleri Göster düğmesini tıklatın.

Bu örnekte, bebek ürünleri tablosunun Öğe Kimliği sütununda arama yapılır; fiyatları ve sınama koşullarını hesaplamak üzere Maliyet ve Satış Marjı alanlarındaki değerler eşleştirilir.

 
1
2
3
4
5
6
A B C D
Öğe Kimliği Öğe Maliyet Satış Marjı
ST-340 Puset 145,67 YTL %30
BI-567 Mama Önlüğü 3,56 YTL %40
DI-328 Bebek Bezi 21,45 YTL %35
WI-989 Islak Mendil 5,12 YTL %40
AS-469 Aspiratör 2,56 YTL %45
Formül Açıklama (sonuç)
= DÜŞEYARA("DI-328", A2:D6, 3, YANLIŞ) * (1 + DÜŞEYARA("DI-328", A2:D6, 4, YANLIŞ)) Satış marjı yüzdesini maliyete ekleyerek bebek bezinin perakende fiyatını hesaplar. (28,96 YTL)
= (DÜŞEYARA("WI-989", A2:D6, 3, YANLIŞ) * (1 + DÜŞEYARA("WI-989", A2:D6, 4, YANLIŞ))) * (1 - %20) Perakende fiyatından belirli bir indirim yaparak ıslak mendilin satış fiyatını hesaplar. (5,73 YTL)
= EĞER(DÜŞEYARA(A2, A2:D6, 3, YANLIŞ) >= 20, "Satış marjı eşittir " & 100 * DÜŞEYARA(A2, A2:D6, 4, YANLIŞ) &"%", "Maliyet 20,00 YTL'nin altında") Öğenin maliyeti 20,00 YTL veya daha fazlaysa, "Satış marjı %nn" dizesini görüntüler; bunun dışındaki durumlarda "Maliyet 20,00 YTL'nin altında" dizesini görüntüler. (Satış marjı %30)
= EĞER(DÜŞEYARA(A3, A2:D6, 3, YANLIŞ) >= 20, "Satış marjı eşittir: " & 100 * DÜŞEYARA(A3, A2:D6, 4, YANLIŞ) &"%", "Maliyet eşittir " & DÜŞEYARA(A3, A2:D6, 3, YANLIŞ)) Öğenin maliyeti 20,00 YTL veya daha fazlaysa "Satış marjı %nn" dizesini görüntüler; bunun dışındaki durumlarda "Maliyet n,nn YTL" dizesini görüntüler. (Maliyet 3,56 YTL)

Örnek 3

Boş bir çalışma sayfasına kopyalarsanız örneği anlamanız daha kolay olabilir.

GösterÖrneği kopyalama

  • Boş bir çalışma kitabı veya çalışma sayfası oluşturun.
  • Yardım konusundaki örneği seçin.

 Not   Satır veya sütun başlıklarını seçmeyin.

Yardım'dan bir örnek seçme

Yardım'dan bir örnek seçme
  • CTRL+C tuş bileşimine basın.
  • Çalışma sayfasında, A1 hücresini seçin ve CTRL+V tuş bileşimine basın.
  • Sonuçları görüntüleme ile bu sonuçları döndüren formülleri görüntüleme arasında geçiş yapmak için CTRL+` (aksan) tuş bileşimine basın veya Formüller sekmesindeki Formül Denetimi grubunda Formülleri Göster düğmesini tıklatın.

Bu örnekte, çalışan tablosunun Kimlik sütununda arama yapılır; yaşları hesaplamak ve hata durumlarına göre sınama yapmak için diğer sütunlardaki değerler eşleştirilir.

 
1
2
3
4
5
6
7
A B C D E
Kimlik Soyadı Ad Unvan Doğum tarihi
1 Etikan Gamze Satış Temsilcisi 8/12/1968
2 Ilgaz Emre Başkan Yardımcısı, Satış 19/2/1952
3 Demirci Canan Satış Temsilcisi 30/8/1963
4 Güçlü Melahat Satış Temsilcisi 19/9/1958
5 Koç Serdar Satış Müdürü 4/3/1955
6 Uludağ Ali Satış Temsilcisi 2/7/1963
Formül Açıklama (Sonuç)
=TAMSAYI(YILORAN(TARİH(2004,6,30), DÜŞEYARA(5,A2:E7,5, YANLIŞ), 1)) 2004 mali yılı için, kimliği 5'e eşit olan çalışanın yaşını bulur. Mali yıl son tarihinden doğum tarihini çıkarmak için YILORAN fonksiyonunu kullanır ve TAMSAYI fonksiyonunu kullanarak tamsayı olarak sonucu görüntüler. (49)
=EĞER(EYOKSA(DÜŞEYARA(5,A2:E7,2,YANLIŞ)) = DOĞRU, "Çalışan bulunamadı", DÜŞEYARA(5,A2:E7,2,YANLIŞ))

Kimliği 5 olan bir çalışan varsa, çalışanın soyadını görüntüler; yoksa, "Çalışan bulunamadı" iletisini görüntüler. (Koç)

DÜŞEYARA fonksiyonu #YOK hata değerini döndürdüğünde EYOKSA fonksiyonu DOĞRU değerini döndürür.

=EĞER(EYOKSA(DÜŞEYARA(15,A3:E8,2,YANLIŞ)) = DOĞRU, "Çalışan bulunamadı", DÜŞEYARA(15,A3:E8,2,YANLIŞ))

Kimliği 15 olan bir çalışan varsa, çalışanın soyadını görüntüler; yoksa, "Çalışan bulunamadı" iletisini görüntüler. (Çalışan bulunamadı)

DÜŞEYARA fonksiyonu #YOK hata değerini döndürdüğünde EYOKSA fonksiyonu DOĞRU değerini döndürür.

=DÜŞEYARA(4,A2:E7,3,YANLIŞ) & " " & DÜŞEYARA(4,A2:E7,2,YANLIŞ) & " bir " & DÜŞEYARA(4,A2:E7,4,YANLIŞ) & "." Kimliği 4 olan çalışan için, üç hücrenin değerlerini birleştirerek tam bir cümle oluşturur. (Melahat Güçlü bir Satış Temsilcisi.)

 Not   Yukarıdaki ilk formül YILORAN fonksiyonunu kullanır. Bu fonksiyon kullanılamıyor ve #AD? hatası veriyorsa, ToolPak Çözümleyicisi eklentisini seçip yükleyin.

GösterNasıl Yapılır?

  1. Araçlar menüsünde Eklentiler'i tıklatın.
  2. Kullanılabilir eklentiler listesinde ToolPak Çözümleyicisi kutusunu seçin ve Tamam'ı tıklatın.
  3. Gerekirse, kurulum programındaki yönergeleri izleyin.
 
 
Uygulandığı uygulamalar:
Excel 2003