EĞER

Belirttiğiniz koşul DOĞRU olarak değerlendirilirse bir değer, YANLIŞ olarak değerlendirilirse başka bir değer verir.

Değerler ve formüller üzerinde koşullu sınamalar yürütmek için EĞER fonksiyonunu kullanın.

Sözdizimi

EĞER(mantıksal_sınama;eğer_doğruysa_değer;eğer_yanlışsa_değer)

Mantıksal_sınama     DOĞRU veya YANLIŞ olarak değerlendirilebilecek herhangi bir değer veya deyim. Örneğin, A10=100, mantıksal bir deyimdir; A10 hücresindeki değer 100'e eşitse, deyim DOĞRU olarak değerlendirilir. Tersi durumda, YANLIŞ olarak değerlendirilir. Bu bağımsız değişken herhangi bir karşılaştırma hesabı işleci kullanabilir.

Eğer_doğruysa_değer     mantıksal_sınama DOĞRU ise verilen değerdir. Örneğin, metin dizesindeki bu bağımsız değişken "Bütçe içinde" ise ve mantıksal_sınama bağımsız değişkeni DOĞRU olarak değerlendirilirse, EĞER fonksiyonu "Bütçe içinde" metnini görüntüler. Mantıksal_sınama DOĞRU ise ve eğer_doğruysa_değer boşsa, bu bağımsız değişken 0 (sıfır) değeri verir. DOĞRU sözcüğünü görüntülemek üzere bu bağımsız değişken için DOĞRU mantıksal değerini kullanın. Eğer_doğruysa_değer başka bir formül olabilir.

Eğer_yanlışsa_değer     Mantıksal_sınama YANLIŞ ise verilen değerdir. Örneğin, metin dizesindeki bu bağımsız değişken "Bütçeyi aşıyor" ise ve mantıksal_sınama bağımsız değişkeni YANLIŞ olarak değerlendirilirse, EĞER fonksiyonu "Bütçeyi aşıyor" metnini görüntüler. Mantıksal_sınama YANLIŞ ise ve eğer_yanlışsa_değer belirtilmemişse (bu, eğer_doğruysa_değer'inden sonra virgül olmamasıdır) YANLIŞ mantıksal değeri verilir. Mantıksal_sınama YANLIŞ ise ve eğer_yanlışsa_değer boşsa (bu, eğer_doğruysa_değer'inden sonra bir virgül ve onu izleyen kapatma parantezi olması durumudur) 0 (sıfır) değeri verilir. Eğer_yanlışsa_değer başka bir formül olabilir.

Uyarılar

Örnek 1

Örneği boş çalışma sayfasına kopyalarsanız anlamanız daha kolay olabilir.

GösterNasıl Yapılır?

  1. Boş bir çalışma kitabı veya çalışma sayfası oluşturun.
  2. Yardım konusundaki örneği seçin. Satır veya sütun başlıklarını seçmeyin. 

Yardım'dan bir örnek seçme

Yardım'dan bir örnek seçme
  1. CTRL+C tuşlarına basın.
  2. Çalışma sayfasında, A1 hücresini seçin ve CTRL+V tuşlarına basın.
  3. Sonuçları görüntüleme ve sonuçları döndüren formülleri görüntüleme arasında geçiş yapmak için, CTRL+` (kesme işareti) tuşlarına basın veya Araçlar menüsündeki Formül İzleme'yi seçin ve Formül İzleme Modu'nu tıklatın.
 
1
2
A
Veri
50
Formül Açıklama (Sonuç)
=EĞER(A2<=100;"Bütçe içinde";"Bütçeyi aşıyor") Yukarıdaki sayı 100'e eşit veya küçükse, bu durumda formül "Bütçe içinde"yi görüntüler. Aksi halde, fonksiyon "Bütçeyi aşıyor" metni görüntüler (Bütçe içinde)
=EĞER(A2=100;TOPLA(B5:B15);"") Yukarıdaki sayı 100 ise, B5:B15 aralığı hesaplanır. Aksi halde, boş metin ("") verilir ()

Örnek 2

Örneği boş çalışma sayfasına kopyalarsanız anlamanız daha kolay olabilir.

GösterNasıl Yapılır?

  1. Boş bir çalışma kitabı veya çalışma sayfası oluşturun.
  2. Yardım konusundaki örneği seçin. Satır veya sütun başlıklarını seçmeyin. 

Yardım'dan bir örnek seçme

Yardım'dan bir örnek seçme
  1. CTRL+C tuşlarına basın.
  2. Çalışma sayfasında, A1 hücresini seçin ve CTRL+V tuşlarına basın.
  3. Sonuçları görüntüleme ve sonuçları döndüren formülleri görüntüleme arasında geçiş yapmak için, CTRL+` (kesme işareti) tuşlarına basın veya Araçlar menüsündeki Formül İzleme'yi seçin ve Formül İzleme Modu'nu tıklatın.
 
1
2
3
4
A B
Fiili Harcamalar Öngörülen Harcamalar
1500 900
500 900
500 925
Formül Açıklama (Sonuç)
=EĞER(A2>B2;"Bütçeyi Aşıyor";"Tamam") Birinci sıranın bütçeyi aşıp aşmadığını denetler (Bütçeyi Aşıyor)
=EĞER(A3>B3;"Bütçeyi Aşıyor";"Tamam") İkinci sıranın bütçeyi aşıp aşmadığını denetler (Tamam)

Örnek 3

Örneği boş çalışma sayfasına kopyalarsanız anlamanız daha kolay olabilir.

GösterNasıl Yapılır?

  1. Boş bir çalışma kitabı veya çalışma sayfası oluşturun.
  2. Yardım konusundaki örneği seçin. Satır veya sütun başlıklarını seçmeyin. 

Yardım'dan bir örnek seçme

Yardım'dan bir örnek seçme
  1. CTRL+C tuşlarına basın.
  2. Çalışma sayfasında, A1 hücresini seçin ve CTRL+V tuşlarına basın.
  3. Sonuçları görüntüleme ve sonuçları döndüren formülleri görüntüleme arasında geçiş yapmak için, CTRL+` (kesme işareti) tuşlarına basın veya Araçlar menüsündeki Formül İzleme'yi seçin ve Formül İzleme Modu'nu tıklatın.
 
1
2
3
4
A
Puan
45
90
78
Formül Açıklama (Sonuç)
=EĞER(A2>89;"A";EĞER(A2>79;"B";EĞER(A2>69;"C";EĞER(A2>59;"D";"F")))) Birinci puana harf derecesi atar (F)
=EĞER(A3>89;"A";EĞER(A3>79;"B";EĞER(A3>69;"C";EĞER(A3>59;"D";"F")))) İkinci puana harf derecesi atar (A)
=EĞER(A4>89;"A";EĞER(A4>79;"B";EĞER(A4>69;"C";EĞER(A4>59;"D";"F")))) Üçüncü puana harf derecesi atar (C)

Önceki örnekte, ikinci EĞER deyimi birinci EĞER deyiminin de eğer_yanlışsa_değer bağımsız değişkenidir. Benzer şekilde, üçüncü EĞER deyimi de ikinci EĞER deyiminin eğer_yanlışsa_değer bağımsız değişkenidir. Örneğin, birinci mantıksal_sınama (Ortalama>89) DOĞRU ise, "A" döndürülür. Birinci mantıksal_sınama YANLIŞ ise, ikinci EĞER deyimi değerlendirilir ve bu şekilde işlem devam eder.

Harf dereceleri aşağıdaki anahtar kullanılarak sayılara atanmaktadır.

Puan Verilecek değer
89'dan büyükse A
80 ile 89 arasındaysa B
70 ile 79 arasındaysa C
60 ile 69 arasındaysa D
60'dan küçükse F
 
 
Uygulandığı uygulamalar:
Excel 2003