Formül oluşturma

Formüller, çalışma sayfanızdaki değerler üzerinden hesaplama yapan denklemlerdir. Formül, eşittir imiyle (=) başlar. Örneğin, aşağıdaki formül 2 ile 3'ü çarpar ve sonucu 5 ile toplar.

=5+2*3

GösterBasit bir formül oluşturma: =128+345

GösterBaşvuru veya ad içeren formül oluşturma: =A1+23

Aşağıdaki formüller, diğer hücrelere göreli başvuruları (göreli başvuru: Bir formülde, hücrenin, formülü ve başvurulan hücreyi içeren hücrenin göreli konumunu esas alan adresi. Formülü kopyalarsanız, başvuru otomatik olarak ayarlanır. Göreli başvuru A1 biçimini alır.) ve diğer hücrelerin adlarını (ad: Bir hücreyi, hücre aralığını, formülü veya sabit değeri temsil eden bir sözcük veya karakter dizesi. Satışlar!C20:C30 gibi zor anlaşılır aralıklara başvurmak için Ürünler gibi kolay anlaşılır adlar kullanın.) içerir. Formül içeren hücrenin değeri, diğer hücrelerdeki değerlere bağlı olduğunda, formülü içeren hücre etkilenen hücre olarak bilinir. Örneğin, B2 hücresi =C2 formülünü içeriyorsa etkilenen hücredir.

Örnek formül Ne yapar
=C2 C2 hücresindeki değeri kullanır
=Sayfa2!B2 Sayfa2'de B2 hücresindeki değeri kullanır
=Aktif-Pasif Pasif adlı bir hücreden Aktif adlı bir hücreyi çıkarır
  1. Formülü girmek istediğiniz hücreyi tıklatın.
  2. Formül çubuğunda (formül çubuğu: Excel penceresinin üzerinde, hücreler veya grafiklere değerler veya formüller eklemek veya düzenlemek için kullanılan bir çubuk. Etkin hücrede depolanan sabit değer veya formülü görüntüler.) Formül çubuğu = (eşittir işareti) yazın.
  3. Aşağıdakilerden birini yapın:
    • Başvuru oluşturmak için, bir hücre, hücre aralığı, başka bir çalışma sayfasında veya kitabındaki bir konumu seçin. Seçimi taşımak için hücre seçiminin kenarlığını sürükleyebileceğiniz gibi, seçimi genişletmek için kenarlığın köşesini de sürükleyebilirsiniz.

Aralık Bulucu renk kodları etkileyen hücreleri

  • Adlandırılmış aralığa başvuru oluşturmak için, F3'e basın, Ad yapıştır kutusunda adı seçin ve Tamam'ı tıklatın.
  1. ENTER tuşuna basın.

GösterFonksiyon içeren formül oluşturma: =ORTALAMA(A1:B4)

Aşağıdaki formüller fonksiyonlar (fonksiyon: Bir değer veya değerleri alan, bir işlemi gerçekleştiren ve bir değer veya değerler döndüren, önceden yazılmış bir formül. Çalışma sayfasındaki formülleri, özellikle uzun veya karmaşık hesaplamalar yapanları sadeleştirmek ve kısaltmak için fonksiyonları kullanın.) içerir.

Örnek formül Ne yaptığı
=TOPLA(A:A) A sütunundaki tüm sayıları toplar
=ORTALAMA(A1:B4) Aralıktaki tüm sayıların ortalamasını alır
  1. Formülü girmek istediğiniz hücreyi tıklatın.
  2. Formüle fonksiyonla başlamak için formül çubuğunda (formül çubuğu: Excel penceresinin üzerinde, hücreler veya grafiklere değerler veya formüller eklemek veya düzenlemek için kullanılan bir çubuk. Etkin hücrede depolanan sabit değer veya formülü görüntüler.) Formül çubuğu Fonksiyon Ekle Düğme görüntüsü simgesini tıklatın.
  3. Kullanmak istediğiniz fonksiyonları seçin. Fonksiyon ara kutusuna, yapmak istediğiniz işlemi açıklayan bir soru girebilir (örneğin, "sayıları topla" TOPLA fonksiyonunu getirir) ya da Veya bir kategori seç kutusundaki kategorilere göz atabilirsiniz.
  4. Bağımsız değişkenleri (bağımsız değişken: İşlevin işlemler veya hesaplamalar yapmakta kullandığı değerler. İşlevin kullandığı bağımsız değişken türü fonksiyona özeldir. İşlevlerde sıklıkla kullanılan bağımsız değişkenler arasında, metin, hücre başvuruları ve adlar yer alır.) girin. Bağımsız değişken olarak hücre başvuruları girmek için, iletişim kutusunu geçici olarak gizlemek üzere İletişim Kutusunu Daralt Düğme görüntüsü simgesini tıklatın. Çalışma sayfasındaki hücreleri seçin ve sonra İletişim Kutusunu Genişlet Düğme görüntüsü düğmesine basın.
  5. Formülü tamamladığınızda, ENTER tuşuna basın.

Gösterİç içe geçen fonksiyonlar içeren formül oluşturma: =EĞER(ORTALAMA(F2:F5)>50, TOPLA(G2:G5),0)

İç içe geçen fonksiyonlar, bir fonksiyonu, başka bir fonksiyonun bağımsız değerlerinden biri olarak kullanır. Aşağıdaki formül, bir sayı kümesinin (G2:G5) toplamını, yalnızca diğer sayı kümesinin (F2:F5) ortalaması 50'den büyükse alır. Aksi halde 0'ı getirir.

İç içe Geçen Fonksiyonlar

  1. Formülü girmek istediğiniz hücreyi tıklatın.
  2. Formüle fonksiyonla başlamak için formül çubuğunda (formül çubuğu: Excel penceresinin üzerinde, hücreler veya grafiklere değerler veya formüller eklemek veya düzenlemek için kullanılan bir çubuk. Etkin hücrede depolanan sabit değer veya formülü görüntüler.) Formül çubuğu Fonksiyon Ekle Düğme görüntüsü simgesini tıklatın.
  3. Kullanmak istediğiniz fonksiyonları seçin. Fonksiyon ara kutusuna, yapmak istediğiniz işlemi açıklayan bir soru girebilir (örneğin, "sayıları topla" TOPLA fonksiyonunu getirir) ya da Veya bir kategori seç kutusundaki kategorilere göz atabilirsiniz.
  4. Bağımsız değişkenleri (bağımsız değişken: İşlevin işlemler veya hesaplamalar yapmakta kullandığı değerler. İşlevin kullandığı bağımsız değişken türü fonksiyona özeldir. İşlevlerde sıklıkla kullanılan bağımsız değişkenler arasında, metin, hücre başvuruları ve adlar yer alır.) girin.
    • Bağımsız değişken olarak hücre başvuruları girmek için, iletişim kutusunu geçici olarak gizlemek istediğiniz bağımsız değişkenin yanındaki İletişim Kutusunu Daralt Düğme görüntüsü simgesini tıklatın. Çalışma sayfasındaki hücreleri seçin; sonra İletişim Kutusunu Genişlet Düğme görüntüsü düğmesine basın.
    • Bağımsız değişken olarak başka bir fonksiyon girmek için, istediğiniz bağımsız değişken kutusuna fonksiyonu girin. Örneğin, Eğer_doğruysa_değer düzenleme kutusuna TOPLAM(G2:G5) girebilirsiniz.
    • Fonksiyon Bağımsız Değişkenleri iletişim kutusunda görüntülenen formülün bölümleri arasında geçiş yapmak için formül çubuğunda bir fonksiyon adını tıklatın. Örneğin, EĞER'i tıklatırsanız, EĞER işlevi ile ilgili bağımsız değişkenler görünür.

Gösterİpuçları

 
 
Uygulandığı uygulamalar:
Excel 2003