Skapa en formel med en funktion

 Viktigt   De beräknade resultaten av formler och vissa funktioner i Excel-kalkylblad kan skilja sig något mellan en Windows PC med x86- eller x86-64-arkitektur och en Windows RT-dator med ARM-arkitektur. Läs mer om skillnaderna.

Du kan skapa en formel (formel: En sekvens med värden, cellreferenser, namn, funktioner eller operatorer i en cell som tillsammans producerar ett nytt värde. En formel börjar alltid med ett likhetstecken (=).) om du vill beräkna värden i ditt kalkylblad med en funktion (funktion: En färdigskriven formel som använder ett eller flera värden, utför en åtgärd och sedan returnerar ett eller flera värden. Du kan använda funktioner för att förenkla och förkorta formler i ett kalkylblad, speciellt de som genomför långa eller komplexa beräkningar.). Formlerna =SUMMA(A1:A2) och SUMMA(A1;A2) använder exempelvis båda funktionen SUMMA för att summera värdena i cell A1 och A2. Formler börjar alltid med ett likhetstecken (=).

  1. Klicka på cellen där du vill skriva formeln.
  2. Om du vill inleda formeln med funktionen klickar du på Infoga funktionBild av knapp i formelfältet Bild av knapp.

Likhetstecknet (=) infogas.

  1. Markera Alla i kryssrutan Eller välj en kategori.

Om du är bekant med funktionskategorierna kan du också välja en kategori.

Om du inte är säker på vilken funktion du ska använda kan du skriva in en fråga som beskriver vad du vill i rutan Sök efter funktion ("lägg till tal" returnerar t.ex. funktionen SUMMA).

 Tips    En lista över tillgängliga funktioner finns i Excel-funktioner (alfabetiskt) eller Excel-funktioner (efter kategori).

  1. Välj den funktion du vill använda i dialogrutan Välj en funktion och klicka på OK.
  2. Ange de värden, textsträngar eller cellreferenser du vill ha i argumentrutorna som visas för den funktion du har valt.

I stället för att skriva in cellreferenser kan du markera cellerna du vill referera till. Klicka på Bild av knapp om du vill minimera dialogrutan, markera cellerna du vill referera till och klicka sedan på Bild av knapp om du vill expandera dialogrutan igen.

 Tips    Klicka på Hjälp om funktionen om du vill ha mer information om funktionen och dess argument.

  1. Klicka på OK efter att du har slutfört argumenten för formel.

 Tips    Om du använder funktioner ofta kan du ange formler direkt i kalkylbladet. Efter att du har angett ett likhetstecken (=) och funktionens namn kan du få information om formelsyntaxen och funktionsargumenten genom att trycka på F1.

Exempel

Kopiera tabellen till cell A1 på ett tomt kalkylblad i Excel om du vill arbeta med de här exemplen på formler som använder funktioner.

Data
5 4
2 6
3 8
7 1
Formel Beskrivning Resultat
'=SUMMA(A:A) Adderar alla nummer i kolumn A =SUMMA(A:A)
'=MEDEL(A1:B4) Beräknar genomsnittet av alla tal i intervallet A1:B4 =MEDEL(A1:B4)

Överst på sidan Överst på sidan

 
 
Gäller:
Excel 2013