Функция ЕСЛИ

Возвращает одно значение, если заданное условие при вычислении дает значение ИСТИНА, и другое значение, если ЛОЖЬ.

Функция ЕСЛИ используется при проверке условий для значений и формул.

Синтаксис

ЕСЛИ(лог_выражение;значение_если_истина;значение_если_ложь)

Лог_выражение     — любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ. Например, A10=100 — логическое выражение; если значение в ячейке A10 равно 100, это выражение принимает значение ИСТИНА, а в противном случае — значение ЛОЖЬ. Этот аргумент может использоваться в любом операторе сравнения.

Значение_если_истина     — значение, которое возвращается, если аргумент «лог_выражение» имеет значение ИСТИНА. Например, если данный аргумент — строка «В пределах бюджета», а аргумент «лог_выражение» имеет значение ИСТИНА, то функция ЕСЛИ отобразит текст «В пределах бюджета». Если аргумент «лог_выражение» имеет значение ИСТИНА, а аргумент «значение_если_истина» не задан, возвращается значение 0 (ноль). Чтобы отобразить слово ИСТИНА, необходимо использовать логическое значение ИСТИНА для этого аргумента. Аргумент «значение_если_истина» может быть формулой.

Значение_если_ложь     — значение, которое возвращается, если «лог_выражение» имеет значение ЛОЖЬ. Например, если данный аргумент — строка «Превышение бюджета», а аргумент «лог_выражение» имеет значение ЛОЖЬ, то функция ЕСЛИ отобразит текст «Превышение бюджета». Если аргумент «лог_выражение» имеет значение ЛОЖЬ, а аргумент «значение_если_ложь» опущен (т. е. после аргумента «значение_если_истина» отсутствует точка с запятой), то возвращается логическое значение ЛОЖЬ. Если аргумент «лог_выражение» имеет значение ЛОЖЬ, а аргумент «значение_если_ложь» пуст (т. е. после аргумента «значение_если_истина» стоит точка с запятой, а за ней — закрывающая скобка), то возвращается значение 0 (ноль). Аргумент «значение_если_ложь» может быть формулой.

Замечания

Пример 1

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

ПоказатьИнструкции

  1. Создайте пустую книгу или лист.
  2. Выделите пример в разделе справки.

 Примечание.   Не выделяйте заголовок строки или столбца.

Выделение примера в справке

Выделение примера в справке
  1. Нажмите клавиши CTRL+C.
  2. Выделите на листе ячейку A1 и нажмите клавиши CTRL+V.
  3. Чтобы перейти от просмотра результатов к просмотру формул, возвращающих эти результаты, нажмите клавиши CTRL+` (апостроф) или на вкладке Формулы в группе Зависимости формул нажмите кнопку Показать формулы.
 
1
2
3
4
5
A B C
Данные
50
Формула Описание результат
=ЕСЛИ(A2<=100;"Внутри бюджета";"Вне бюджета") Если приведенное выше число меньше или равно 100, формула отображает строку «В пределах бюджета». В противном случае отображается строка «Превышение бюджета» В пределах бюджета
=ЕСЛИ(A2=100;СУММ(B5:B15);"") Если число равно 100, вычисляется сумма в диапазоне B5:B15. В противном случае возвращается пустая текстовая строка ("")

Пример 2

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

ПоказатьИнструкции

  1. Создайте пустую книгу или лист.
  2. Выделите пример в разделе справки.

 Примечание.   Не выделяйте заголовок строки или столбца.

Выделение примера в справке

Выделение примера в справке
  1. Нажмите клавиши CTRL+C.
  2. Выделите на листе ячейку A1 и нажмите клавиши CTRL+V.
  3. Чтобы перейти от просмотра результатов к просмотру формул, возвращающих эти результаты, нажмите клавиши CTRL+` (апостроф) или на вкладке Формулы в группе Зависимости формул нажмите кнопку Показать формулы.
 
1
2
3
4
5
6
7
A B C
Фактические расходы Предполагаемые расходы
1500 900
500 900
500 925
Формула Описание результат
=ЕСЛИ(A2>B2;"Превышение бюджета";"ОК") Проверяет первую строку на превышение бюджета Превышение бюджета
=ЕСЛИ(A3>B3;"Превышение бюджета";"ОК") Проверяет вторую строку на превышение бюджета ОК

Пример 3

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

ПоказатьИнструкции

  1. Создайте пустую книгу или лист.
  2. Выделите пример в разделе справки.

 Примечание.   Не выделяйте заголовок строки или столбца.

Выделение примера в справке

Выделение примера в справке
  1. Нажмите клавиши CTRL+C.
  2. Выделите на листе ячейку A1 и нажмите клавиши CTRL+V.
  3. Чтобы перейти от просмотра результатов к просмотру формул, возвращающих эти результаты, нажмите клавиши CTRL+` (апостроф) или на вкладке Формулы в группе Зависимости формул нажмите кнопку Показать формулы.
 
1
2
3
4
5
6
7
8
A
Балл
45
90
78
Формула Описание результат
=ЕСЛИ(A2>89;"A";ЕСЛИ(A2>79;"B"; ЕСЛИ(A2>69;"C";ЕСЛИ(A2>59;"D";"F")))) Назначает буквенную категорию первому баллу F
=ЕСЛИ(A3>89;"A";ЕСЛИ(A3>79;"B"; ЕСЛИ(A3>69;"C";ЕСЛИ(A3>59;"D";"F")))) Назначает буквенную категорию второму баллу A
=ЕСЛИ(A4>89;"A";ЕСЛИ(A4>79;"B"; ЕСЛИ(A4>69;"C";ЕСЛИ(A4>59;"D";"F")))) Назначает буквенную категорию третьему баллу C

В предыдущем примере второе предложение ЕСЛИ является одновременно аргументом «значение_если_ложь» для первого предложения ЕСЛИ. В свою очередь, третье предложение ЕСЛИ является аргументом «значение_если_ложь» для второго предложения ЕСЛИ. Например, если первый аргумент «лог_выражение» (Среднее>89) имеет значение ИСТИНА, то возвращается значение «A». Если первый аргумент «лог_выражение» имеет значение ЛОЖЬ, вычисляется второе предложение ЕСЛИ, и так далее.

Чтобы назначить числам буквенные категории, воспользуйтесь следующей таблицей.

Если балл равен Категория
Больше 89 A
От 80 до 89 B
От 70 до 79 C
От 60 до 69 D
Меньше 60 F

Пример 4

Поскольку в этом примере надо проверить тринадцать условий, то для удобства чтения и сохранения вместо функции ЕСЛИ используется функция ПРОСМОТР.

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

ПоказатьИнструкции

  1. Создайте пустую книгу или лист.
  2. Выделите пример в разделе справки.

 Примечание.   Не выделяйте заголовок строки или столбца.

Выделение примера в справке

Выделение примера в справке
  1. Нажмите клавиши CTRL+C.
  2. Выделите на листе ячейку A1 и нажмите клавиши CTRL+V.
  3. Чтобы перейти от просмотра результатов к просмотру формул, возвращающих эти результаты, нажмите клавиши CTRL+` (апостроф) или на вкладке Формулы в группе Зависимости формул нажмите кнопку Показать формулы.
 
1
2
3
4
5
6
7
8
A
Балл
45
90
78
Формула Описание Результат
=ПРОСМОТР(A2;{0;60;63;67;70;73;77;80;83;87;90;93;97};{"F";"D-";"D";"D+";"C-";"C";"C+";"B-";"B";"B+";"A-";"A";"A+"}) Назначает буквенную категорию первому баллу F
=ПРОСМОТР(A3;{0;60;63;67;70;73;77;80;83;87;90;93;97};{"F";"D-";"D";"D+";"C-";"C";"C+";"B-";"B";"B+";"A-";"A";"A+"}) Назначает буквенную категорию второму баллу A-
=ПРОСМОТР(A4;{0;60;63;67;70;73;77;80;83;87;90;93;97};{"F";"D-";"D";"D+";"C-";"C";"C+";"B-";"B";"B+";"A-";"A";"A+"}) Назначает буквенную категорию третьему баллу C+
 
 
Применимо к:
Excel 2007