CONTAR.SE

Calcula o número de células num intervalo que corresponde aos critérios determinados.

Sintaxe

CONTAR.SE(intervalo;critérios)

Intervalo     é o intervalo de células a partir do qual deseja contar células.

Critério     é o critério na forma de um número, expressão, referência da célula ou texto) que define quais as células que serão contadas. Por exemplo, critérios podem ser expressos como 32, "32", ">;32", "maçãs" ou B4.

Observações

O Microsoft Excel fornece funções adicionais, que podem ser utilizadas para analisar os dados baseados numa condição.

  • Para calcular uma soma baseada num cadeia de texto ou um número num intervalo, utilize a função SOMA.SE da folha de cálculo.
  • Para que uma fórmula devolva um de dois valores baseados numa condição, tais como bónus de vendas baseados num valor de vendas específico, utilize a função SE da folha de cálculo.
  • Para contar células que estão em branco e as que não estão, utilize as funções CONTAR.VAL e CONTAR.VAZIO.

Exemplo 1: Fórmulas CONTAR.SE comuns

O exemplo pode ser mais fácil de perceber se o copiar para uma folha de cálculo em branco.

MostrarComo?

  1. Criar um livro ou folha de cálculo em branco.
  2. Seleccione o exemplo no tópico da ajuda. Não seleccione os cabeçalhos de linha ou coluna. 

Seleccionar um exemplo na Ajuda

Seleccionar um exemplo na Ajuda
  1. Prima CTRL+C
  2. Na folha de cálculo, seleccione a célula A1 e prima CTRL+V.
  3. Para alternar entre a visualização dos resultados e das fórmulas que devolvem os resultados, prima CTRL+` (acento grave) ou, no menu Ferramentas, aponte para Auditoria de fórmulas e, em seguida, clique em Modo de audição da fórmula.
 
1
2
3
4
5
A B
Dados Dados
maçãs 32
laranjas 54
pêssegos 75
maçãs 86
Fórmula Descrição (resultado)
=CONTAR.SE(A2:A5;"maçãs") Número de células com maçãs na primeira coluna acima (2)
=CONTAR.SE(A2:A5,A4) Número de células com pêssegos na primeira coluna acima (2)
=CONTAR.SE(A2:A5,A3)+CONTAR.SE(A2:A5,A2) Número de células com laranjas e maças na primeira coluna acima (3)
=CONTAR.SE(B2:B5;">55") Número de células com um valor superior a 55 na segunda coluna acima (2)
=CONTAR.SE(B2:B5,"<>"&B4) Número de células com um valor não igual a 75 na segunda coluna acima (2)
=CONTAR.SE(B2:B5,">=32")-CONTAR.SE(B2:B5,">85") Número de células com um valor maior que ou igual a 32 e inferior a ou igual a 85 na segunda coluna acima (3)

Exemplo 2: Fórmulas CONTAR.SE utilizando caracteres universais e tratamento de valores em branco

O exemplo pode ser mais fácil de perceber se o copiar para uma folha de cálculo em branco.

MostrarComo?

  1. Criar um livro ou folha de cálculo em branco.
  2. Seleccione o exemplo no tópico da ajuda. Não seleccione os cabeçalhos de linha ou coluna. 

Seleccionar um exemplo na Ajuda

Seleccionar um exemplo na Ajuda
  1. Prima CTRL+C
  2. Na folha de cálculo, seleccione a célula A1 e prima CTRL+V.
  3. Para alternar entre a visualização dos resultados e das fórmulas que devolvem os resultados, prima CTRL+` (acento grave) ou, no menu Ferramentas, aponte para Auditoria de fórmulas e, em seguida, clique em Modo de audição da fórmula.
 
1
2
3
4
5
6
7
A B
Dados Dados
maçãs Sim
   
laranjas Não
pêssegos Não
   
maçãs Sim
Fórmula Descrição (resultado)
=CONTAR.SE(A2:A7,"*es") Número de células que terminam em "les" na primeira coluna acima (4)
=CONTAR.SE(A2:A7,"?????es") Número de células que terminam em "les" com 8 letras exactamente na primeira coluna acima (2)
=CONTAR.SE(A2:A7,"*") Número de células com texto na primeira coluna acima (4)
=CONTAR.SE(A2:A7,"<>"&"*") Número de células sem texto na primeira coluna acima (2)
=CONTAR.SE(B2:B7,"Não") / LINHAS(B2:B7) O número médio de votos "Não" incluindo células em branco na segunda coluna acima formatada em percentagem sem casas decimais (33%)
=CONTAR.SE(B2:B7,"Sim") / (LINHAS(B2:B7) -CONTAR.SE(B2:B7, "<>"&"*")) O número médio de votos "Sim" excluindo células em branco na segunda coluna acima formatada em percentagem sem casas decimais (50%)

 Nota    Para ver o número como percentagem, seleccione a célula e clique em Células no menu Formatar. Clique no separador Número e, em seguida, em Percentagem na caixa Categoria.

 
 
Aplica-se a:
Excel 2003