SOMA

Retorna a soma de todos os números na lista de argumentos.

Sintaxe

SOMA(núm1;núm2; ...)

Núm1, núm2,...  são argumentos de 1 a 30 que se deseja somar.

Comentários

  • Os números, valores lógicos e representações em forma de texto de números digitados diretamente na lista de argumentos são contados. Consulte o primeiro e o segundo exemplos seguintes.
  • Se um argumento for uma matriz ou referência, apenas os números nesta matriz ou referência serão contados. Células vazias, valores lógicos, texto ou valores de erro na matriz ou referência são ignorados. Consulte o terceiro exemplo a seguir.
  • Os argumentos que são valores de erro ou texto que não podem ser traduzidos em números geram erros.

Exemplo

Talvez seja mais fácil compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo?

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda. Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na <b>Ajuda</b>

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, no menu Ferramentas, aponte para Auditoria de fórmulas e clique em Modo de auditoria de fórmulas.
 
1
2
3
4
5
6
A
Dados
-5
15
30
'5
VERDADEIRO
Fórmula Descrição (resultado)
=SOMA(3; 2) Adiciona 3 e 2 (5)
=SOMA("5"; 15; VERDADEIRO) Adiciona 5, 15 e 1, porque os valores de texto são traduzidos em números e o valor lógico VERDADEIRO é traduzido no número 1 (21)
=SOMA(A2:A4) Adiciona os três primeiros números da coluna acima (40)
=SOMA(A2:A4; 15) Adiciona os três primeiros números da coluna acima e 15 (55)
=SOMA(A5;A6; 2) Adiciona os valores das duas últimas linhas acima e 2. Como valores não-numéricos em referências não são traduzidos, os valores na coluna acima são ignorados (2)
 
 
Aplica-se a:
Excel 2003