SEERRO (Função SEERRO)

Este artigo descreve a sintaxe da fórmula e o uso da função SEERRO (função: um fórmula pré-desenvolvida que assume um valor ou vários valores, executa uma operação e retorna um valor ou vários valores. Use as funções para simplificar e reduzir fórmulas em uma planilha, especialmente aquelas que executam cálculos longos e complexos.) no Microsoft Excel.

Descrição

Retorna um valor especificado se uma fórmula gerar um erro; caso contrário, retorna o resultado da fórmula. Use a função SEERRO para capturar e controlar os erros em uma fórmula (fórmula: uma sequência de valores, referências de células, nomes, funções ou operadores em uma célula que juntos produzem um novo valor. Uma fórmula sempre começa com um sinal de igual (=).).

Sintaxe

SEERRO(valor,valor_se_erro)

A sintaxe da função SEERRO tem os seguintes argumentos (argumento: um valor que fornece informações a uma ação, um evento, um método, uma função ou um procedimento.):

  • Valor    Obrigatório. O argumento verificado quanto ao erro.
  • Valor_se_erro    Obrigatório. O valor a ser retornado se a fórmula gerar um erro. Os seguintes tipos de erro são considerados: #N/D, #VALOR!, #REF!, #DIV/0!, #NÚM!, #NOME? ou #NULO!.

Comentários

  • Se valor ou valor_se_erro for uma célula vazia, SEERRO a tratará como um valor de cadeia vazio ("").
  • Se o valor for uma fórmula de matriz, SEERRO retornará uma matriz de resultados para cada célula no intervalo especificado no valor. Consulte o segundo exemplo a seguir.

Exemplos

Exemplo: Ajustando erros de divisão, usando uma fórmula regular

Talvez seja mais fácil entender o exemplo se você copiá-lo em uma planilha em branco.

MostrarComo copiar um exemplo?

  1. Selecione o exemplo neste artigo. Se estiver copiando o exemplo no Excel Online, copie e cole uma célula de cada vez.
    Important: Não selecione os cabeçalhos de linha ou coluna.

Selecionando um exemplo da Ajuda

Selecionando um exemplo da Ajuda

  1. Pressione CTRL+C.
  2. Crie uma pasta de trabalho ou planilha em branco.
  3. Na planilha, selecione a célula A1 e pressione Ctrl+V. Se estiver trabalhando no Excel Online, repita a ação de copiar e colar para cada célula do exemplo.
    Important: Para que o exemplo funcione corretamente, é preciso colá-lo na célula A1 da planilha.
  4. Para alternar entre a visualização de resultados e de fórmulas que retornam tais resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas , clique no botão Exibir Fórmulas.

Depois de copiar o exemplo em uma planilha em branco, você pode adaptá-lo de acordo com as suas necessidades.

 
1
2
3
4
5


6


7


8
A B
Cota Unidades Vendidas
210 35
55 0
23
Fórmula Descrição (resultado)
=SEERRO(A2/B2, "Erro no cálculo") Verifica erros na fórmula no primeiro argumento (divide 210 por 35), não localiza nenhum erro e, em seguida, retorna os resultados da fórmula (6)
=SEERRO(A3/B3, "Erro no cálculo") Verifique erros na fórmula no primeiro argumento (divide 55 por 0), localiza um erro de divisão por 0 e, em seguida, retorna valor_se_erro (Erro no cálculo)
=SEERRO(A4/B4, "Erro no cálculo") Verifica erros na fórmula no primeiro argumento (divide "" por 23), não localiza nenhum erro e, em seguida, retorna os resultados da fórmula (0).

Exemplo: Ajustando erros de divisão, usando uma fórmula de matriz

Talvez seja mais fácil entender o exemplo se você copiá-lo em uma planilha em branco.

MostrarComo copiar um exemplo?

  1. Selecione o exemplo neste artigo. Se estiver copiando o exemplo no Excel Online, copie e cole uma célula de cada vez.
    Important: Não selecione os cabeçalhos de linha ou coluna.

Selecionando um exemplo da Ajuda

Selecionando um exemplo da Ajuda

  1. Pressione CTRL+C.
  2. Crie uma pasta de trabalho ou planilha em branco.
  3. Na planilha, selecione a célula A1 e pressione Ctrl+V. Se estiver trabalhando no Excel Online, repita a ação de copiar e colar para cada célula do exemplo.
    Important: Para que o exemplo funcione corretamente, é preciso colá-lo na célula A1 da planilha.
  4. Para alternar entre a visualização de resultados e de fórmulas que retornam tais resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas , clique no botão Exibir Fórmulas.

Depois de copiar o exemplo em uma planilha em branco, você pode adaptá-lo de acordo com as suas necessidades.

 
1



2
3
4
5



6




7



8
A B C
Cota Unidades Vendidas Proporção
210 35 =SEERRO(A2:A4/B2:B4, "Erro no cálculo")
55 0
23
Fórmula Descrição (resultado)
=C2 Verifica erros na fórmula no primeiro argumento, no primeiro elemento da matriz (A2/B2 ou divide 210 por 35), não localiza nenhum erro e, em seguida, retorna o resultado da fórmula (6)
=C3 Verifique erros na fórmula no primeiro argumento, no segundo elemento da matriz (A3/B3 ou divide 55 por 0), localiza um erro de divisão por 0 e, em seguida, retorna valor_se_erro (Erro no cálculo)
=C4 Verifica erros na fórmula no primeiro argumento, no terceiro elemento da matriz (A4/B4 ou divide "" por 23), não localiza nenhum erro e, em seguida, retorna o resultado da fórmula (0)

 Observação   A fórmula no exemplo precisa ser inserida como uma fórmula de matriz. Após copiar o exemplo em uma planilha em branco, selecione o intervalo C2:C4, pressione F2 e, em seguida, pressione CTRL+SHIFT+ENTER.

 
 
Aplica-se a:
Excel 2010, Excel Web App