SE

Retorna um valor se uma condição que você especificou avaliar como VERDADEIRO e um outro valor se for avaliado como FALSO.

Use SE para efetuear testes condicionais com valores e fórmulas.

Sintaxe

SE(teste_lógico;valor_se_verdadeiro;valor_se_falso)

Teste_lógico     é qualquer valor ou expressão que possa ser avaliado como VERDADEIRO ou FALSO. Por exemplo, A10=100 é uma expressão lógica; se o valor da célula A10 for igual a 100, a expressão será considerada VERDADEIRO. Caso contrário, a expressão será considerada FALSO. Esse argumento pode usar qualquer operador de cálculo de comparação.

Valor_se_verdadeiro     é o valor retornado se teste_lógico for VERDADEIRO. Por exemplo, se esse argumento for a seqüência de caracteres de texto "Dentro do orçamento" e o argumento teste_lógico for considerado VERDADEIRO, a função SE exibirá o texto "Dentro do orçamento". Se teste_lógico for VERDADEIRO e valor_se_verdadeiro for vazio, o argumento retornará 0 (zero). Para exibir a palavra VERDADEIRO, use o valor lógico VERDADEIRO para esse argumento. Valor_se_verdadeiro pode ser outra fórmula.

Valor_se_falso     é o valor retornado se teste_lógico for FALSO. Por exemplo, se esse argumento for a seqüência de caracteres de texto "Acima do orçamento" e o argumento teste_lógico for considerado FALSO, a função SE exibirá o texto "Acima do orçamento". Se teste_lógico for FALSO e valor_se_falso for omitido (ou seja, se não houver vírgula após valor_se_verdadeiro), o valor lógico FALSO será retornado. Se teste_lógico for FALSO e valor_se_falso for vazio (ou seja, se houver uma vírgula após valor_se_verdadeiro seguida do parênteses de fechamento), o valor 0 (zero) será retornado. Valor_se_falso pode ser outra fórmula.

Comentários

Exemplo 1

Talvez seja mais fácil de compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo copiar um exemplo

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda.

 Observação   Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.
 
1
2
A
Dados
50
Fórmula Descrição (resultado)
=SE(A2<=100;"Dentro do orçamento";"Acima do orçamento") Se o número acima for menor ou igual a 100, a fórmula exibirá "Dentro do orçamento". Caso contrário, a função exibirá "Acima do orçamento" (Dentro do orçamento)
=SE(A2=100;SOMA(B5:B15);"") Se o número acima for 100, o intervalo B5:B15 será calculado. Caso contrário, o texto vazio ("") será retornado ()

Exemplo 2

Talvez seja mais fácil de compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo copiar um exemplo

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda.

 Observação   Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.
 
1
2
3
4
A B
Despesas reais Despesas previstas
1500 900
500 900
500 925
Fórmula Descrição (resultado)
=SE(A2>B2;"Acima do orçamento";"OK") Verifica se a primeira linha está acima do orçamento (Acima do orçamento)
=SE(A3>B3;"Acima do orçamento";"OK") Verifica se a segunda linha está acima do orçamento (OK)

Exemplo 3

Talvez seja mais fácil de compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo copiar um exemplo

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda.

 Observação   Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.
 
1
2
3
4
A
Resultado
45
90
78
Fórmula Descrição (resultado)
=SE(A2>89;"A";SE(A2>79;"B"; SE(A2>69;"C";SE(A2>59;"D";"F")))) Atribui uma letra ao primeiro resultado (F)
=SE(A3>89;"A";SE(A3>79;"B"; SE(A3>69;"C";SE(A3>59;"D";"F")))) Atribui uma letra ao segundo resultado (A)
=SE(A4>89;"A";SE(A4>79;"B"; SE(A4>69;"C";SE(A4>59;"D";"F")))) Atribui uma letra ao terceiro resultado (C)

No exemplo anterior, a segunda instrução SE também é o argumento valor_se_falso para a primeira instrução SE. Da mesma maneira, a terceira instrução SE é o argumento valor_se_falso para a segunda instrução SE. Por exemplo, se o primeiro teste_lógico (Média>89) for VERDADEIRO, "A" será retornado. Se o primeiro teste_lógico for FALSO, a segunda instrução SE é avaliada e assim por diante.

As letras são atribuídas a números usando a seguinte chave.

Se Resultado for Então retornará
Maior do que 89 A
De 80 a 89 B
De 70 a 79 C
De 60 a 69 D
Menor do que 60 F

Exemplo 4

Neste exemplo, a função PROC é utilizada no lugar da função SE, pois há treze condições para serem testadas e pode ser mais fácil para ler e manter.

Talvez seja mais fácil de compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo copiar um exemplo

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda.

 Observação   Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.
 
1
2
3
4
A
Resultado
45
90
78
Fórmula Descrição (resultado)
=PROC(A2,{0,60,63,67,70,73,77,80,83,87,90,93,97},{"F","D-","D","D+","C-","C","C+","B-","B","B+","A-","A","A+"}) Atribui uma letra ao primeiro resultado (F)
=PROC(A3,{0,60,63,67,70,73,77,80,83,87,90,93,97},{"F","D-","D","D+","C-","C","C+","B-","B","B+","A-","A","A+"}) Atribui uma letra ao segundo resultado (A-)
=PROC(A4,{0,60,63,67,70,73,77,80,83,87,90,93,97},{"F","D-","D","D+","C-","C","C+","B-","B","B+","A-","A","A+"}) Atribui uma letra ao terceiro resultado (C+)
 
 
Aplica-se a:
Excel 2007