Ocultar valores e indicadores de erro nas células

Suponha que as fórmulas da sua planilha contenham erros que você já sabe e que não precisam de correção, mas você deseja aprimorar a exibição dos resultados. Há várias formas de ocultar os valores de erro e os indicadores nas células.

Há muitas razões para que as fórmulas retornem erros. Por exemplo, a divisão por 0 não é permitida, e se você digitar a fórmula =1/0, ela retornará #DIV/0. Os valores de erro são #DIV/0!, #N/D, #NOME?, #NULO!, #NÚM!, #REF! e #VALOR!.

O que você deseja fazer?


Formatar texto em células que contenham erros de modo que eles não sejam exibidos

  1. Selecione o intervalo de células que contêm o valor de erro.
  2. Na guia Página Inicial, no grupo Estilos, clique na seta ao lado de Formatação Condicional e, em seguida, clique em Gerenciar Regras.

A caixa de diálogo Gerenciador de Regras de Formatação Condicional é exibida.

  1. Clique em Nova regra.

A caixa de diálogo Nova Regra de Formatação será exibida.

  1. Em Selecionar um Tipo de Regra, clique em Usar uma fórmula para determinar quais células devem ser formatadas.
  2. Em Editar a Descrição da Regra, na caixa de listagem Formatar valores nos quais essa fórmula é verdadeira, digite a seguinte fórmula:

=ISERROR(reference)

Em que reference é uma referência relativa à célula que contém o valor de erro.

  1. Clique em Formatar e, em seguida, clique na guia Fonte.
  2. Na caixa Cor, selecione a cor branca.

Início da página Início da página

Exibir um traço, #N/D ou NÃO.DISP no lugar de um valor de erro

Para executar essa tarefa, use as funções SEERRO e ND.

Exemplo

Talvez seja mais fácil entender o exemplo se você copiá-lo em uma planilha em branco.

MostrarComo copiar um exemplo

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda.

 Observação   Não selecione os cabeçalhos da linha ou da coluna.

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.
 
1
2
3
A
Dados
10
0
Fórmula Descrição (Resultado)
=A2/A3 Resultado em um erro (#DIV/0)
=SEERRO(A2/A3,"NA") Retorna NÃO.DISP quando o valor é um erro
=SEERRO(A2/A3,"-") Retorna um traço quando o valor é um erro
=SEERRO(A2/A3,NA()) Retorna #N/D quando o valor é um erro

Detalhes da função

SEERRO

NÃO.DISP

Início da página Início da página

Ocultar valores de erro em um relatório de tabela dinâmica

  1. Clique no relatório de tabela dinâmica.
  2. Na guia Opções, no grupo Opções de Tabela Dinâmica, clique na seta ao lado de Opções e, em seguida, clique em Opções.
  1. Clique na guia Layout e Formatação e, em seguida execute um ou mais dos procedimentos a seguir:

Altere a exibição de erro        Marque a caixa de seleção Para valores de erro, mostrar em Formatar. Na caixa, digite o valor que você deseja exibir no lugar de erros. Para exibir erros como células vazias, exclua os caracteres da caixa.

Altere a exibição de célula vazia        Marque a caixa de seleção Para células vazias, mostrar. Na caixa, digite o valor que você deseja exibir em células vazias. Para exibir células vazias, exclua os caracteres da caixa. Para exibir zeros, desmarque a caixa de seleção.

Início da página Início da página

Ocultar indicadores de erro em células

Se uma célula contiver uma fórmula que viole uma das regras, aparecerá um triângulo no canto superior esquerdo da célula. Você pode impedir que esses indicadores sejam exibidos.


Célula com um problema de fórmula

Célula com um problema de fórmula

  1. Clique no Botão Microsoft Office Imagem do botão, clique em Opções do Excel, e, em seguida, clique na categoria Fórmulas.
  1. Em Verificação de Erros, desmarque a caixa de seleção Ativar verificação de erro em segundo plano.

Início da página Início da página

 
 
Aplica-se a:
Excel 2007