Função E

Este artigo descreve a sintaxe da fórmula e o uso da função (função: um fórmula pré-desenvolvida que assume um valor ou vários valores, executa uma operação e retorna um valor ou vários valores. Use as funções para simplificar e reduzir fórmulas em uma planilha, especialmente aquelas que executam cálculos longos e complexos.) E no Microsoft Office Excel.

Descrição

Retornará VERDADEIRO se todos os seus argumentos forem avaliados como VERDADEIRO e retornará FALSO se um ou mais argumentos forem avaliados como FALSO.

Um uso comum para a função E é expandir a utilidade de outras funções que realizam testes lógicos. Por exemplo, a função SE realiza um teste lógico e, em seguida, retornará um valor se o teste for avaliado como VERDADEIRO e outro valor se o teste for avaliado como FALSO. Usando a função E como argumento teste_lógico da função SE, você pode testar várias condições diferentes em vez de apenas uma.

Sintaxe

E(lógico1, [lógico2], ...)

A sintaxe da função E tem os seguintes argumentos (argumento: um valor que fornece informações a uma ação, um evento, um método, uma função ou um procedimento.):

  • lógico1    Necessário. A primeira condição que você deseja testar que pode ser avaliada como VERDADEIRO ou FALSO.
  • lógico2, ...    Opcional. Condições adicionais que você deseja testar que pode ser avaliada como VERDADEIRO ou FALSO, até um máximo de 255 condições.

Comentários

Exemplo 1

Talvez seja mais fácil entender o exemplo se você copiá-lo em uma planilha em branco.

MostrarComo copiar um exemplo?

  1. Selecione o exemplo deste artigo. Se estiver copiando o exemplo no Excel Web App, copie e cole uma célula de cada vez.

 Importante   Não selecione os cabeçalhos de linha ou de coluna.

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Crie uma pasta de trabalho ou planilha em branco.
  3. Na planilha, selecione a célula A1 e pressione CTRL+V. Se estiver trabalhando no Excel Web App, repita a ação de copiar e colar para cada célula do exemplo.

 Importante   Para que o exemplo funcione corretamente, é preciso colá-lo na célula A1 da planilha.

  1. Para alternar entre a exibição de resultados e a exibição das fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.

Depois de copiar o exemplo em uma planilha em branco, você poderá adaptá-lo às suas necessidades.


 
1
2
3
4
A B C
Fórmula Descrição Resultado
=E(VERDADEIRO, VERDADEIRO) Todos os argumentos são VERDADEIRO VERDADEIRO
=E(VERDADEIRO, FALSO) Um argumento é FALSO FALSO
=E(2+2=4, 2+3=5) Todos os argumentos são avaliados como VERDADEIRO VERDADEIRO

Exemplo 2

Talvez seja mais fácil entender o exemplo se você copiá-lo em uma planilha em branco.

MostrarComo copiar um exemplo?

  1. Selecione o exemplo deste artigo. Se estiver copiando o exemplo no Excel Web App, copie e cole uma célula de cada vez.

 Importante   Não selecione os cabeçalhos de linha ou de coluna.

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Crie uma pasta de trabalho ou planilha em branco.
  3. Na planilha, selecione a célula A1 e pressione CTRL+V. Se estiver trabalhando no Excel Web App, repita a ação de copiar e colar para cada célula do exemplo.

 Importante   Para que o exemplo funcione corretamente, é preciso colá-lo na célula A1 da planilha.

  1. Para alternar entre a exibição de resultados e a exibição das fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.

Depois de copiar o exemplo em uma planilha em branco, você poderá adaptá-lo às suas necessidades.


 
1
2
3
4


5




6



7
A B C
Dados
50
104
Fórmula Descrição Resultado
=E(1<A2, A2<100) Exibirá VERDADEIRO se o número na célula A2 estiver entre 1 e 100. Caso contrário, exibirá FALSO. VERDADEIRO
=SE(E(1<A3;A3<100); A3; "O valor está fora do intervalo.") Exibirá o número na célula A3, se estiver entre 1 e 100. Caso contrário, exibirá a mensagem "O valor está fora do intervalo". O valor está fora do intervalo.
=SE(E(1<A2; A2<100); A2; "O valor está fora do intervalo.") Exibirá o número na célula A2, se estiver entre 1 e 100. Caso contrário, exibirá uma mensagem. 50
 
 
Aplica-se a:
Excel 2007