Função CONT.SES

Este artigo descreve a sintaxe da fórmula e o uso da função (função: um fórmula pré-desenvolvida que assume um valor ou vários valores, executa uma operação e retorna um valor ou vários valores. Use as funções para simplificar e reduzir fórmulas em uma planilha, especialmente aquelas que executam cálculos longos e complexos.)CONT.SES no Microsoft Office Excel.

Descrição

Aplica critérios a células em vários intervalos e conta o número de vezes que todos os critérios são atendidos.

Sintaxe

CONT.SES(intervalo_critérios1, critérios1, [intervalo_critérios2, critérios2]…)

A sintaxe da função CONT.SES tem os seguintes argumentos (argumento: um valor que fornece informações a uma ação, um evento, um método, uma função ou um procedimento.):

  • intervalo_critérios1    Necessário. O primeiro intervalo no qual avaliar os critérios associados.
  • critérios1    Necessário. Os critérios no formato de um número, uma expressão, uma referência de célula ou um texto que define quais células serão contadas. Por exemplo, os critérios podem ser expressos como 32, ">32", B4, "maçãs" ou "32".
  • intervalo_critérios2, critérios2, ...    Opcional. Intervalos adicionais e seus critérios associados. Até 127 intervalo/critérios pares são permitidos.

 Importante   Cada intervalo adicional deve ter o mesmo número de linhas e colunas que o argumento intervalo_critérios1. Os intervalos não precisam ser adjacentes entre si.

Comentários

  • Os critérios de cada intervalo são aplicados a uma célula de cada vez. Se todas as primeiras células atenderem aos seus critérios associados, a contagem aumentará em 1. Se todas as segundas células atenderem aos seus critérios associados, a contagem aumentará em 1 novamente e assim por diante até que todas as células sejam avaliadas.
  • Se o argumento de critérios for uma referência a uma célula vazia, a função CONT.SES tratará essa célula vazia como um valor 0.
  • Você pode usar os caracteres curinga — o ponto de interrogação (?) e o asterisco (*)  — nos critérios. Um ponto de interrogação corresponde qualquer caractere simples, enquanto um asterisco corresponde qualquer seqüência de caracteres. Se você quiser encontrar um ponto de interrogação ou asterisco real, digite um til (~) antes do caractere.

Exemplo 1

Talvez seja mais fácil entender o exemplo se você copiá-lo em uma planilha em branco.

MostrarComo copiar um exemplo?

  1. Selecione o exemplo deste artigo. Se estiver copiando o exemplo no Excel Web App, copie e cole uma célula de cada vez.

 Importante   Não selecione os cabeçalhos de linha ou de coluna.

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Crie uma pasta de trabalho ou planilha em branco.
  3. Na planilha, selecione a célula A1 e pressione CTRL+V. Se estiver trabalhando no Excel Web App, repita a ação de copiar e colar para cada célula do exemplo.

 Importante   Para que o exemplo funcione corretamente, é preciso colá-lo na célula A1 da planilha.

  1. Para alternar entre a exibição de resultados e a exibição das fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.

Depois de copiar o exemplo em uma planilha em branco, você poderá adaptá-lo às suas necessidades.


 


1
2
3
4
5
6



7


8



9
A B C D
Vendedor Quota de Acessórios Ultrapassada Quota de Dispositivos Ultrapassada Quota de Apetrechos Ultrapassada
Andrade Sim Não Não
Barreto Sim Sim Não
Gambaro Sim Sim Sim
Nuno Não Sim Sim
Fórmula Descrição Resultado
=CONT.SES(B2:D2,"=Sim") Conta quantas vezes Andrade excedeu uma cota de vendas para Acessórios, Dispositivos e Apetrechos. 1
=CONT.SES(B2:B5,"=Sim",C2:C5,"=Sim") Conta quantas pessoas ultrapassaram suas Quotas de Acessórios e Dispositivos. 2
=CONT.SES(B5:D5,"=Sim",B3:D3,"=Sim") Conta quantas vezes Nuno e Barreto excederam a mesma cota para Acessórios, Dispositivos e Apetrechos. 1

Exemplo 2

Talvez seja mais fácil entender o exemplo se você copiá-lo em uma planilha em branco.

MostrarComo copiar um exemplo?

  1. Selecione o exemplo deste artigo. Se estiver copiando o exemplo no Excel Web App, copie e cole uma célula de cada vez.

 Importante   Não selecione os cabeçalhos de linha ou de coluna.

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Crie uma pasta de trabalho ou planilha em branco.
  3. Na planilha, selecione a célula A1 e pressione CTRL+V. Se estiver trabalhando no Excel Web App, repita a ação de copiar e colar para cada célula do exemplo.

 Importante   Para que o exemplo funcione corretamente, é preciso colá-lo na célula A1 da planilha.

  1. Para alternar entre a exibição de resultados e a exibição das fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.

Depois de copiar o exemplo em uma planilha em branco, você poderá adaptá-lo às suas necessidades.


 
1
2
3
4
5
6
7
8


9




10


11
A B C
Dados Dados
1 5/1/2008
2 5/2/2008
3 5/3/2008
4 5/4/2008
5 5/5/2008
6 5/6/2008
Fórmula Descrição Resultado
=CONT.SES(A2:A7,"<6",A2:A7,">1") Conta quantos números entre 1 e 6 (sem incluir 1 e 6) estão contidos nas células entre A2 e A7. 4
=CONT.SES(A2:A7, "<5",B2:B7,"<5/3/2008") Conta quantas linhas têm números menores do que 5 nas células entre A2 a A7 e também têm datas anteriores a 5/3/2008 nas células entre B2 e B7. 2
=CONT.SES(A2:A7, "<" & A6,B2:B7,"<" & B4) Mesma descrição que o exemplo anterior, mas usando referências de célula no lugar de constantes nos critérios. 2
 
 
Aplica-se a:
Excel 2007