Exibir ou ocultar valores nulos

Talvez você tenha uma preferência pessoal para a exibição de valores iguais a zero em uma célula ou você pode estar usando uma planilha que segue um conjunto de padrões de formatos que exigem a ocultação de valores iguais a zero. Há várias maneiras de exibir ou ocultar valores iguais a zero.

O que você deseja fazer?


Exibir ou ocultar todos os valores zero em uma planilha

  1. Clique no Botão Microsoft Office Imagem do botão, clique em Opções do Excel, e, em seguida, clique na categoria Avançado.
  1. Em Exibir opções para esta planilha, selecione uma planilha e siga um destes procedimentos:
    • Para exibir valores zero (0) nas células, marque a caixa de seleção Mostrar um zero nas células cujo valor é zero.
    • Para exibir valores zero (0) como células vazias, desmarque a caixa de seleção Mostrar um zero nas células cujo valor é zero.

Início da página Início da página

Usar um formato de número para ocultar valores zero em células selecionadas

Siga este procedimento para ocultar valores zero em células selecionadas. Se o valor de uma dessas células for alterado para um valor diferente de zero, o formato do valor será semelhante ao formato de número geral.

  1. Selecione as células que contêm os valores zero (0) que você deseja ocultar.
  2. Na guia Página Inicial, no grupo Células, clique em Formatar e, em seguida, clique em Formatar Células.
  1. Na lista Categoria, clique em Personalizada.
  2. Na caixa Tipo, digite 0;-0;;@

 Observações 

  • Os valores ocultos aparecem somente na barra de fórmulas Barra de fórmulas  — ou em uma célula se você editar dentro da célula — e não são impressos.
  • Na guia Página Inicial, no grupo Células, clique em Formatar e, em seguida, clique em Formatar Células.
  • Para exibir os valores ocultos novamente, selecione as células e, em seguida, na guia Início, no grupo Células, aponte para Formatar e clique em Formatar Células. Na lista Categoria, clique em Geral para aplicar o formato de número padrão. Para reexibir uma data ou hora, selecione o formato de data ou hora apropriado na guia Número.

Início da página Início da página

Usar um formato condicional para ocultar valores zero retornados por uma fórmula

  1. Selecione a célula que contém o valor zero (0).
  2. Na guia Página Inicial, no grupo Estilos, clique na seta ao lado de Formatação Condicional, aponte para Realçar Regras das Células e, em seguida, clique em Igual a.
  1. Na caixa à esquerda, digite 0.
  2. Na caixa à direita, selecione Formato Personalizado.
  3. Na caixa de diálogo Formatar Células, clique na guia Fonte.
  4. Na caixa Cor, selecione a cor branca.

Início da página Início da página

Usar uma fórmula para exibir zeros como vazios ou traços

Para executar essa tarefa, use a função SE.

Exemplo

Talvez seja mais fácil de compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo copiar um exemplo?

  1. Selecione o exemplo deste artigo. Se estiver copiando o exemplo no Excel Web App, copie e cole uma célula de cada vez.

 Importante   Não selecione os cabeçalhos de linha ou de coluna.

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Crie uma pasta de trabalho ou planilha em branco.
  3. Na planilha, selecione a célula A1 e pressione CTRL+V. Se estiver trabalhando no Excel Web App, repita a ação de copiar e colar para cada célula do exemplo.

 Importante   Para que o exemplo funcione corretamente, é preciso colá-lo na célula A1 da planilha.

  1. Para alternar entre a exibição de resultados e a exibição das fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.

Depois de copiar o exemplo em uma planilha em branco, você poderá adaptá-lo às suas necessidades.


 
1
2
3
4
5

6
7
A B
Dados
10
10
Fórmula Descrição (Resultado)
=A2-A3 O segundo número subtraído do primeiro (0)
=SE(A2-A3=0;"";A2-A3) Retorna uma célula em branco quando o valor é zero (célula vazia)
=SE(A2-A3=0,"-",A2-A3 Retorna um traço quando o valor é zero (-)

Para obter mais informações sobre como usar essa função, consulte Função SE.

Início da página Início da página

Ocultar valores zero em um relatório de tabela dinâmica

  1. Clique no relatório de tabela dinâmica.
  2. Na guia Opções, no grupo Opções de Tabela Dinâmica, clique na seta ao lado de Opções e, em seguida, clique em Opções.
  1. Clique na guia Layout e Formato e, em seguida, siga um destes procedimentos:

Altere a exibição de erro        Marque a caixa de seleção Para valores de erro, mostrar em Formatar. Na caixa, digite o valor que você deseja exibir no lugar de erros. Para exibir erros como células vazias, exclua os caracteres da caixa.

Altere a exibição de célula vazia     Marque a caixa de seleção Para células vazias, mostrar. Na caixa, digite o valor que deseja exibir em células vazias. Para exibir células vazias, exclua os caracteres da caixa. Para exibir zeros, desmarque a caixa de seleção.

Início da página Início da página

 
 
Aplica-se a:
Excel 2007