Criar fórmulas condicionais

Testar se condições são verdadeiras ou falsas e fazer comparações lógicas entre expressões são ações comuns a várias tarefas. Você pode usar as funções E, OU, NÃO e SE para criar fórmulas condicionais.

A função SE utiliza os seguintes argumentos:


Fórmula com a função SE

Fórmula com a função SE

Texto explicativo 1  teste_lógico: a condição a ser verificada.

Texto explicativo 2  valor_se_verdadeiro: o valor a ser retornado se a condição for verdadeira.

Texto explicativo 3  valor_se_falso: o valor a ser retornado se a condição for falsa.


O que você deseja fazer?


Criar uma fórmula condicional que resulte em um valor lógico (VERDADEIRO ou FALSO)

Para executar essa tarefa, use as funções E, OU, NÃO e operadores (operador: um sinal ou símbolo que especifica o tipo de cálculo a ser executado dentro de uma expressão. Existem operadores matemáticos, de comparação, lógicos e de referência.).

Exemplo

Talvez seja mais fácil compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo copiar um exemplo

  1. Crie uma pasta de trabalho ou uma planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda.

 Observação   Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de fórmulas, clique no botão Mostrar fórmulas.
 
1
2
3
4
A
Dados
15
9
8
Rodas dentadas
Acessórios
Fórmula Descrição (resultado)
=E(A2>A3; A2<A4) 15 é maior que 9 e menor que 8? (FALSO)
=OU(A2>A3; A2<A4) 15 é maior que 9 ou menor que 8? (VERDADEIRO)
=NÃO(A2+A3=24) 15 mais 9 não é igual a 24? (FALSO)
=NÃO(A5="Rodas dentadas") A5 não é igual a "Rodas dentadas"? (FALSO)
=OU(A5<>"Rodas dentadas";A6 = "Acessórios") A5 não é igual a "Rodas dentadas" ou A6 é igual a "Acessórios"? (VERDADEIRO)

Detalhes da função

E

OU

NÃO

Início da página Início da página

Criar uma fórmula condicional que resulte em outro cálculo ou em valores diferentes de VERDADEIRO ou FALSO

Para executar essa tarefa, use as funções SE, PROCURAR e ÉNÚM.

Exemplo

Talvez seja mais fácil compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo copiar um exemplo

  1. Crie uma pasta de trabalho ou uma planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda.

 Observação   Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de fórmulas, clique no botão Mostrar fórmulas.
 
1
2
3
4
A
Dados
15
9
8
Rodas dentadas
Acessórios
Fórmula Descrição (resultado)
=SE(A2=15; "OK"; "Não OK") Se o valor na célula A2 for igual a 15, retornar "OK". (OK)
=SeA2<>15;"OK";"Não OK") Se o valor na célula A2 não for igual a 15, retornar "OK". (Não OK)
=SE(NÃO(A2<=15); "OK"; "Não OK") Se o valor na célula A2 não for menor ou igual a 15, retornar "OK". (Não OK)
=SE(A5<>"RODAS DENTADAS"; "OK"; "Não OK") Se o valor na célula A5 não for igual a "RODAS DENTADAS", retornar "OK". (Não OK)
=SE(E(A2>A3; A2<A4); "OK"; "Não OK") Se 15 for maior que 9 e menor que 8, retornar "OK". (Não OK)
=SE(E(A2<>A3; A2<>A4); "OK"; "Não OK") Se 15 não for igual a 9 e 15 não for igual a 8, retornar "OK". (OK)
=SE(OU(A2>A3; A2<A4); "OK"; "Não OK") Se 15 for maior que 9 ou menor que 8, retornar "OK". (OK)
=SE(OU(A5<>"Rodas dentadas"; A6<>"Acessórios"); "OK"; "Não OK") Se o valor na célula A5 não for igual a "Rodas dentadas" ou o valor na célula A6 não for igual a "Acessórios", retornar "OK". (Não OK)
=SE(OU(A2<>A3; A2<>A4); "OK"; "Não OK") Se 15 não for igual a 9 ou 15 não for igual a 8, retornar "OK". (OK)

Detalhes da função

SE

E

OU

Início da página Início da página

 
 
Aplica-se a:
Excel 2007