Converter horas

Suponhamos que você queira descobrir quantas horas há em cinco dias e meio, ou quantos dias há em 3,45 anos, ou quantos meses se passaram entre uma data inicial e uma data final. Existem várias maneiras de converter horas.

O que você deseja fazer?


Converter entre unidades de hora

Para executar esta tarefa, utilize a função CONVERTER.

Exemplo

Talvez seja mais fácil de compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo copiar um exemplo

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda.

 Observação   Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas e clique no botão Mostrar Fórmulas.
 
1
2
A
Dados
6
Fórmula Descrição (resultado)
=CONVERTER(A2,"dia","hora") Converter 6 dias em horas (144)
=CONVERTER(A2,"hora","min") Converter 6 horas em minutos (360)
=CONVERTER(A2,"ano", "dia") Converter 6 anos em dias (2.191,5)

 Observação   Para conversões usando ano, um ano é tratado como 365,25 dias.

Detalhes da função

CONVERTER

Início da página Início da página

Converter horas do formato de hora oficial (horas : minutos : segundos) em um número decimal

Para executar esta tarefa, utilize a função INT.

Exemplo

Talvez seja mais fácil de compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo copiar um exemplo

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda.

 Observação   Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas e clique no botão Mostrar Fórmulas.
 
1
2
3
A
Hora
10:35:00
00:15
Fórmula Descrição (resultado)
=(A2-INT(A2))*24 Número de horas desde 12:00 (10,583333)
=(A3-INT(A3))*24 Número de horas desde 12:00 (12,25)

Detalhes da função

INT

Início da página Início da página

Converter horas de número decimal para o formato de hora oficial (horas : minutos : segundos)

Para executar esta tarefa, use o operador de divisão (/) e a função TEXTO para executar esta função.

Exemplo

Talvez seja mais fácil de compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo copiar um exemplo

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda.

 Observação   Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas e clique no botão Mostrar Fórmulas.
 
1
2
3
A
Horas
10,5833
12,25
Fórmula Descrição (resultado)
=TEXTO(A2/24; "h:mm") Horas desde 12:00 (10:35:00)
=TEXTO(A3/24; "h:mm") Horas desde 12:00 (12:15)

 Observação   Você também pode aplicar o formato de hora sem usar a função TEXTO para especificá-lo. Para visualizar o número como hora, selecione a célula e na guia Início, no grupo Número, clique na seta ao lado da caixa Formato de Número, clique em Mais Formatos de Número, clique Personalizar na lista Categoria e, em seguida, clique em um formato de personalizado na caixa Tipo. Entretanto, se você usar tanto um formato aplicado com a função TEXTO como um formato numérico, a função TEXTO terá preferência.

Detalhes da função

TEXTO

Início da página Início da página

 
 
Aplica-se a:
Excel 2007