Converter horas

MostrarConverter entre unidades de hora

Use a função CONVERTER para executar esta tarefa.

Se essa função não estiver disponível, instale e carregue o suplemento Ferramentas de análise.

MostrarComo?

  1. No menu Ferramentas, clique em Suplementos.
  2. Na lista Suplementos disponíveis, selecione a caixa Ferramentas de análise e clique em OK.
  3. Se necessário, siga as instruções da instalação.

Exemplo de planilha

Talvez seja mais fácil de compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo?

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda. Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na <b>Ajuda</b>

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, no menu Ferramentas, aponte para Auditoria de fórmulas e clique em Modo de auditoria de fórmulas.
 
1
2
A
Dados
6
Fórmula Descrição (resultado)
=CONVERTER(A2,"dia","hora") Converter 6 dias em horas (144)
=CONVERTER(A2,"hora","min") Converter 6 horas em minutos (360)
=CONVERTER(A2,"ano", "dia") Converter 6 anos em dias (2191,5)

 Observação   Para conversões usando ano, um ano é tratado como 365,25 dias.

Detalhes da função

CONVERTER

MostrarConverter horas do formato de hora oficial (horas : minutos : segundos) em um número decimal

Use a função INT para executar esta tarefa.

Exemplo de planilha

Talvez seja mais fácil de compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo?

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda. Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na <b>Ajuda</b>

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, no menu Ferramentas, aponte para Auditoria de fórmulas e clique em Modo de auditoria de fórmulas.
 
1
2
3
A
Hora
10:35
00:15
Fórmula Descrição (resultado)
=(A2-INT(A2))*24 Número de horas desde 12:00 (10,583333)
=(A3-INT(A3))*24 Número de horas desde 12:00 (12,25)

Detalhes da função

INT

MostrarConverter horas de número decimal para o formato de hora oficial (horas : minutos : segundos)

Use o operador de divisão (/) e a função TEXTO para executar esta função.

Exemplo de planilha

Talvez seja mais fácil de compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo?

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda. Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na <b>Ajuda</b>

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, no menu Ferramentas, aponte para Auditoria de fórmulas e clique em Modo de auditoria de fórmulas.
 
1
2
3
A
Horas
10,5833
12,25
Fórmula Descrição (resultado)
=TEXTO(A2/24; "h:mm") Horas desde 12:00 (10:35)
=TEXTO(A3/24; "h:mm") Horas desde 12:00 (12:15)

 Observação   Você também pode aplicar o formato numérico de hora sem usar a função TEXTO para especificar o formato. Para exibir o número como uma hora, selecione a célula e clique em Células no menu Formatar. Clique na guia Número e, em seguida, clique em Hora na caixa Categoria. Entretanto, se você usar tanto um formato aplicado com a função TEXTO como um formato numérico, a função TEXTO terá preferência.

Detalhes da função

TEXTO

 
 
Aplica-se a:
Excel 2003