Contar com que freqüência um valor ocorre

Suponha que você deseje descobrir quantas vezes um texto específico ou um valor numérico ocorre. Por exemplo:

  • Se um intervalo contiver os valores numéricos 5, 6, 7 e 6, o número 6 ocorrerá, portanto, duas vezes.
  • Se uma coluna contiver "Cardoso", "Couto", "Couto" e "Couto", "Couto" ocorrerá, portanto, três vezes.

Há várias maneiras de contar com que freqüência um valor ocorre.

O que você deseja fazer?


Contar com que freqüência um único valor ocorre usando uma função

Use a função CONT.SE para executar esta tarefa.

Exemplo

Talvez seja mais fácil compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo copiar um exemplo

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda.

 Observação   Não selecione os cabeçalhos de linha ou de coluna.

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.
 
1
2
3
4
5
6
7
A B
Vendedor Fatura
Cardoso 15.000
Cardoso 9.000
Ruivo 8.000
Ruivo 20.000
Cardoso 5.000
Couto 22.500
Fórmula Descrição (Resultado)
=CONT.SE(A2:A7,"Cardoso") Número de entradas para Cardoso (3)
=CONT.SE(A2:A7,A4) Número de entradas para Ruivo (2)
=CONT.SE(B2:B7,"< 20000") Número de valores de fatura menores que 20.000 (4)
=CONT.SE(B2:B7,">="&B5) Número de valores de fatura maiores ou iguais a 20.000 (2)

Detalhes da função

CONT.SE

Início da página Início da página

Contar com que freqüência vários valores numéricos ocorrem usando funções

Suponha que você precise determinar quantos vendedores venderam um item específico em uma certa região, ou que deseje saber quantas vendas acima de um determinado valor foram feitas por um vendedor específico. Você pode usar as funções SE e CONTA.

Exemplo

Talvez seja mais fácil compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo copiar um exemplo

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda.

 Observação   Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.
 
1
2
3
4
5
6
7
8
9
10
11
A B C D
Região Vendedor Tipo Vendas
Sul Cardoso Bebidas 3.571
Oeste Ribeiro Laticínios 3.338
Leste Ruivo Bebidas 5.122
Norte Ruivo Laticínios 6.239
Sul Couto Produção 8.677
Sul Ribeiro Carne 450
Sul Ribeiro Carne 7.673
Leste Ruivo Produção 664
Norte Ribeiro Produção 1.500
Sul Couto Carne 6.596
Fórmula Descrição (resultado)
=CONTA(SE((A2:A11="Sul")*(C2:C11="Carne"),D2:D11)) Número de vendedores que venderam carne na região Sul (3)
=CONTA(SE((B2:B11="Ruivo")*(D2:D11=1000),D2:D11)) Número de vendas maiores do que 1.000 feitas por Ruivo (2)

 Observações 

Detalhes da função

CONT.NÚM

SE

Início da página Início da página

Contar com que freqüência vários textos ou valores numéricos ocorrem usando funções

Use as funções SE e SOMA para executar esta tarefa.

  • Atribua um valor igual a 1 para cada condição verdadeira usando a função SE.
  • Calcule o total, usando a função SOMA.

Exemplo

Talvez seja mais fácil compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo copiar um exemplo

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda.

 Observação   Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.
 
1
2
3
4
5
6
7
A B
Vendedor Fatura
Cardoso 15.000
Cardoso 9.000
Ruivo 8.000
Ruivo 20.000
Cardoso 5.000
Couto 22.500
Fórmula Descrição (Resultado)
=SOMA(SE((A2:A7="Cardoso")+(A2:A7="Couto"),1,0)) Número de faturas de Cardoso ou Couto (4)
=SOMA(SE((B2:B7<9000)+(B2:B7>19000),1,0)) Número de faturas com valores menores que 9.000 ou maiores que 19.000 (4)
=SOMA(SE(A2:A7="Cardoso",SE(B2:B7<9000,1,0))) Número de faturas de Cardoso com valor menor que 9.000 (1)

 Observação   As fórmulas contidas neste exemplo devem ser inseridas como fórmulas de matriz (fórmula de matriz: uma fórmula que executa vários cálculos em um ou mais conjuntos de valores e retorna um único resultado ou vários resultados. As fórmulas de matriz ficam entre chaves { } e são inseridas pressionando-se CTRL+SHIFT+ENTER.). Selecione cada célula que contém uma fórmula, pressione F2 e, em seguida, pressione CTRL+SHIFT+ENTER.

Detalhes da função

SE

SOMA

Início da página Início da página

Contar com que freqüência vários valores ocorrem usando um relatório de tabela dinâmica

Você pode usar um relatório de tabela dinâmica para exibir totais e contar as ocorrências de valores únicos.

  1. Selecione a coluna que contém os dados. Verifique se a coluna tem um título.
  2. Na guia Inserir, no grupo Tabelas, clique em Tabela Dinâmica.
  1. A caixa de diálogo Criar Tabela Dinâmica será exibida.
  2. Clique em Selecione uma tabela ou um intervalo.
  3. Coloque o relatório de tabela dinâmica em uma nova planilha iniciando na célula A1 clicando em Nova Planilha.
  4. Clique em OK.

Um relatório de tabela dinâmica vazio será adicionado ao local especificado exibindo a lista de campos da Tabela Dinâmica.

  1. Na seção de campos na parte superior da lista de campos da Tabela Dinâmica, clique e mantenha pressionado o nome do campo e, em seguida, arraste o campo para a caixa Rótulos de Linha na seção de layout da parte inferior da lista de campos da Tabela Dinâmica.
  2. Na seção de campos, na parte superior da lista de campos da Tabela Dinâmica, clique e mantenha pressionado o mesmo nome de campo e, em seguida, arraste o campo novamente para a caixa Valores na seção de layout da parte inferior da Lista de Campos da Tabela Dinâmica.

 Observação   Se os seus dados contiverem números, o relatório de tabela dinâmica somará as entradas em vez de contá-las. Para mudar da função resumo Soma para a função resumo ContNúm, selecione uma célula naquela coluna e, em seguida, na guia Opções do grupo Ativar Campo, clique em Configurações do Campo, clique na guia Resumir por, clique em ContNúm e em OK.

Início da página Início da página

 
 
Aplica-se a:
Excel 2007