CONT.SE

Calcula o número de células não vazias em um intervalo que corresponde a determinados critérios.

Sintaxe

CONT.SE(intervalo;critérios)

Intervalo     é o intervalo de células do qual se deseja contar células não vazias.

Critérios     é o critério na forma de um número, expressão, referência de célula ou texto que define quais células serão contadas. Por exemplo, os critérios podem ser expressos como 32, "32", ">32", "maçãs" ou B4.

Comentários

O Microsoft Excel oferece funções adicionais que podem ser usadas para analisar os dados com base em uma condição.

  • Para calcular uma soma com base em uma seqüência ou um número dentro de um intervalo, use a função de pasta de trabalho SOMASE.
  • Para que a fórmula retorne um de dois valores com base em uma condição, como uma bonificação de vendas com base em um valor de vendas especificado, use a função de planilha SE.
  • Para contar as células vazias ou não, use as funções CONT.VALORES e CONTAR.VAZIO.

Exemplo 1: Fórmulas CONT.SE comuns

Talvez seja mais fácil entender o exemplo se você copiá-lo em uma planilha em branco.

MostrarComo?

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda. Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, no menu Ferramentas, aponte para Auditoria de Fórmulas e clique em Modo de Auditoria de Fórmulas.
 
1
2
3
4
5
A B
Dados Dados
maçãs 32
laranjas 54
pêssegos 75
maçãs 86
Fórmula Descrição (resultado)
=CONT.SE(A2:A5;"maçãs") O número de células com maçãs na primeira coluna acima (2)
=CONT.SE(A2:A5,A4) O número de células com pêssegos na primeira coluna acima (2)
=CONT.SE(A2:A5,A3)+CONT.SE(A2:A5,A2) O número de células com laranjas e maçãs na primeira coluna acima (3)
=CONT.SE(B2:B5;">55") O número de células com um valor maior que 55 na segunda coluna acima (2)
=CONT.SE(B2:B5,"<>"&B4) O número de células com um valor diferente de 75 na segunda coluna acima (2)
=CONT.SE(B2:B5,">=32")-CONT.SE(B2:B5,">85") O número de células com um valor maior ou igual a 32 e menor ou igual a 85 na segunda coluna acima (3)

Exemplo 2: Fórmulas CONT.SE usando caracteres curinga e manipulando valores em branco

Talvez seja mais fácil entender o exemplo se você copiá-lo em uma planilha em branco.

MostrarComo?

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda. Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na Ajuda

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, no menu Ferramentas, aponte para Auditoria de Fórmulas e clique em Modo de Auditoria de Fórmulas.
 
1
2
3
4
5
6
7
A B
Dados Dados
maçãs Sim
   
laranjas NÃO
pêssegos Não
   
maçãs Sim
Fórmula Descrição (resultado)
=CONT.SE(A2:A7,"*es") O número de células terminadas com as letras "çãs" na primeira coluna acima (4)
=CONT.SE(A2:A7,"?????es") O número de células terminando com as letras "çãs" e com exatamente 8 letras na primeira coluna acima (2)
=CONT.SE(A2:A7,"*") O número de células que contêm texto na primeira coluna acima (4)
=CONT.SE(A2:A7,"<>"&"*") O número de células que não contém texto na primeira coluna acima (2)
=CONT.SE(B2:B7,"Não") / LINHAS(B2:B7) O número médio de votos "Não" incluindo as células em branco na segunda coluna acima formatada como uma porcentagem sem nenhuma casa decimal (33%)
=CONT.SE(B2:B7,"Sim") / (LINHAS(B2:B7) -CONT.SE(B2:B7, "<>"&"*")) O número médio de votos "Sim" excluindo as células em branco na segunda coluna acima formatada como uma porcentagem sem nenhuma casa decimal (50%)

 Observação    Para exibir o número como uma porcentagem, selecione a célula e clique em Células no menu Formatar. Clique na guia Número e em Porcentagem na caixa Categoria.

 
 
Aplica-se a:
Excel 2003