Calcular a média de números

A média também é chamada de termo-médio.

MostrarCalcular a média de números em uma linha ou coluna contígua

  1. Clique em uma célula abaixo ou à direita dos números para os quais você deseja encontrar a média.
  2. Clique na seta próxima a AutoSoma imagem de botão na barra de ferramentas (barra de ferramentas: uma barra com botões e opções que podem ser usadas para executar comandos. Para exibir uma barra de ferramentas, pressione ALT e, em seguida, SHIFT+10.) Padrão e, em seguida, clique em Média e pressione ENTER.

MostrarCalcular a média de números em uma linha ou coluna não contígua

Use a função MÉDIA para executar esta tarefa.

Exemplo de planilha

Talvez seja mais fácil de compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo?

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda. Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na <b>Ajuda</b>

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, no menu Ferramentas, aponte para Auditoria de fórmulas e clique em Modo de auditoria de fórmulas.
 
1
2
3
4
5
6
7
A
Dados
10
7
9
27
0
4
Fórmula Descrição (resultado)
=MÉDIA(A2:A7) Calcula a média de todos os números na lista acima (9,5)
=MÉDIA(A2:A4;A7) Calcula a média do primeiro, segundo e terceiro e último números na lista (7,5)
=MÉDIA(SE(A2:A7<>0; A2:A7;"")) Calcula a média dos números na lista, exceto daqueles que contêm zero, como a célula A6 (11,4)

 Observação    A última fórmula no exemplo precisa ser inserida como uma fórmula de matriz (fórmula de matriz: uma fórmula que executa vários cálculos em um ou mais conjuntos de valores e retorna um único resultado ou vários resultados. As fórmulas de matriz ficam entre chaves { } e são inseridas pressionando-se CTRL+SHIFT+ENTER.). Após copiar o exemplo em uma planilha em branco, selecione a célula A11. Pressione F2 e, em seguida, pressione CTRL+SHIFT+ENTER. Se a fórmula não for inserida como uma fórmula de matriz, será retornado o erro #VALOR!.

Detalhes da função

MÉDIA

MostrarCalcular uma média ponderada

Use as funções SOMARPRODUTO e SOMA para executar esta tarefa.

Exemplo de planilha

Talvez seja mais fácil de compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo?

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda. Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na <b>Ajuda</b>

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, no menu Ferramentas, aponte para Auditoria de fórmulas e clique em Modo de auditoria de fórmulas.

Este exemplo calcula o preço médio pago por uma unidade em três aquisições, sendo que o número de unidades e o preço por unidade em cada aquisição são diferentes.

 
1
2
3
4
A B
Preço por unidade Número de unidades
20 500
25 750
35 200
Fórmula Descrição (resultado)
=SOMARPRODUTO(A2:A4;B2:B4)/SOMA(B2:B4) Divide o custo total de todos os três pedidos pelo número total de unidades pedidas  (24,66)

Detalhes da função

SOMA

SOMARPRODUTO

MostrarCalcular a média de números, ignorando valores zero (0)

Use as funções MÉDIA e SE para executar esta tarefa.

Exemplo de planilha

Talvez seja mais fácil de compreender o exemplo se você copiá-lo para uma planilha em branco.

MostrarComo?

  1. Crie uma pasta de trabalho ou planilha em branco.
  2. Selecione o exemplo no tópico da Ajuda. Não selecione os cabeçalhos de linha ou de coluna. 

Selecionando um exemplo na <b>Ajuda</b>

Selecionando um exemplo na Ajuda
  1. Pressione CTRL+C.
  2. Na planilha, selecione a célula A1 e pressione CTRL+V.
  3. Para alternar entre exibir os resultados e exibir as fórmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, no menu Ferramentas, aponte para Auditoria de fórmulas e clique em Modo de auditoria de fórmulas.
 
1
2
3
4
5
6
7
A
Dados
10
7
9
27
0
4
Fórmula Descrição (resultado)
=MÉDIA(SE(A2:A7<>0; A2:A7;"")) Calcula a média dos números na lista, exceto daqueles que contêm zero, como a célula A6 (11,4)

 Observação    A fórmula do exemplo precisa ser inserida como uma fórmula de matriz (fórmula de matriz: uma fórmula que executa vários cálculos em um ou mais conjuntos de valores e retorna um único resultado ou vários resultados. As fórmulas de matriz ficam entre chaves { } e são inseridas pressionando-se CTRL+SHIFT+ENTER.). Após copiar o exemplo em uma planilha em branco, selecione a célula A9. Pressione F2 e, em seguida, pressione CTRL+SHIFT+ENTER. Se a fórmula não for inserida como uma fórmula de matriz, será retornado o erro #VALOR!.

Detalhes da função

MÉDIA

SE

 
 
Aplica-se a:
Excel 2003