Zliczanie wystąpień określonej wartości

Załóżmy, że należy sprawdzić, ile razy występuje określona wartość tekstowa lub liczbowa, na przykład:

  • Jeśli zakres zawiera wartości liczbowe 5, 6, 7 i 6, to wartość 6 występuje dwa razy.
  • Jeśli kolumna zawiera wartości „Karwat”, „Dubicki”, „Dubicki” i „Dubicki”, to wartość "Dubicki" występuje trzy razy.

Istnieje kilka sposobów zliczania, ile razy występuje dana wartość.

Co chcesz zrobić?


Zliczanie przy użyciu funkcji, ile razy występuje określona wartość

Aby wykonać to zadanie, należy użyć funkcji LICZ.JEŻELI.

Przykład

Przykład będzie bardziej zrozumiały, gdy zostanie skopiowany do pustego arkusza.

PokażJak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Zaznacz przykład w temacie Pomocy.

 Uwaga   Nie zaznaczaj nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w temacie Pomocy

Zaznaczanie przykładu w temacie Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć między wyświetlaniem wyników a wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.
 
1
2
3
4
5
6
7
A B
Sprzedawca Faktura
Dubicki 15 000
Dubicki 9 000
Stąpor 8 000
Stąpor 20 000
Dubicki 5 000
Karwat 22 500
Formuła Opis (wynik)
=LICZ.JEŻELI(A2:A7;"Dubicki") Liczba wpisów dla sprzedawcy o nazwisku Dubicki (3)
=LICZ.JEŻELI(A2:A7;A4) Liczba wpisów dla sprzedawcy o nazwisku Stąpor (2)
=LICZ.JEŻELI(B2:B7;"< 20000") Liczba faktur o wartości mniejszej niż 20 000 (4)
=LICZ.JEŻELI(B2:B7;">="&B5) Liczba faktur o wartości równej lub większej niż 20 000 (2)

Szczegóły funkcji

LICZ.JEŻELI

Początek strony Początek strony

Zliczanie przy użyciu funkcji, ile razy występują różne wartości liczbowych

Załóżmy, że należy ustalić, ilu sprzedawców sprzedało określony produkt w danym regionie lub ile transakcji sprzedaży przekraczających określoną wartość odnotował dany sprzedawca. W tym celu można użyć funkcji JEŻELI i ILE.LICZB.

Przykład

Przykład będzie bardziej zrozumiały, gdy zostanie skopiowany do pustego arkusza.

PokażJak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Zaznacz przykład w temacie Pomocy.

 Uwaga   Nie zaznaczaj nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w temacie Pomocy

Zaznaczanie przykładu w temacie Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć między wyświetlaniem wyników a wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.
 
1
2
3
4
5
6
7
8
9
10
11
A B C D
Region Sprzedawca Typ Sprzedaż
Południe Dubicki Napoje 3571
Zachód Misztal Nabiał 3338
Wschód Stąpor Napoje 5122
Północ Stąpor Nabiał 6239
Południe Karwat Warzywa 8677
Południe Misztal Mięso 450
Południe Misztal Mięso 7673
Wschód Stąpor Warzywa 664
Północ Misztal Warzywa 1500
Południe Karwat Mięso 6596
Formuła Opis (wynik)
=ILE.LICZB(JEŻELI((A2:A11="Południe")*(C2:C11="Mięso");D2:D11)) Liczba sprzedawców, którzy sprzedali mięso w regionie Południe (3)
=ILE.LICZB(JEŻELI((B2:B11="Stąpor")*(D2:D11>=1000);D2:D11)) Liczba transakcji sprzedaży przekraczających wartość 1000 dla sprzedawcy o nazwisku Stąpor (2)

 Uwagi 

Szczegóły funkcji

ILE.LICZB

JEŻELI

Początek strony Początek strony

Zliczanie przy użyciu funkcji, ile razy występują różne wartości tekstowe lub liczbowe

Aby wykonać to zadanie, należy użyć funkcji JEŻELI i SUMA:

  • Przypisz wartość 1 do każdego spełnionego warunku, używając funkcji JEŻELI.
  • Dodaj sumę, używając funkcji SUMA.

Przykład

Przykład będzie bardziej zrozumiały, gdy zostanie skopiowany do pustego arkusza.

PokażJak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Zaznacz przykład w temacie Pomocy.

 Uwaga   Nie zaznaczaj nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w temacie Pomocy

Zaznaczanie przykładu w temacie Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć między wyświetlaniem wyników a wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.
 
1
2
3
4
5
6
7
A B
Sprzedawca Faktura
Dubicki 15 000
Dubicki 9 000
Stąpor 8 000
Stąpor 20 000
Dubicki 5 000
Karwat 22 500
Formuła Opis (wynik)
=SUMA(JEŻELI((A2:A7="Dubicki")+(A2:A7="Karwat");1;0)) Liczba faktur dla sprzedawcy o nazwisku Dubicki lub Karwat (4)
=SUMA(JEŻELI((B2:B7<9000)+(B2:B7>19000);1;0)) Liczba faktur o wartościach mniejszych niż 9 000 lub większych niż 19 000 (4)
=SUMA(JEŻELI(A2:A7="Dubicki";JEŻELI(B2:B7<9000;1;0))) Liczba faktur dla sprzedawcy o nazwisku Dubicki i wartości mniejszej niż 9 000 (1)

 Uwaga   Formuły w tym przykładzie należy wprowadzić jako formuły tablicowe (formuła tablicowa: Formuła, która przeprowadza wiele obliczeń na jednym lub wielu zestawach wartości, a następnie zwraca jeden lub wiele wyników. Formuły tablicowe są ujęte w nawias klamrowy { }, a wprowadza się je przez naciśnięcie klawiszy CTRL+SHIFT+ENTER.). Należy zaznaczyć każdą komórkę zawierającą formułę, nacisnąć klawisz F2, a następnie nacisnąć klawisze CTRL+SHIFT+ENTER.

Szczegóły funkcji

JEŻELI

SUMA

Początek strony Początek strony

Zliczanie przy użyciu raportu tabeli przestawnej, ile razy występują różne wartości

Raportu tabeli przestawnej można używać do wyświetlania sum całkowitych i zliczania wystąpień unikatowych wartości.

  1. Zaznacz kolumnę zawierającą dane. Upewnij się, że kolumna ma nagłówek.
  2. Na karcie Wstawianie w grupie Tabele kliknij przycisk Tabela przestawna.
  1. Zostanie wyświetlone okno dialogowe Tworzenie tabeli przestawnej.
  2. Kliknij opcję Zaznacz tabelę lub zakres.
  3. Umieść raport tabeli przestawnej w nowym arkuszu tak, aby zaczynał się w komórce A1, klikając opcję Nowy arkusz.
  4. Kliknij przycisk OK.

W lokalizacji określonej na wyświetlonej liście pól tabeli przestawnej zostanie dodany pusty raport tabeli przestawnej.

  1. W sekcji pola u góry listy pól tabeli przestawnej kliknij i przytrzymaj nazwę pola, a następnie przeciągnij pole do pola Etykiety wierszy w sekcji układu znajdującej się u dołu listy pól tabeli przestawnej.
  2. W sekcji pola u góry listy pól tabeli przestawnej kliknij i przytrzymaj tę samą nazwę pola, a następnie ponownie przeciągnij pole do pola Wartości w sekcji układu znajdującej się u dołu listy pól tabeli przestawnej.

 Uwaga   Jeśli dane zawierają liczby, raport tabeli przestawnej podsumuje wpisy zamiast je zliczyć. Aby zmienić funkcję podsumowania z funkcji SUMA na funkcję ILE.LICZB, zaznacz komórkę w tej kolumnie, a następnie na karcie Opcje w grupie Aktywne pole kliknij przycisk Ustawienia pola, kliknij kartę Podsumowanie według, kliknij pozycję Licznik i kliknij przycisk OK.

Początek strony Początek strony

 
 
Dotyczy:
Excel 2007