Zaokrąglanie liczby

Załóżmy, że trzeba zaokrąglić liczbę do najbliższej liczby całkowitej, gdyż wartości dziesiętne nie mają znaczenia przy obliczeniach, albo zaokrąglić liczbę do wielokrotności liczby 10, aby uprościć przybliżanie wielkości. Liczby można zaokrąglać na wiele sposobów.

Co chcesz zrobić?


Zmienianie wyświetlanej liczby miejsc dziesiętnych bez zmieniania liczby

W arkuszu

  1. Zaznacz komórki, które chcesz sformatować.
  2. Aby wyświetlić więcej albo mniej cyfr po przecinku dziesiętnym, na karcie Narzędzia główne w grupie Liczba kliknij przycisk Zwiększ dziesiętne Obraz przycisku albo przycisk Zmniejsz dziesiętne Obraz przycisku.

We wbudowanym formacie liczby

  1. Na karcie Narzędzia główne w grupie Liczba kliknij strzałkę, a następnie kliknij pozycję Więcej.
  2. Na liście Kategoria kliknij pozycję Walutowe, Księgowe, Procentowe lub Naukowe.
  3. W polu Miejsca dziesiętne wprowadź liczbę miejsc dziesiętnych, które mają być wyświetlane.

Początek strony Początek strony

Zaokrąglanie liczby w górę

Aby wykonać to zadanie, należy użyć funkcji ZAOKR.GÓRA, ZAOKR.DO.PARZ albo ZAOKR.DO.NPARZ.

Przykład

Przykład będzie bardziej zrozumiały, gdy zostanie skopiowany do pustego arkusza.

PokażJak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Zaznacz przykład w temacie Pomocy.

 Uwaga   Nie zaznaczaj nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w temacie Pomocy

Zaznaczanie przykładu w temacie Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć między wyświetlaniem wyników a wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.
 
1
2
3
4
A
Dane
20,3
-5,9
12,5493
Formuła Opis (wynik)
=ZAOKR.GÓRA(A2;0) Zaokrągla liczbę 20,3 w górę do najbliższej liczby całkowitej (21)
=ZAOKR.GÓRA(A3;0) Zaokrągla liczbę -5,9 w górę (-6)
=ZAOKR.GÓRA(A4;2) Zaokrągla liczbę 12,5493 w górę do najbliższej setnej, czyli dwóch miejsc dziesiętnych (12,55)
=ZAOKR.DO.PARZ(A2) Zaokrągla liczbę 20,3 w górę do najbliższej liczby parzystej (22)
=ZAOKR.DO.NPARZ(A2) Zaokrągla liczbę 20,3 w górę do najbliższej liczby nieparzystej (21)

Szczegóły funkcji

ZAOKR.GÓRA

ZAOKR.DO.PARZ

ZAOKR.DO.NPARZ

Początek strony Początek strony

Zaokrąglanie liczby w dół

Aby wykonać to zadanie, należy użyć funkcji ZAOKR.DÓŁ.

Przykład

Przykład będzie bardziej zrozumiały, gdy zostanie skopiowany do pustego arkusza.

PokażJak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Zaznacz przykład w temacie Pomocy.

 Uwaga   Nie zaznaczaj nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w temacie Pomocy

Zaznaczanie przykładu w temacie Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć między wyświetlaniem wyników a wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.
 
1
2
3
4
A
Dane
20,3
-5,9
12,5493
Formuła Opis (wynik)
=ZAOKR.DÓŁ(A2;0) Zaokrągla liczbę 20,3 w dół do najbliższej liczby całkowitej (20)
=ZAOKR.DÓŁ(A3;0) Zaokrągla liczbę -5,9 w dół (-5)
=ZAOKR.DÓŁ(A4;2) Zaokrągla liczbę w dół do najbliższej setnej, czyli dwóch miejsc dziesiętnych (12,54)

Szczegóły funkcji

ZAOKR.DÓŁ

Początek strony Początek strony

Zaokrąglanie do najbliższej liczby

Aby wykonać to zadanie, należy użyć funkcji ZAOKR.

Przykład

Przykład będzie bardziej zrozumiały, gdy zostanie skopiowany do pustego arkusza.

PokażJak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Zaznacz przykład w temacie Pomocy.

 Uwaga   Nie zaznaczaj nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w temacie Pomocy

Zaznaczanie przykładu w temacie Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć między wyświetlaniem wyników a wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.
 
1
2
3
4
A
Dane
20,3
5,9
-5,9
Formuła Opis (wynik)
=ZAOKR(A2;0) Zaokrągla liczbę 20,3 w dół, ponieważ część ułamkowa jest mniejsza niż 0,5 (20)
=ZAOKR(A3;0) Zaokrągla liczbę 5,9 w górę, ponieważ część ułamkowa jest większa niż 0,5 (6)
=ZAOKR(A4;0) Zaokrągla liczbę -5,9 w dół, ponieważ część ułamkowa jest mniejsza niż -0,5 (-6)

Szczegóły funkcji

ZAOKR

Początek strony Początek strony

Zaokrąglanie liczby do najbliższego ułamka

Aby wykonać to zadanie, należy użyć funkcji ZAOKR.

Przykład

Przykład będzie bardziej zrozumiały, gdy zostanie skopiowany do pustego arkusza.

PokażJak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Zaznacz przykład w temacie Pomocy.

 Uwaga   Nie zaznaczaj nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w temacie Pomocy

Zaznaczanie przykładu w temacie Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć między wyświetlaniem wyników a wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.
 
1
2
3
A
Dane
1,25
30,452
Formuła Opis (wynik)
=ZAOKR(A2;1) Zaokrągla liczbę do najbliższej dziesiętnej (jednego miejsca dziesiętnego). Ponieważ zaokrąglana część jest większa niż lub równa 0,05, liczba jest zaokrąglana w górę (wynik: 1,3)
=ZAOKR(A3;2) Zaokrągla liczbę do najbliższej setnej (dwóch miejsc dziesiętnych). Ponieważ zaokrąglana część, 0,002, jest mniejsza niż 0,005, liczba jest zaokrąglana w dół (wynik: 30,45)

Szczegóły funkcji

ZAOKR

Początek strony Początek strony

Zaokrąglanie liczby do cyfry znaczącej powyżej 0

Aby wykonać to zadanie, należy użyć funkcji ZAOKR, ZAOKR.GÓRA, ZAOKR.DÓŁ, DŁ i ZAOKR.DO.CAŁK.

Przykład

Przykład będzie bardziej zrozumiały, gdy zostanie skopiowany do pustego arkusza.

PokażJak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Zaznacz przykład w temacie Pomocy.

 Uwaga   Nie zaznaczaj nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w temacie Pomocy

Zaznaczanie przykładu w temacie Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć między wyświetlaniem wyników a wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.
 
1
2
3
A
Dane
5492820
22230
Formuła Opis (wynik)
=ZAOKR(A2;3-DŁ(ZAOKR.DO.CAŁK(A2))) Zaokrągla górną liczbę do 3 cyfr znaczących (5490000)
=ZAOKR.DÓŁ(A3;3-DŁ(ZAOKR.DO.CAŁK(A3))) Zaokrągla dolną liczbę w dół do 3 cyfr znaczących (22200)
=ZAOKR.GÓRA(A2;5-DŁ(ZAOKR.DO.CAŁK(A2))) Zaokrągla górną liczbę w górę do 5 cyfr znaczących (5492900)

Szczegóły funkcji

ZAOKR.GÓRA

ZAOKR.DÓŁ

ZAOKR

DŁ, DŁ.B

ZAOKR.DO.CAŁK

Początek strony Początek strony

Zaokrąglanie liczby do określonej wielokrotności

Aby wykonać to zadanie, należy użyć funkcji MROUND.

Przykład

Przykład będzie bardziej zrozumiały, gdy zostanie skopiowany do pustego arkusza.

PokażJak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Zaznacz przykład w temacie Pomocy.

 Uwaga   Nie zaznaczaj nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w temacie Pomocy

Zaznaczanie przykładu w temacie Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć między wyświetlaniem wyników a wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.
 
1
2
3
4
5
A B
Formuła Opis (wynik)
=MROUND(16; 5) Zaokrągla wartość 16 do najbliższej wielokrotności wartości 5 (15)
=MROUND(-16; -5) Zaokrągla wartość -16 do najbliższej wielokrotności wartości -5 (-15)
=MROUND(2,6; 0,08) Zaokrągla wartość 2,6 do najbliższej wielokrotności wartości 0,08 (2,64)
=MROUND(5; -2) Zwraca błąd, ponieważ argumenty 5 i -2 mają odmienne znaki (#LICZBA!)

Szczegóły funkcji

MROUND

Początek strony Początek strony

 
 
Dotyczy:
Excel 2007