Zaokrąglanie liczb

PokażZmiana wyświetlanej liczby miejsc dziesiętnych bez zmieniania liczby

W arkuszu

  1. Zaznacz komórki, które chcesz formatować.
  2. Aby wyświetlić większą lub mniejszą liczbę cyfr po przecinku, kliknij przycisk Zwiększ dziesiętne obraz przycisku lub Zmniejsz dziesiętne obraz przycisku na pasku narzędzi (pasek narzędzi: Pasek z przyciskami i opcjami umożliwiającymi wykonywanie poleceń. Aby wyświetlić pasek narzędzi, należy nacisnąć klawisz ALT, a następnie klawisze SHIFT+F10.) Formatowanie.

We wbudowanym formacie liczby

  1. W menu Format kliknij polecenie Komórki, a następnie kliknij kartę Liczby.
  2. Na liście Kategoria kliknij pozycję Walutowe, Księgowe, Procentowe lub Naukowe.
  3. W polu Miejsca dziesiętne wprowadź liczbę miejsc dziesiętnych, które chcesz wyświetlić.

PokażZaokrąglanie liczby w górę

Użyj funkcji ZAOKR.GÓRA, ZAOKR.DO.PARZ albo ZAOKR.DO.NPARZ, aby wykonać to zadanie.

Przykład arkusza

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w tematach Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączać się pomiędzy wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisz CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
3
4
A
Dane
20,3
-5,9
12,5493
Formuła Opis (wynik)
=ZAOKR.GÓRA(A2;0) Zaokrągla liczbę 20,3 w górę do najbliższej liczby całkowitej (21)
=ZAOKR.GÓRA(A3;0) Zaokrągla liczbę -5,9 w górę (-6)
=ZAOKR.GÓRA(A4;2) Zaokrągla liczbę 12,5493 w górę do najbliższej setnej, czyli dwóch miejsc dziesiętnych (12,55)
=ZAOKR.DO.PARZ(A2) Zaokrągla liczbę 20,3 w górę do najbliższej liczby parzystej (22)
=ZAOKR.DO.NPARZ(A2) Zaokrągla liczbę 20,3 w górę do najbliższej liczby nieparzystej (21)

Szczegóły funkcji

ZAOKR.GÓRA

ZAOKR.DO.PARZ

ZAOKR.DO.NPARZ

PokażZaokrąglanie liczby w dół

Użyj funkcji ZAOKR.DÓŁ, aby wykonać to zadanie.

Przykład arkusza

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
3
4
A
Dane
20,3
-5,9
12,5493
Formuła Opis (wynik)
=ZAOKR.DÓŁ(A2;0) Zaokrągla liczbę 20,3 w dół do najbliższej liczby całkowitej (20)
=ZAOKR.DÓŁ(A3;0) Zaokrągla liczbę -5,9 w dół (-5)
=ZAOKR.DÓŁ(A4;2) Zaokrągla liczbę w dół do najbliższej setnej, czyli dwóch miejsc dziesiętnych (12,54)

Szczegóły funkcji

ZAOKR.DÓŁ

PokażZaokrąglanie do najbliższej liczby

Użyj funkcji ZAOKR, aby wykonać to zadanie.

Przykład arkusza

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
3
4
A
Dane
20,3
5,9
-5,9
Formuła Opis (wynik)
=ZAOKR(A2;0) Zaokrągla liczbę 20,3 w dół, ponieważ część ułamkowa jest mniejsza niż 0,5 (20)
=ZAOKR(A3;0) Zaokrągla liczbę 5,9 w górę, ponieważ część ułamkowa jest większa niż 0,5 (6)
=ZAOKR(A4;0) Zaokrągla liczbę -5,9 w dół, ponieważ część ułamkowa jest mniejsza niż -0,5 (-6)

Szczegóły funkcji

ZAOKR

PokażZaokrąglanie liczby do najbliższego ułamka

Użyj funkcji ZAOKR, aby wykonać to zadanie.

Przykład arkusza

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
3
A
Dane
1,25
30,452
Formuła Opis (wynik)
=ZAOKR(A2;1) Zaokrągla liczbę do najbliższej dziesiętnej (jednego miejsca dziesiętnego). Ponieważ zaokrąglana część jest większa lub równa 0,05, liczba jest zaokrąglana w górę (wynik: 1,3)
=ZAOKR(A3;2) Zaokrągla liczbę do najbliższej setnej (dwóch miejsc dziesiętnych). Ponieważ zaokrąglana część, 0,002, jest mniejsza niż 0,005, liczba jest zaokrąglana w dół (wynik: 30,45)

Szczegóły funkcji

ZAOKR

PokażZaokrąglanie liczby do cyfry znaczącej powyżej 0

Użyj funkcji ZAOKR, ZAOKR.GÓRA, ZAOKR.DÓŁ, DŁ i ZAOKR.DO.CAŁK, aby wykonać to zadanie.

Przykład arkusza

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
3
A
Dane
5492820
22230
Formuła Opis (wynik)
=ZAOKR(A2;3-DŁ(ZAOKR.DO.CAŁK(A2))) Zaokrągla górną liczbę do 3 cyfr znaczących (5490000)
=ZAOKR.DÓŁ(A3;3-DŁ(ZAOKR.DO.CAŁK(A3))) Zaokrągla dolną liczbę w dół do 3 cyfr znaczących (22200)
=ZAOKR.GÓRA(A2;6-DŁ(ZAOKR.DO.CAŁK(A2))) Zaokrągla górną liczbę w górę do 5 cyfr znaczących (5492900)

Szczegóły funkcji

ZAOKR.GÓRA

ZAOKR.DÓŁ

ZAOKR

ZAOKR.DO.CAŁK

 
 
Dotyczy:
Excel 2003