WYSZUKAJ.PIONOWO

Wyszukuje wartość w skrajnej lewej kolumnie tablicy, a następnie zwraca wartość w tym samym wierszu innej kolumny określonej w tablicy.

Funkcję WYSZUKAJ.PIONOWO należy stosować zamiast funkcji WYSZUKAJ.POZIOMO wtedy, gdy porównywane wartości są umieszczone w kolumnie znajdującej się z lewej strony danych, które należy odszukać.

Składnia

WYSZUKAJ.PIONOWO(odniesienie;tablica;nr_kolumny;kolumna)

Odniesienie    to wartość, którą należy znaleźć w pierwszej kolumnie tablicy (tablica: Służy do konstruowania pojedynczych formuł, które dają wiele wyników lub operują na grupie argumentów uporządkowanych w wiersze i kolumny. Zakres tablicy współużytkuje wspólną formułę; stała tablicowa to grupa stałych używana jako argument.). Odniesienie może być wartością lub odwołaniem. Jeśli argument odniesienie jest mniejszy niż najmniejsza wartość znajdująca się w pierwszej kolumnie tablicy określonej przez argument tablica, funkcja WYSZUKAJ.PIONOWO zwraca wartość błędu #N/D!.

Tablica    to co najmniej dwie kolumny danych. Należy używać odwołania do zakresu lub nazwy zakresu. Wśród wartości w pierwszej kolumnie argumentu tablica są wyszukiwane wartości argumentu odniesienie. Wartości argumentu tablica mogą być tekstami, liczbami lub wartościami logicznymi. Teksty pisane wielkimi i małymi literami są równoważne.

Nr_kolumny    to numer kolumny w tablicy, z której ma pochodzić pasująca wartość. Nr_kolumny o wartości 1 zwraca wartość z pierwszej kolumny tablicy określonej przez argument tablica; nr_kolumny o wartości 2 zwraca wartość z drugiej kolumny tablicy określonej przez argument tablica itd. Jeśli argument nr_kolumny ma wartość:

  • mniejszą niż 1, funkcja WYSZUKAJ.PIONOWO zwraca wartość błędu #ARG!;
  • większą niż liczba kolumn znajdujących się w tablicy określonej przez argument tablica, funkcja WYSZUKAJ.PIONOWO zwraca wartość błędu #ADR.

Kolumna    to wartość logiczna określająca, czy funkcja WYSZUKAJ.PIONOWO ma znaleźć dokładne czy przybliżone dopasowanie.

  • Jeśli ten argument ma wartość PRAWDA bądź zostanie pominięty, funkcja zwraca dopasowanie dokładne lub przybliżone. Jeśli nie zostanie znalezione dokładne dopasowanie, funkcja zwraca następną największą wartość mniejszą od argumentu odniesienie.

Wartości w pierwszej kolumnie argumentu tablica muszą być uporządkowane rosnąco; w przeciwnym razie wynik funkcji WYSZUKAJ.PIONOWO może być nieprawidłowy. Wartości można ustawić w kolejności rosnącej, wskazując polecenie Sortuj w menu Dane i wybierając polecenie Rosnąco. Aby uzyskać więcej informacji, zobacz temat Domyślne kolejności sortowania.

  • Jeśli argument ma wartość FAŁSZ, funkcja WYSZUKAJ.PIONOWO wyszuka tylko dopasowanie dokładne. W tym przypadku wartości w pierwszej kolumnie argumentu tablica nie muszą być sortowane. W przypadku znalezienia w pierwszej kolumnie argumentu tablica co najmniej dwóch wartości pasujących do argumentu odniesienie funkcja zwraca pierwszą wartość. Jeśli dokładne dopasowanie nie zostanie znalezione, funkcja zwraca wartość błędu #N/D!.

Uwagi

  • Przy wyszukiwaniu wartości tekstowych w pierwszej kolumnie argumentu tablica należy się upewnić, że dane w tej kolumnie nie zawierają początkowych i końcowych spacji, niekonsekwentnie stosowanych cudzysłowów prostych (' lub ") i drukarskich (‘ lub “) ani też znaków niedrukowalnych. W przeciwnym razie wynik funkcji WYSZUKAJ.PIONOWO może być nieprawidłowy lub nieprzewidywalny. Aby uzyskać więcej informacji na temat funkcji, których można użyć do oczyszczenia danych tekstowych, zobacz temat Funkcje tekstowe i danych.
  • Przy wyszukiwaniu wartości liczbowych lub dat w pierwszej kolumnie argumentu tablica należy się upewnić, że dane w tej kolumnie nie są przechowywane jako wartości tekstowe. W przeciwnym razie wynik funkcji WYSZUKAJ.PIONOWO może być nieprawidłowy lub nieprzewidywalny. Aby uzyskać więcej informacji, zobacz temat Konwertowanie liczb przechowywanych jako tekst na liczby.
  • Jeśli argument kolumna ma wartość FAŁSZ, a argument szukana_wartość zawiera tekst, można używać znaków zastępczych: znaku zapytania (?) i gwiazdki (*). Znak zapytania zastępuje dowolny pojedynczy znak, a gwiazdka zastępuje sekwencję znaków. Jeśli trzeba znaleźć autentyczny znak zapytania lub gwiazdkę, należy poprzedzić go znakiem tyldy (~).

Przykład 1

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak skopiować przykład

  • Utwórz pusty skoroszyt lub arkusz.
  • Zaznacz przykład w tym temacie Pomocy.

 Uwaga   Nie zaznaczaj nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w Pomocy

Zaznaczanie przykładu w Pomocy
  • Naciśnij klawisze CTRL+C.
  • W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  • Aby przełączać się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisz CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.

W tym przykładzie przeszukujemy kolumnę Gęstość z tabeli właściwości atmosferycznych w celu znalezienia odpowiednich wartości w kolumnach Lepkość i Temperatura. Podane wartości dotyczą powietrza o temperaturze 0 stopni Celsjusza na poziomie morza, czyli ciśnienia 1 atmosfery.

 
1
2
3
4
5
6
7
8
9
10
A B C
Gęstość Lepkość Temperatura
0,457 3,55 500
0,525 3,25 400
0,616 2,93 300
0,675 2,75 250
0,746 2,57 200
0,835 2,38 150
0,946 2,17 100
1,09 1,95 50
1,29 1,71 0
Formuła Opis (wynik)
=WYSZUKAJ.PIONOWO(1;A2:C10;2) Za pomocą dopasowania przybliżonego wyszukuje wartość 1 w kolumnie A. Po znalezieniu największej wartości mniejszej lub równej 1 w kolumnie A (0,946) zwraca wartość z tego samego wiersza w kolumnie B (2,17).
=WYSZUKAJ.PIONOWO(1;A2:C10;3;PRAWDA) Za pomocą dopasowania przybliżonego wyszukuje wartość 1 w kolumnie A. Po znalezieniu największej wartości mniejszej lub równej 1 w kolumnie A (0,946) zwraca wartość z tego samego wiersza w kolumnie C (100).
=WYSZUKAJ.PIONOWO(0,7;A2:C10;3;FAŁSZ) Za pomocą dopasowania dokładnego wyszukuje wartość 0,7 w kolumnie A. Ponieważ w kolumnie A nie ma dokładnego dopasowania, funkcja zwraca błąd (#N/D!).
=WYSZUKAJ.PIONOWO(0,1;A2:C10;2;PRAWDA) Za pomocą dopasowania przybliżonego wyszukuje wartość 0,1 w kolumnie A. Ponieważ wartość 0,1 jest mniejsza niż najmniejsza wartość w kolumnie A, funkcja zwraca błąd (#N/D!).
=WYSZUKAJ.PIONOWO(2;A2:C10;2;PRAWDA) Za pomocą dopasowania przybliżonego wyszukuje wartość 2 w kolumnie A. Po znalezieniu największej wartości mniejszej lub równej 2 w kolumnie A (1,29) zwraca wartość z tego samego wiersza w kolumnie B (1,71).

Przykład 2

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak skopiować przykład

  • Utwórz pusty skoroszyt lub arkusz.
  • Zaznacz przykład w tym temacie Pomocy.

 Uwaga   Nie zaznaczaj nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w Pomocy

Zaznaczanie przykładu w Pomocy
  • Naciśnij klawisze CTRL+C.
  • W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  • Aby przełączać się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisz CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.

W tym przykładzie kolumna ID produktu w tabeli produktów dziecięcych jest przeszukiwana w celu dopasowania wartości w kolumnach Koszt i Znacznik oraz obliczenia cen i sprawdzenia warunków.

 
1
2
3
4
5
6
A B C D
ID produktu Produkt Koszt Znacznik
WZ-340 Wózek 145,67 zł 30%
SL-567 Śliniak 3,56 zł 40%
PI-328 Pieluchy 21,45 zł 35%
CH-989 Chustki 5,12 zł 40%
OD-469 Odsysacz 2,56 zł 45%
Formuła Opis (wynik)
= WYSZUKAJ.PIONOWO("PI-328"; A2:D6; 3; FAŁSZ) * (1 + WYSZUKAJ.PIONOWO("PI-328"; A2:D6; 4; FAŁSZ)) Oblicza cenę detaliczną pieluch, dodając do kosztu znacznik procentowy (28,96 zł).
= (WYSZUKAJ.PIONOWO("CH-989"; A2:D6; 3; FAŁSZ) * (1 + WYSZUKAJ.PIONOWO("CH-989"; A2:D6; 4; FAŁSZ))) * (1 - 20%) Oblicza cenę sprzedaży chustek, odejmując określony rabat od ceny detalicznej (5,73 zł).
= JEŻELI(WYSZUKAJ.PIONOWO(A2; A2:D6; 3; FAŁSZ) >= 20; "Znacznik wynosi " & 100 * WYSZUKAJ.PIONOWO(A2; A2:D6; 4; FAŁSZ) &"%"; "Koszt poniżej 20,00 zł") Jeśli koszt produktu jest większy lub równy 20 zł, wyświetla ciąg „Znacznik wynosi nn%”; w przeciwnym razie wyświetla ciąg „Koszt poniżej 20,00 zł” (Znacznik wynosi 30%).
= JEŻELI(WYSZUKAJ.PIONOWO(A3; A2:D6; 3; FAŁSZ) >= 20; "Znacznik wynosi: " & 100 * WYSZUKAJ.PIONOWO(A3; A2:D6; 4; FAŁSZ) &"%"; "Koszt wynosi " & WYSZUKAJ.PIONOWO(A3; A2:D6; 3; FAŁSZ) & " zł") Jeśli koszt produktu jest większy lub równy 20 zł, wyświetla ciąg „Znacznik wynosi nn%”; w przeciwnym razie wyświetla ciąg „Koszt poniżej 20,00 zł” (Koszt wynosi 3,56 zł).

Przykład 3

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak skopiować przykład

  • Utwórz pusty skoroszyt lub arkusz.
  • Zaznacz przykład w tym temacie Pomocy.

 Uwaga   Nie zaznaczaj nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w Pomocy

Zaznaczanie przykładu w Pomocy
  • Naciśnij klawisze CTRL+C.
  • W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  • Aby przełączać się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisz CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.

W tym przykładzie przeszukujemy kolumnę ID tabeli pracowników w celu dopasowania wartości z innych kolumn, obliczenia wieku i sprawdzenia warunków błędów.

 
1
2
3
4
5
6
7
A B C D E
Identyfikator Nazwisko Imię Tytuł Data urodzenia
1 Ciesielska Ewa Przedstawiciel handlowy 1968-12-08
2 Bator Tomasz Wiceprezes, dział sprzedaży 1952-02-19
3 Karwat Magdalena Przedstawiciel handlowy 1963-08-30
4 Korzun Dariusz Przedstawiciel handlowy 1958-09-19
5 Szymczak Radosław Kierownik działu sprzedaży 1955-03-04
6 Szypuła Greta Przedstawiciel handlowy 1963-07-02
Formuła Opis (wynik)
=LICZBA.CAŁK(YEARFRAC(DATA(2004;6;30); WYSZUKAJ.PIONOWO(5;A2:E7;5; FAŁSZ); 1)) Dla roku podatkowego 2004 wyszukuje wiek pracownika o identyfikatorze (ID) równym 5. Funkcja YEARFRAC służy do odjęcia daty urodzenia od daty końca roku podatkowego. Wynik jest wyświetlany jako liczba całkowita za pomocą funkcji LICZBA.CAŁK (49).
=JEŻELI(CZY.BRAK(WYSZUKAJ.PIONOWO(5;A2:E7;2;FAŁSZ)) = PRAWDA; "Nie znaleziono pracownika"; WYSZUKAJ.PIONOWO(5;A2:E7;2;FAŁSZ))

Jeśli w tabeli jest pracownik o identyfikatorze 5, zwraca jego nazwisko. W przeciwnym razie wyświetla komunikat „Nie znaleziono pracownika” (Szymczak).

Funkcja CZY.BRAK zwraca wartość PRAWDA, jeśli funkcja WYSZUKAJ.PIONOWO zwraca wartość błędu #N/D!.

=JEŻELI(CZY.BRAK(WYSZUKAJ.PIONOWO(15;A3:E8;2;FAŁSZ)) = PRAWDA; "Nie znaleziono pracownika"; WYSZUKAJ.PIONOWO(15;A3:E8;2;FAŁSZ))

Jeśli w tabeli jest pracownik o identyfikatorze 15, zwraca jego nazwisko. W przeciwnym razie wyświetla komunikat „Nie znaleziono pracownika” (Nie znaleziono pracownika).

Funkcja CZY.BRAK zwraca wartość PRAWDA, jeśli funkcja WYSZUKAJ.PIONOWO zwraca wartość błędu #N/D!.

=WYSZUKAJ.PIONOWO(4;A2:E7;3;FAŁSZ) & " " & WYSZUKAJ.PIONOWO(4;A2:E7;2;FAŁSZ) & " pracuje na stanowisku " & WYSZUKAJ.PIONOWO(4;A2:E7;4;FAŁSZ) & "." Dla pracownika o identyfikatorze 4 łączy wartości trzech komórek w jedno pełne zdanie (Dariusz Korzun pracuje na stanowisku Przedstawiciel handlowy).

 Uwaga   W pierwszej formule powyższego przykładu jest używana funkcja YEARFRAC. Jeśli ta funkcja jest niedostępna i zwracany jest błąd #NAZWA?, należy zainstalować i załadować dodatek Analysis ToolPak.

PokażJak?

  1. W menu Narzędzia kliknij polecenie Dodatki.
  2. Na liście Dostępne dodatki zaznacz pole Pakiet Analysis ToolPak, a następnie kliknij przycisk OK.
  3. Jeśli to konieczne, wykonaj instrukcje programu instalacyjnego.
 
 
Dotyczy:
Excel 2003