Wyświetlanie lub ukrywanie wartości zerowych

PokażWyświetlanie lub ukrywanie wszystkich wartości zerowych w skoroszycie

  1. W menu Narzędzia kliknij polecenie Opcje, a następnie kliknij kartę Widok.
  2. Wykonaj jedną z następujących czynności:
    • Aby wyświetlić w komórkach wartości zerowe (0), zaznacz pole wyboru Wartości zerowe.
    • Aby wyświetlić wartości zerowe jako puste komórki, wyczyść to pole wyboru.

PokażUżywanie formatu liczbowego do ukrywania wartości zerowych w zaznaczonych komórkach

W tym temacie opisano zastosowanie formatu do ukrywania w zaznaczonych komórkach wartości zerowych. Jeśli wartość w jednej z takich komórek zmieni się na wartość niezerową, format wartości będzie podobny do ogólnego formatu liczbowego.

  1. Zaznacz komórki zawierające zera (0), które chcesz ukryć.
  2. W menu Format kliknij polecenie Komórki, a następnie kliknij kartę Liczby.
  3. Na liście Kategoria kliknij pozycję Niestandardowe.
  4. W polu Typ wpisz 0;-0;;@.

 Uwagi 

  • Wartości ukryte są wyświetlane tylko na pasku formuły Pasek formuły  — albo w komórce, gdy użytkownik edytuje w jej wnętrzu — i nie są drukowane.
  • Aby znowu wyświetlić ukryte wartości, zaznacz komórki, kliknij polecenie Komórki w menu Format, a następnie kliknij kartę Liczba. Na liście Kategoria, kliknij pozycję Ogólne, aby zastosować domyślny format liczbowy. Aby wyświetlić ponownie datę lub czas, zaznacz odpowiedni format daty lub czasu na karcie Liczba.

PokażUżywanie formatu warunkowego do ukrywania wartości zerowych zwracanych przez formułę

  1. Zaznacz komórkę zawierającą wartość zerową.
  2. W menu Format kliknij polecenie Formatowanie warunkowe.
  3. W polu po lewej stronie kliknij pozycję Wartość komórki jest.
  4. W drugim polu od lewej kliknij pozycję równa.
  5. W polu po prawej stronie wpisz liczbę 0.
  6. Kliknij przycisk Formatuj, a następnie kliknij kartę Czcionki.
  7. W polu Kolor wybierz kolor biały.

PokażUżywanie formuły do wyświetlania zer jako odstępów albo kresek

Użyj funkcji JEŻELI, aby wykonać to zadanie.

Przykład arkusza

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
3
A
Dane
10
10
Formuła Opis (wynik)
=A2-A3 Druga liczba odjęta od pierwszej (0)
=JEŻELI(A2-A3=0;"";A2-A3) Zwraca pustą komórkę, gdy wartość jest równa zero (pusta komórka)
=JEŻELI(A2-A3=0;"-";A2-A3) Zwraca kreskę, gdy wartość jest równa zero (-)

Szczegóły funkcji

JEŻELI

PokażUkrywanie wartości zerowych w raporcie tabeli przestawnej

  1. Kliknij raport.
  2. Na pasku narzędzi Tabela przestawna kliknij przycisk Tabela przestawna, a następnie kliknij przycisk Opcje tabeli.
  3. Wykonaj co najmniej jedną z następujących czynności:

Zmiana sposobu wyświetlania błędów       W obszarze Opcje formatowania zaznacz pole wyboru Dla błędnych wartości pokazuj. W polu wpisz wartość, która ma być wyświetlona zamiast błędnej wartości. Aby wyświetlić błędy jako puste komórki, usuń wszystkie znaki w polu.

Zmiana sposobu wyświetlania pustych komórek       Zaznacz pole wyboru Dla pustych komórek pokazuj. W polu wpisz wartość, która ma być wyświetlana w pustej komórce. Aby wyświetlić puste komórki, usuń wszystkie znaki w polu. Aby wyświetlić zera, wyczyść to pole wyboru.

 
 
Dotyczy:
Excel 2003