Tworzenie formuły

Formuły są to równania, które wykonują obliczenia na wartościach zawartych w arkuszu. Formuła musi się zaczynać od znaku równości (=). Na przykład poniższa formuła mnoży 2 przez 3, a do wyniku dodaje 5.

=5+2*3

PokażTworzenie prostej formuły =128+345

PokażTworzenie formuły zawierającej odwołania lub nazwy: =A1+23

Następujące formuły zawierają odwołania względne (odwołanie względne: W formule jest to adres komórki oparty na względnym położeniu komórki, która zawiera formułę, i komórki, do której następuje odwołanie. Jeśli formuła zostanie skopiowana, odwołanie jest automatycznie dostosowywane. Odwołanie względne ma postać A1.) do komórek i nazwy (nazwa: Wyraz lub ciąg, który reprezentuje komórkę, zakres komórek, formułę lub wartość stałą. Używając nazw, łatwiej jest zrozumieć odwołania; na przykład odwołanie Produkty jest bardziej zrozumiałe niż Sprzedaż!C20:C30.) komórek. Komórka zawierająca formułę jest zwana komórką zależną wówczas, gdy jej wartość jest zależna od wartości w innych komórkach. Na przykład komórka B2 jest komórką zależną, jeżeli zawiera formułę =C2.

Przykład formuły Operacje wykonywane przez formułę
=C2 Używa wartości w komórce C2
=Arkusz2!B2 Używa wartości w komórce B2 w arkuszu Arkusz2
=Aktywa-Pasywa Odejmuje komórkę o nazwie Pasywa od komórki o nazwie Aktywa
  1. Kliknij komórkę, do której chcesz wprowadzić formułę.
  2. Na pasku formuły (pasek formuły: Pasek u góry okna programu Excel, który służy do wprowadzania i edytowania wartości i formuł w komórkach i na wykresach. Wyświetlana jest w nim wartość stała lub formuła przechowywana w komórce aktywnej.) Pasek formuły wpisz = (znak równości).
  3. Wykonaj jedną z następujących czynności:
    • Aby utworzyć odwołanie, zaznacz komórkę, zakres komórek, lokalizację w innym arkuszu lub lokalizację w innym skoroszycie. Można przeciągnąć krawędź zaznaczenia komórki, aby przenieść zaznaczenie, albo przeciągnąć róg obramowania, aby rozszerzyć zaznaczenie.

Wyszukiwacz zakresów oznacza odpowiednimi kodami kolorów komórki poprzedzające

  • Aby utworzyć odwołanie do nazwanego zakresu, naciśnij klawisz F3, zaznacz nazwę w polu Wklej nazwę i kliknij przycisk OK.
  1. Naciśnij klawisz ENTER.

PokażTworzenie formuły zawierającej funkcję: =ŚREDNIA(A1:B4)

Poniższe formuły zawierają funkcje (funkcja: Uprzednio napisana formuła, która pobiera wartość lub wartości, przeprowadza operację i zwraca wartość lub wartości. Funkcje upraszczają i skracają formuły używane w arkuszu, szczególnie te, które przeprowadzają długie lub złożone obliczenia.).

Przykład formuły Co robi
=SUMA(A:A) Dodaje wszystkie liczby umieszczone w kolumnie A
=ŚREDNIA(A1:B4) Oblicza średnią ze wszystkich liczb umieszczonych w zakresie
  1. Kliknij komórkę, do której chcesz wprowadzić formułę.
  2. Aby rozpocząć tworzenie formuły od funkcji, na pasku formuły (pasek formuły: Pasek u góry okna programu Excel, który służy do wprowadzania i edytowania wartości i formuł w komórkach i na wykresach. Wyświetlana jest w nim wartość stała lub formuła przechowywana w komórce aktywnej.) Pasek formuły kliknij przycisk Wstaw funkcję Obrazek przycisku.
  3. Wybierz wymaganą funkcję. Można wprowadzić pytanie opisujące, co zamierzasz zrobić, w polu Wyszukaj funkcję (na przykład wyrażenie „dodaj liczby” zwróciłoby funkcję SUMA) lub przeszukać kategorie w polu Lub wybierz kategorię.
  4. Wprowadź argumenty (argument: Wartość, której funkcja używa do wykonywania operacji lub obliczeń. Typ argumentu używany przez funkcję jest specyficzny dla funkcji. Do typowych argumentów używanych przez funkcje należą liczby, tekst, odwołania do komórek i nazwy.). Aby wprowadzić jako argument odwołanie do komórki, kliknij przycisk Zwiń okno dialogowe Obrazek przycisku, aby tymczasowo ukryć okno dialogowe. Po zaznaczeniu komórek w arkuszu kliknij przycisk Rozwiń okno dialogowe Obrazek przycisku.
  5. Po zakończeniu tworzenia formuły naciśnij klawisz ENTER.

PokażTworzenie formuły zawierającej funkcje zagnieżdżone: =JEŻELI(ŚREDNIA(F2:F5)>50;SUMA(G2:G5);0)

Funkcje zagnieżdżone używają funkcji jako argumentów innej funkcji. Poniższa formuła podsumowuje zbiór liczb (G2:G5) tylko wtedy, gdy średnia innego zbioru liczb (F2:F5) jest większa niż 50. W przeciwnym razie zwraca 0.

Funkcje zagnieżdżone

  1. Kliknij komórkę, do której chcesz wprowadzić formułę.
  2. Aby rozpocząć tworzenie formuły od funkcji, na pasku formuły (pasek formuły: Pasek u góry okna programu Excel, który służy do wprowadzania i edytowania wartości i formuł w komórkach i na wykresach. Wyświetlana jest w nim wartość stała lub formuła przechowywana w komórce aktywnej.) Pasek formuły kliknij przycisk Wstaw funkcję Obrazek przycisku.
  3. Wybierz wymaganą funkcję. Można wprowadzić pytanie opisujące, co zamierzasz zrobić, w polu Wyszukaj funkcję (na przykład wyrażenie „dodaj liczby” zwróciłoby funkcję SUMA), lub przeszukać kategorie w polu Lub wybierz kategorię.
  4. Wprowadź argumenty (argument: Wartość, której funkcja używa do wykonywania operacji lub obliczeń. Typ argumentu używany przez funkcję jest specyficzny dla funkcji. Do typowych argumentów używanych przez funkcje należą liczby, tekst, odwołania do komórek i nazwy.).
    • Aby wprowadzić jako argument odwołanie do komórki, kliknij przycisk Zwiń okno dialogowe Obrazek przycisku obok argumentu, który ma spowodować tymczasowe ukrycie okna dialogowego. Zaznacz komórki w arkuszu, a następnie kliknij przycisk Rozwiń okno dialogowe Obrazek przycisku.
    • Aby umieścić kolejną funkcję jako argument, wprowadź ją do pola wymaganego argumentu. Można na przykład w polu edycji Wartość jeżeli prawda dodać wyrażenie SUMA(G2:G5).
    • Aby zamienić części formuły wyświetlone w oknie dialogowym Argumenty funkcji, kliknij nazwę odpowiedniej funkcji na pasku formuły. Jeśli na przykład zostanie kliknięta funkcja JEŻELI, zostaną wyświetlone argumenty dla tej funkcji.

PokażPorady

 
 
Dotyczy:
Excel 2003