Tworzenie formuł warunkowych za pomocą funkcji JEŻELI

PokażWynik jest wartością logiczną (PRAWDA lub FAŁSZ)

Użyj funkcji ORAZ, LUB i NIE, a także operatorów (operator: Znak lub symbol, który określa typ obliczenia, jakie ma być przeprowadzane w wyrażeniu. Wyróżnia się operatory matematyczne, porównania, logiczne i odwołania.), aby wykonać to zadanie.

Przykład arkusza

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
3
4
A
Dane
15
9
8
Formuła Opis (wynik)
=ORAZ(A2>A3;A2<A4) Czy 15 jest większe niż 9 i mniejsze niż 8? (FAŁSZ)
=LUB(A2>A3;A2<A4) Czy 15 jest większe niż 9 lub mniejsze niż 8? (PRAWDA)
=NIE(A2+A3=24) Czy 15 plus 9 nie równa się 24? (FAŁSZ)

Szczegóły funkcji

ORAZ

LUB

NIE

PokażWynik innego obliczenia lub dowolna wartość inna niż PRAWDA lub FAŁSZ

Użyj funkcji JEŻELI, ORAZ i LUB, aby wykonać to zadanie.

Przykład arkusza

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
3
4
A
Dane
15
9
8
Formuła Opis (wynik)
=JEŻELI(A2=15;"Tak";"Nie") Jeśli wartość umieszczona w komórce A2 równa się 15, wtedy zwracany jest tekst „Tak”. (Tak)
=JEŻELI(ORAZ(A2>A3;A2<A4);"Tak";"Nie") Jeśli 15 jest większe niż 9 i mniejsze niż 8, wtedy zwracany jest tekst „Tak”. (Nie)
=JEŻELI(LUB(A2>A3;A2<A4);"Tak";"Nie") Jeżeli 15 jest większe niż lub mniejsze niż 8, wtedy zwracany jest tekst „Tak”. (Tak)

Funkcja JEŻELI korzysta z następujących argumentów.

Formuła zawierająca funkcję JEŻELI

Formuła zawierająca funkcję JEŻELI

Objaśnienie 1   Test logiczny: warunek, który ma zostać sprawdzony

Objaśnienie 2   Wartość jeżeli prawda: wartość, jaka ma zostać zwrócona, jeśli warunek okaże się prawdziwy

Objaśnienie 3   Wartość jeżeli fałsz: wartość, jaka ma zostać zwrócona, jeśli warunek okaże się fałszywy

Szczegóły funkcji

ORAZ

LUB

JEŻELI

 
 
Dotyczy:
Excel 2003