Tworzenie formuł warunkowych

Testowanie, czy warunki są spełnione, czy nie, i logiczne porównywanie wyrażeń to operacje typowe dla wielu zadań. Do tworzenia formuł warunkowych służą funkcje ORAZ, LUB, NIE i JEŻELI.

W przypadku funkcji JEŻELI są stosowane następujące argumenty.


Formuła zawierająca funkcję JEŻELI

Formuła zawierająca funkcję JEŻELI

Objaśnienie 1  test_logiczny: warunek, który ma zostać sprawdzony.

Objaśnienie 2  wartość_jeżeli_prawda: wartość zwracana wtedy, gdy warunek jest prawdziwy.

Objaśnienie 3  wartość_jeżeli_fałsz: wartość zwracana wtedy, gdy warunek jest fałszywy.


Co chcesz zrobić?


Tworzenie formuł warunkowych zwracających wartość logiczną (PRAWDA lub FAŁSZ)

Do wykonania tego zadania należy użyć funkcji ORAZ, LUB i NIE, a także operatorów (operator: Znak lub symbol, który określa typ obliczenia, jakie ma być przeprowadzane w wyrażeniu. Wyróżnia się operatory matematyczne, porównania, logiczne i odwołania.).

Przykład

Przykład będzie bardziej zrozumiały, gdy zostanie skopiowany do pustego arkusza.

PokażJak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Zaznacz przykład w temacie Pomocy.

 Uwaga   Nie zaznaczaj nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w temacie Pomocy

Zaznaczanie przykładu w temacie Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć między wyświetlaniem wyników a wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.
 
1
2
3
4
A
Dane
15
9
8
Zębatki
Wihajstry
Formuła Opis (wynik)
=ORAZ(A2>A3; A2<A4) Czy 15 jest większe niż 9 i mniejsze niż 8? (FAŁSZ)
=LUB(A2>A3; A2<A4) Czy 15 jest większe niż 9 lub mniejsze niż 8? (PRAWDA)
=NIE(A2+A3=24) Czy 15 plus 9 nie równa się 24? (FAŁSZ)
=NIE(A5="Zębatki") Czy A5 jest różne od „Zębatki"? (FAŁSZ)
=LUB(A5<>"Zębatki";A6 = "Wihajstry") Czy A5 jest różne od „Zębatki" lub A6 jest równe „Wihajstry"? (PRAWDA)

Szczegóły funkcji

ORAZ

LUB

NIE

Początek strony Początek strony

Tworzenie formuł warunkowych, których wynikiem są obliczenia lub wartości inne niż PRAWDA i FAŁSZ

Do wykonania tego zadania należy użyć funkcji JEŻELI, ORAZ i LUB.

Przykład

Przykład będzie bardziej zrozumiały, gdy zostanie skopiowany do pustego arkusza.

PokażJak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Zaznacz przykład w temacie Pomocy.

 Uwaga   Nie zaznaczaj nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w temacie Pomocy

Zaznaczanie przykładu w temacie Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć między wyświetlaniem wyników a wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.
 
1
2
3
4
A
Dane
15
9
8
Zębatki
Wihajstry
Formuła Opis (wynik)
=JEŻELI(A2=15, "OK", "Nie OK") Jeśli wartość umieszczona w komórce A2 równa się 15, zwracany jest tekst „OK” (OK)
=JEŻELI(A2<>15; "OK"; "Nie OK") Jeśli wartość w komórce A2 jest różna od 15, zwracany jest tekst „OK" (Nie OK)
=JEŻELI(NIE(A2<=15); "OK"; "Nie OK") Jeśli wartość w komórce A2 nie jest mniejsza niż ani równa 15, zwracany jest tekst „OK" (Nie OK)
=JEŻELI(A5<>"ZĘBATKI"; "OK"; "Nie OK") Jeśli wartość w komórce A5 jest różna od „ZĘBATKI", zwracany jest tekst „OK" (Nie OK)
=JEŻELI(ORAZ(A2>A3; A2<A4); "OK"; "Nie OK") Jeśli 15 jest większe niż 9 i mniejsze niż 8, zwracany jest tekst „OK” (Nie OK)
=JEŻELI(ORAZ(A2<>A3; A2<>A4); "OK"; "Nie OK") Jeśli 15 jest różne od 9 i 15 jest różne od 8, zwracany jest tekst „OK" (OK)
=JEŻELI(LUB(A2>A3; A2<A4); "OK"; "Nie OK") Jeżeli 15 jest większe niż 9 lub mniejsze niż 8, zwracany jest tekst „OK” (OK)
=JEŻELI(LUB(A5<>"Zębatki"; A6<>"Wihajstry"); "OK"; "Nie OK") Jeśli wartość w komórce A5 jest różna od „Zębatki" lub jeśli wartość w komórce A6 jest różna od „Wihajstry", zwracany jest tekst „OK" (Nie OK)
=JEŻELI(LUB(A2<>A3; A2<>A4); "OK"; "Nie OK") Jeśli 15 jest różne od 9 lub 15 jest różne od 8, zwracany jest tekst „OK" (OK)

Szczegóły funkcji

JEŻELI

ORAZ

LUB

Początek strony Początek strony

 
 
Dotyczy:
Excel 2007