SUMA

Dodaje wszystkie liczby znajdujące się w zakresie komórek.

Składnia

SUMA(liczba1;liczba2;...)

Liczba1;liczba2,...     to od 1 do 30 argumentów, dla których należy obliczyć wartość ogólną, czyli sumę.

Spostrzeżenia

  • Funkcja zlicza liczby, wartości logiczne i tekstowe reprezentacje liczb, które zostały wpisane bezpośrednio na listę argumentów. Zobacz pierwszy i drugi z poniższych przykładów.
  • Jeśli argument jest tablicą lub odwołaniem, sumowane są tylko liczby umieszczone w tej tablicy lub odwołaniu. Puste komórki, wartości logiczne, tekst lub wartości błędów, zawarte w tablicy lub w odwołaniu, są pomijane. Zobacz trzeci z poniższych przykładów.
  • Argumenty, które są wartościami błędów, albo tekst, którego nie można przekształcić, powodują występowanie błędów.

Przykład

Przykład będzie bardziej zrozumiały, jeśli zostanie skopiowany do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
3
4
5
6
A
Dane
-5
15
30
'5
PRAWDA
Formuła Opis (wynik)
=SUMA(3; 2) Dodaje liczby 3 i 2 (5)
=SUMA("5"; 15; PRAWDA) Dodaje liczby 5, 15 i 1, ponieważ wartości tekstowe przekształcane są na liczby, a wartość logiczna PRAWDA przekształcana jest na liczbę 1 (21)
=SUMA(A2:A4) Dodaje pierwsze trzy liczby znajdujące się w podanej kolumnie (40)
=SUMA(A2:A4; 15) Dodaje pierwsze trzy liczby znajdujące się w podanej kolumnie i liczbę 15 (55)
=SUMA(A5;A6;2) Dodaje wartości podane w ostatnich dwóch wierszach i liczbę 2. Ponieważ wartości nienumeryczne umieszczone w odwołaniach nie są przekształcane, wartości umieszczone w podanej kolumnie są ignorowane (2)
 
 
Dotyczy:
Excel 2003