ŚREDNIA, funkcja

Ten artykuł zawiera opis składni formuły i zastosowania funkcji (funkcja: Uprzednio napisana formuła, która pobiera wartość lub wartości, przeprowadza operację i zwraca wartość lub wartości. Funkcje upraszczają i skracają formuły używane w arkuszu, szczególnie te, które przeprowadzają długie lub złożone obliczenia.) ŚREDNIA w programie Microsoft Office Excel.

Opis

Zwraca średnią (arytmetyczną) argumentów. Jeśli na przykład zakres (zakres: Dwie lub większa liczba komórek w arkuszu. Komórki w zakresie mogą być przylegające lub nieprzylegające.) A1:A20 zawiera liczby, formuła =ŚREDNIA(A1:A20) zwraca średnią tych liczb.

Składnia

ŚREDNIA(liczba1; [liczba2]...)

Składnia funkcji ŚREDNIA obejmuje następujące argumenty (argument: Wartość, która dostarcza informacji akcji, zdarzeniu, metodzie, właściwości, funkcji lub procedurze.):

Spostrzeżenia

  • Argumentami mogą być liczby, nazwy, zakresy lub odwołania do komórek, które zawierają liczby.
  • Wartości logiczne i tekstowe reprezentacje liczb wpisane bezpośrednio na liście argumentów są uwzględniane.
  • Jeśli argument zakresu lub odwołania do komórki zawiera tekst, wartości logiczne lub puste komórki, to wartości te są ignorowane. Komórki o wartości zero są jednak uwzględniane w obliczeniach.
  • Argumenty, które są wartościami błędów lub tekstem, którego nie można przekształcić w cyfry, powodują błędy.
  • Aby uwzględnić wartości logiczne i tekstowe reprezentacje liczb w odwołaniu jako część obliczeń, należy użyć funkcji ŚREDNIA.A.
  • Aby obliczyć średnią tylko dla wartości spełniających określone kryteria, należy użyć funkcji ŚREDNIA.JEŻELI lub funkcji ŚREDNIA.WARUNKÓW.

 Uwaga   Funkcja ŚREDNIA sprawdza tendencję centralną, którą jest lokalizacja środka zbioru liczb w rozkładzie statystycznym. Trzy najczęściej używane miary tendencji centralnej to:

  • Średnia — średnia arytmetyczna, obliczana jako suma zbioru wartości podzielona przez ich liczbę. Na przykład średnią liczb 2, 3, 3, 5, 7 i 10 jest wartość 30 podzielona przez 6, czyli 5.
  • Mediana — środkowa liczba w zbiorze wartości (połowa liczb jest większa lub równa medianie, a połowa liczb jest mniejsza lub równa medianie). Na przykład medianą zbioru 2, 3, 3, 5, 7 i 10 jest 4.
  • Wyst.najczęściej — najczęściej występująca wartość w zbiorze (dominanta). Na przykład dominantą zbioru 2, 3, 3, 5, 7 i 10 jest 3.

W przypadku symetrycznego rozkładu zbioru liczb wszystkie trzy miary tendencji centralnej są takie same. W przypadku skośnego rozkładu zbioru liczb miary mogą być różne.

Porada    Przy obliczaniu średniej komórek należy pamiętać o różnicy między komórkami pustymi a komórkami zawierającymi wartości zerowe, szczególnie jeśli pole wyboru Pokaż zero w komórkach o zerowej wartości w oknie dialogowym Opcje programu Excel jest wyczyszczone. Jeśli ta opcja jest zaznaczona, w obliczeniach są uwzględniane wartości zerowe, ale nie są uwzględniane puste komórki.

Aby znaleźć pole wyboru Pokaż zero w komórkach o zerowej wartości:

  • Kliknij przycisk Microsoft Office Obraz przycisku, kliknij przycisk Opcje programu Excel, a następnie w kategorii Zaawansowane przejdź do obszaru Opcje wyświetlania dla tego arkusza.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak skopiować przykład?

  1. Zaznacz przykład w tym artykule. Jeśli kopiujesz przykład w aplikacji Excel Web App, skopiuj i wklej każdą komórkę pojedynczo.

 Ważne   Nie należy zaznaczać nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w Pomocy

Zaznaczanie przykładu w Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. Utwórz pusty skoroszyt lub arkusz.
  3. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V. Jeśli pracujesz w aplikacji Excel Web App, powtórz kopiowanie i wklejanie dla każdej komórki w przykładzie.

 Ważne   Aby przykład działał poprawnie, musi zostać wklejony do komórki A1 w arkuszu.

  1. Aby przełączać się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisz CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.

Po skopiowaniu przykładu do pustego arkusza można dopasować go do własnych potrzeb.


 
1
2
3
4
5
6
7

8

9

10
A B C
Dane
10 15 32
7
9
27
2
Formuła Opis Wynik
=ŚREDNIA(A2:A6) Średnia liczb z komórek od A2 do A6. 11
=ŚREDNIA(A2:A6; 5) Średnia liczb z komórek od A2 do A6 i liczby 5. 10
=ŚREDNIA(A2:C2) Średnia liczb z komórek od A2 do C2. 19
 
 
Dotyczy:
Excel 2007