Obliczanie średniej wartości liczb

Średnia jest również zwana wartością przeciętną.

PokażObliczanie średniej wartości liczb znajdujących się w ciągłym wierszu lub kolumnie

  1. Kliknij komórkę poniżej lub po prawej stronie liczb, dla których chcesz obliczyć średnią.
  2. Kliknij strzałkę obok przycisku Autosumowanie obraz przycisku na standardowym pasku narzędzi (pasek narzędzi: Pasek z przyciskami i opcjami umożliwiającymi wykonywanie poleceń. Aby wyświetlić pasek narzędzi, należy nacisnąć klawisz ALT, a następnie klawisze SHIFT+F10.), kliknij polecenie Średnia, a następnie naciśnij klawisz ENTER.

PokażObliczanie średniej wartości liczb nieznajdujących się w ciągłym wierszu lub kolumnie

Użyj funkcji ŚREDNIA, aby wykonać to zadanie.

Przykład arkusza

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
3
4
5
6
7
A
Dane
10
7
9
27
0
4
Formuła Opis (wynik)
=ŚREDNIA(A2:A7) Uśrednia wszystkie liczby na powyższej liście (9,5)
=ŚREDNIA(A2:A4;A7) Uśrednia trzy pierwsze i ostatnią liczbę na liście (7,5)
=ŚREDNIA(JEŻELI(A2:A7<>0;A2:A7;"")) Uśrednia liczby na liście z wyjątkiem komórek zawierających zero, takich jak komórka A6 (11,4)

 Uwaga    Ostatnia formuła w przykładzie musi być wprowadzona jako formuła tablicowa (formuła tablicowa: Formuła, która przeprowadza wiele obliczeń na jednym lub wielu zestawach wartości, a następnie zwraca jeden lub wiele wyników. Formuły tablicowe są ujęte w nawias klamrowy { }, a wprowadza się je przez naciśnięcie klawiszy CTRL+SHIFT+ENTER.). Po skopiowaniu przykładu do pustego arkusza należy zaznaczyć komórkę A11. Należy nacisnąć klawisz F2, a następnie nacisnąć klawisze CTRL+SHIFT+ENTER. Jeżeli formuła nie jest wprowadzana jako formuła tablicowa, zwracany jest błąd #ARG!.

Szczegóły funkcji

ŚREDNIA

PokażObliczanie średniej ważonej

Użyj funkcji SUMA.ILOCZYNÓW i SUMA do wykonania tego zadania.

Przykład arkusza

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.

Ten przykład oblicza średnią cenę produktu z trzech zakupów, gdzie każdy zakup dotyczy innej liczby produktów przy innej cenie jednostkowej.

 
1
2
3
4
A B
Cena jednostkowa Liczba produktów
20 500
25 750
35 200
Formuła Opis (wynik)
=SUMA.ILOCZYNÓW(A2:A4;B2:B4)/SUMA(B2:B4) Dzieli całkowity koszt wszystkich trzech zamówień przez całkowitą liczbę zamówionych produktów  (24,66)

Szczegóły funkcji

SUMA

SUMA.ILOCZYNÓW

PokażObliczanie średniej wartości liczb z ignorowaniem wartości zerowych (0)

Użyj funkcji ŚREDNIA i JEŻELI do wykonania tego zadania.

Przykład arkusza

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
3
4
5
6
7
A
Dane
10
7
9
27
0
4
Formuła Opis (wynik)
=ŚREDNIA(JEŻELI(A2:A7<>0;A2:A7;"")) Uśrednia liczby na liście z wyjątkiem komórek zawierających zero, takich jak komórka A6 (11,4)

 Uwaga    Formuła w przykładzie musi być wprowadzona jako formuła tablicowa (formuła tablicowa: Formuła, która przeprowadza wiele obliczeń na jednym lub wielu zestawach wartości, a następnie zwraca jeden lub wiele wyników. Formuły tablicowe są ujęte w nawias klamrowy { }, a wprowadza się je przez naciśnięcie klawiszy CTRL+SHIFT+ENTER.). Po skopiowaniu przykładu do pustego arkusza należy zaznaczyć komórkę A9. Należy nacisnąć klawisz F2, a następnie nacisnąć klawisze CTRL+SHIFT+ENTER. Jeżeli formuła nie jest wprowadzana jako formuła tablicowa, zwracany jest błąd #ARG!.

Szczegóły funkcji

ŚREDNIA

JEŻELI

 
 
Dotyczy:
Excel 2003