Obliczanie różnicy między dwiema wartościami czasu

PokażPrzedstawianie wyniku w standardowym formacie czasu (godziny : minuty : sekundy)

Użyj operatora odejmowania (-) do obliczenia różnicy między wartościami czasu i funkcji TEKST do sformatowania wartości czasu.

Godziny nigdy nie przekraczają wartości 24, minuty nigdy nie przekraczają wartości 60, a sekundy nigdy nie przekraczają wartości 60.

Przykład arkusza

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
A B
Początkowa wartość czasu Końcowa wartość czasu
9-6-2007 10:35 AM 9-6-2007 3:30 PM
Formuła Opis (wynik)
=TEKST(B2-A2;"g") Godziny między dwiema wartościami czasu (4).
=TEKST(B2-A2;"g:mm") Godziny i minuty między dwiema wartościami czasu (4:55).
=TEKST(B2-A2;"g:mm:ss") Godziny, minuty i sekundy między dwiema wartościami czasu (4:55:00).

 Uwaga   Można również zastosować format czasu i daty bez użycia funkcji TEKST do określenia formatu. Jeżeli jednak użyty jest zarówno format zastosowany przy użyciu funkcji TEKST, jak i format liczbowy, funkcja TEKST ma większy priorytet.

Szczegóły funkcji

TEKST

PokażPrzedstawianie wyniku jako posumowania opartego na pojedynczej jednostce czasu (120 minut)

Użyj funkcji ZAOKR.DO.CAŁK lub funkcji GODZINA, MINUTA i SEKUNDA do wykonania tego zadania.

Przykład arkusza

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
A B
Początkowa wartość czasu Końcowa wartość czasu
9-6-2007 10:35 AM 10-6-2007 3:30 PM
Formuła Opis (wynik)
=ZAOKR.DO.CAŁK((B2-A2)*24) Całkowite godziny między dwiema wartościami czasu (28).
=(B2-A2)*1440 Całkowite minuty między dwiema wartościami czasu (1735).
=(B2-A2)*86400 Całkowite sekundy między dwiema wartościami czasu (104100).
=GODZINA(B2-A2) Godziny między dwiema wartościami czasu, gdy różnica nie przekracza 24. (4)
=MINUTA(B2-A2) Minuty między dwiema wartościami czasu, gdy różnica nie przekracza 60. (55)
=SEKUNDA(B2-A2) Sekundy między dwiema wartościami czasu, gdy różnica nie przekracza 60. (0)

Szczegóły funkcji

ZAOKR.DO.CAŁK

GODZINA

MINUTA

SEKUNDA

 
 
Dotyczy:
Excel 2003