Konwertowanie wartości czasu

Załóżmy, że trzeba przeliczyć na godziny pięć i pół dnia lub przeliczyć na dni 3,45 roku albo określić liczbę miesięcy między datą początkową a datą końcową. Wartości czasu można konwertować na kilka sposobów.

Co chcesz zrobić?


Konwertowanie jednostek czasu

Do wykonania tego zadania należy użyć funkcji CONVERT.

Przykład

Przykład będzie bardziej zrozumiały, gdy zostanie skopiowany do pustego arkusza.

PokażJak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Zaznacz przykład w temacie Pomocy.

 Uwaga   Nie zaznaczaj nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w temacie Pomocy

Zaznaczanie przykładu w temacie Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć między wyświetlaniem wyników a wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.
 
1
2
A
Dane
6
Formuła Opis (wynik)
=CONVERT(A2;"dzień";"godzina") Konwertuje 6 dni na godziny (144)
=CONVERT(A2;"godzina";"minuta") Konwertuje 6 godzin na minuty (360)
=CONVERT(A2;"rok";"dzień") Konwertuje 6 lat na dni (2191,5)

 Uwaga   W przypadku konwersji wykorzystujących rok przyjmowany jest rok o długości 365,25 dnia.

Szczegóły funkcji

CONVERT

Początek strony Początek strony

Konwertowanie godzin ze standardowego formatu czasu (godziny : minuty : sekundy) na liczbę dziesiętną

Do wykonania tego zadania należy użyć funkcji ZAOKR.DO.CAŁK.

Przykład

Przykład będzie bardziej zrozumiały, gdy zostanie skopiowany do pustego arkusza.

PokażJak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Zaznacz przykład w temacie Pomocy.

 Uwaga   Nie zaznaczaj nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w temacie Pomocy

Zaznaczanie przykładu w temacie Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć między wyświetlaniem wyników a wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.
 
1
2
3
A
Godzina
10:35
12:15
Formuła Opis (wynik)
=(A2-ZAOKR.DO.CAŁK(A2))*24 Liczba godzin, jakie upłynęły od północy (10,583333)
=(A3-ZAOKR.DO.CAŁK(A3))*24 Liczba godzin, jakie upłynęły od północy (12,25)

Szczegóły funkcji

ZAOKR.DO.CAŁK

Początek strony Początek strony

Konwertowanie godzin z liczby dziesiętnej na standardowy format czasu (godziny : minuty : sekundy)

Do wykonania tego zadania należy użyć operatora dzielenia (/) i funkcji TEKST.

Przykład

Przykład będzie bardziej zrozumiały, gdy zostanie skopiowany do pustego arkusza.

PokażJak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Zaznacz przykład w temacie Pomocy.

 Uwaga   Nie zaznaczaj nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w temacie Pomocy

Zaznaczanie przykładu w temacie Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć między wyświetlaniem wyników a wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.
 
1
2
3
A
Godziny
10,5833
12,25
Formuła Opis (wynik)
=TEKST(A2/24, "g:mm") Godzina liczona od północy (10:35)
=TEKST(A3/24, "g:mm") Godzina liczona od północy (12:15)

 Uwaga   Format czasu można także zastosować bez używania funkcji TEKST. Aby wyświetlić liczbę jako wartość czasu, kliknij strzałkę na karcie Narzędzia główne w grupie Liczba, kliknij strzałkę obok pola Format liczby, kliknij pozycję Więcej formatów liczb, kliknij pozycję Niestandardowe na liście Kategoria, a następnie kliknij niestandardowy format w polu Typ. Jeśli jednak format określony za pomocą funkcji TEKST zostanie użyty jednocześnie z formatem liczbowym, funkcja TEKST ma pierwszeństwo.

Szczegóły funkcji

TEKST

Początek strony Początek strony

 
 
Dotyczy:
Excel 2007