JEŻELI

Zwraca jedną wartość, jeśli podany argument zostanie oszacowany jako PRAWDA, albo inną wartość, jeśli argument zostanie oszacowany jako FAŁSZ.

Funkcję JEŻELI należy stosować do przeprowadzania testów logicznych na wartościach i formułach.

Składnia

JEŻELI(test_logiczny;wartość_jeżeli_prawda;wartość_jeżeli_fałsz)

Test_logiczny     to dowolna wartość lub wyrażenie, które można oszacować jako PRAWDA lub jako FAŁSZ. Na przykład A10=100 to wyrażenie logiczne; jeśli wartość umieszczona w komórce A10 równa jest 100, wyrażenie zostanie oszacowane jako PRAWDA. W przeciwnym przypadku wyrażenie zostanie oszacowane jako FAŁSZ. Argument ten może używać dowolnego operatora obliczeń porównawczych.

Wartość_jeżeli_prawda     to wartość, która zwracana jest wtedy, gdy argument test_logiczny ma wartość PRAWDA. Na przykład, jeśli ten argument jest ciągiem tekstowym "W ramach budżetu", a argument test_logiczny ma wartość PRAWDA, funkcja JEŻELI wyświetla tekst "W ramach budżetu". Jeśli argument test_logiczny ma wartość PRAWDA i argument wartość_jeżeli_prawda jest pusty, argument ten zwraca 0 (zero). Aby wyświetlić słowo PRAWDA, należy użyć dla tego argumentu wartości logicznej PRAWDA. Argument wartość_jeżeli_prawda może być inną formułą.

Wartość_jeżeli_fałsz     to wartość, która zwracana jest wtedy, gdy argument test_logiczny ma wartość FAŁSZ. Na przykład, jeśli argument ten jest ciągiem tekstowym "Budżet przekroczony" i argument test_logiczny zostanie oszacowany jako FAŁSZ, funkcja JEŻELI wyświetli tekst "Budżet przekroczony". Jeśli argument test_logiczny równa się FAŁSZ, a argument wartość_jeżeli_fałsz zostanie pominięty, (to znaczy, po argumencie wartość_jeżeli_prawda nie ma średnika), zwracana jest wartość logiczna FAŁSZ. Jeśli argument test_logiczny ma wartość FAŁSZ i argument wartość_jeżeli_fałsz jest pusty (to znaczy, po argumencie wartość_jeżeli_prawda znajduje się średnik poprzedzający zamykający nawias), zwracana jest wartość 0 (zero). Argument wartość_jeżeli_fałsz może być inną formułą.

Spostrzeżenia

Przykład 1

Przykład będzie bardziej zrozumiały, jeśli zostanie skopiowany do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
A
Dane
50
Formuła Opis (wynik)
=JEŻELI(A2<=100;"W ramach budżetu";"Budżet przekroczony") Jeśli powyższa liczba jest mniejsza lub równa 100, formuła wyświetla "W ramach budżetu". W przeciwnym przypadku, funkcja wyświetla "Budżet przekroczony" (W ramach budżetu)
=JEŻELI(A2=100;SUMA(B5:B15);"") Jeśli powyższa liczba równa jest 100, obliczany jest zakres B5:B15. W przeciwnym przypadku, zwracany jest pusty tekst ("") ()

Przykład 2

Przykład będzie bardziej zrozumiały, jeśli zostanie skopiowany do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
3
4
A B
Wydatki bieżące Wydatki przewidywane
1500 900
500 900
500 925
Formuła Opis (wynik)
=JEŻELI(A2>B2;"Budżet przekroczony";"OK") Sprawdza, czy pierwszy wiersz ma wartość budżetu przekroczonego (Budżet przekroczony)
=JEŻELI(A3>B3;"Budżet przekroczony";"OK") Sprawdza, czy drugi wiersz ma wartość budżetu przekroczonego (OK)

Przykład 3

Przykład będzie bardziej zrozumiały, jeśli zostanie skopiowany do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
3
4
A
Wynik
45
90
78
Formuła Opis (wynik)
=JEŻELI(A2>89;"A";JEŻELI(A2>79;"B"; JEŻELI(A2>69;"C";JEŻELI(A2>59;"D";"F")))) Przypisuje literę do pierwszego wyniku (F)
=JEŻELI(A3>89;"A";JEŻELI(A3>79;"B"; JEŻELI(A3>69;"C";JEŻELI(A3>59;"D";"F")))) Przypisuje literę do drugiego wyniku (A)
=JEŻELI(A4>89;"A";JEŻELI(A4>79;"B"; JEŻELI(A4>69;"C";JEŻELI(A4>59;"D";"F")))) Przypisuje literę do trzeciego wyniku (C)

W powyższym przykładzie druga instrukcja JEŻELI jest jednocześnie argumentem wartość_jeżeli_fałsz dla pierwszej instrukcji JEŻELI. Analogicznie trzecia instrukcja JEŻELI jest argumentem wartość_jeżeli_fałsz dla drugiej instrukcji JEŻELI. Na przykład, jeśli pierwszy argument test_logiczny (Średnia>89) ma wartość PRAWDA, zwracane jest "A". Jeśli pierwszy argument test_logiczny ma wartość FAŁSZ, oszacowywana jest druga instrukcja JEŻELI itd.

Litery przypisywane są do liczb z wykorzystaniem następującego klucza.

Jeśli Wynik równa się Zwracane jest
Więcej niż 89 A
Od 80 do 89 B
Od 70 do 79 C
Od 60 do 69 D
Mniej niż 60 F
 
 
Dotyczy:
Excel 2003