Dodawanie liczb

PokażDodawanie liczb

Liczby można dodawać podczas wpisywania ich do komórki. Na przykład należy wpisać w komórce =5+10, aby wyświetlić wynik 15.

PokażDodawanie wszystkich liczb w ciągłym wierszu lub kolumnie

Aby wykonać to zadanie, można użyć przycisku Autosumowanie obraz przycisku.

  1. Kliknij komórkę znajdującą się poniżej kolumny zawierającej liczby lub po prawej stronie wiersza zawierającego liczby.
  2. Kliknij przycisk Autosumowanie obraz przycisku na pasku narzędzi (pasek narzędzi: Pasek z przyciskami i opcjami umożliwiającymi wykonywanie poleceń. Aby wyświetlić pasek narzędzi, należy nacisnąć klawisz ALT, a następnie klawisze SHIFT+F10.) Standardowy, a następnie naciśnij klawisz ENTER.

PokażDodawanie liczb, które nie znajdują się w ciągłym wierszu lub kolumnie

Aby wykonać to zadanie, można użyć funkcji SUMA, co pokazano w następującym przykładzie.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
3
4
5
6
7
A B
Sprzedawca Faktura
Borowik 15 000
Borowik 9 000
Kocoń 8 000
Kocoń 20 000
Borowik 5 000
Zieliński 22 500
Formuła Opis (wynik)
=SUMA(B2:B3;B5) Dodaje 2 faktury na nazwisko Buchanan i jedną na nazwisko Suyama (44 000).
=SUMA(B2;B5;B7) Dodaje indywidualne faktury na nazwisko Buchanan, Suyama i Dodsworth (57 500).

 Uwaga    Funkcja SUMA może zawierać do 30 odwołań do komórek lub zakresów.

Aby uzyskać więcej informacji, zobacz funkcję SUMA.

PokażDodawanie liczb na podstawie pojedynczego warunku

Funkcję SUMA.JEŻELI można wykorzystać do utworzenia całkowitej wartości pojedynczego zakresu na podstawie wartości w innym zakresie, tak jak w następującym przykładzie.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
3
4
5
6
7
A B
Sprzedawca Faktura
Borowik 15 000
Borowik 9 000
Kocoń 8 000
Kocoń 20 000
Borowik 5 000
Zieliński 22 500
Formuła Opis (wynik)
=SUMA.JEŻELI(A2:A7;"Buchanan";B2:B7) Suma faktur na nazwisko Buchanan (29 000).
=SUMA.JEŻELI(B2:B7;">=9 000";B2:B7) Suma faktur na wartość większą niż lub równą 9 000 (66 500).
=SUMA.JEŻELI(B2:B7;"<9 000";B2:B7) Suma faktur na wartość mniejszą niż 9 000 (13 000).

Funkcja SUMA.JEŻELI używa następujących argumentów

Formuła z funkcją SUMA.JEŻELI

Formuła z funkcją SUMA.JEŻELI

Objaśnienie 1   Zakres, którego będą dotyczyć obliczenia: należy sprawdzić komórki, aby ustalić, czy wiersz jest zgodny z kryteriami.

Objaśnienie 2   Kryteria: warunek, który muszą spełniać komórki uwzględniane przy obliczeniach, aby wiersz został uwzględniony w sumie.

Objaśnienie 3   Zakres przeznaczony do zsumowania: liczby znajdujące się w tych komórkach są dodawane, pod warunkiem, że wiersz jest zgodny z warunkiem.

Aby uzyskać więcej informacji, zobacz funkcję SUMA.JEŻELI.

PokażDodawanie liczb na podstawie wielu warunków

Aby wykonać to zadanie, można użyć funkcji JEŻELI i SUMA, tak jak w następującym przykładzie.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
3
4
5
6
7
8
9
10
11
A B C D
Region Sprzedawca Typ Sprzedaż
Południe Borowik Napoje 3 571
Zachód Stępień Nabiał 3 338
Wschód Kocoń Napoje 5 122
Północ Kocoń Nabiał 6 239
Południe Zieliński Produkcja 8 677
Południe Stępień Mięso 450
Południe Stępień Mięso 7 673
Wschód Kocoń Produkcja 664
Północ Stępień Produkcja 1 500
Południe Zieliński Mięso 6 596
Formuła Opis (wynik)
=SUMA(JEŻELI((A2:A11="Południe")*(C2:C11="Mięso");D2:D11)) Suma sprzedaży typu Mięso w regionie Południe (14 719).
=SUMA(JEŻELI((A2:A11="Południe")+(A2:A11="Wschód");D2:D11)) Suma sprzedaży w regionie Południe lub Wschód (32 753).

 Uwaga    Formuła w tym przykładzie musi być wprowadzona w postaci formuły tablicowej (formuła tablicowa: Formuła, która przeprowadza wiele obliczeń na jednym lub wielu zestawach wartości, a następnie zwraca jeden lub wiele wyników. Formuły tablicowe są ujęte w nawias klamrowy { }, a wprowadza się je przez naciśnięcie klawiszy CTRL+SHIFT+ENTER.). Po skopiowaniu przykładu do pustego arkusza należy zaznaczyć komórkę zawierającą formułę, nacisnąć klawisz F2, a następnie nacisnąć klawisze CTRL+SHIFT+ENTER. Jeżeli formuła nie będzie wprowadzona w postaci formuły tablicowej, to zostanie zwrócony błąd #ARG!

Aby uzyskać więcej informacji, zobacz funkcje SUMA i JEŻELI.

PokażDodawanie liczb na podstawie kryteriów przechowywanych w oddzielnym zakresie

Aby wykonać to zadanie, można użyć funkcji BD.SUMA, tak jak w następującym przykładzie.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

PokażJak?

  1. Utwórz pusty skoroszyt lub arkusz.
  2. Wybierz przykład w temacie Pomocy. Nie zaznaczaj nagłówków wierszy ani kolumn.

Wybieranie przykładu z Pomocy

Wybieranie przykładu z Pomocy
  1. Naciśnij klawisze CTRL+C.
  2. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.
  3. Aby przełączyć się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo wskaż polecenie Inspekcja formuł w menu Narzędzia, a następnie kliknij polecenie Tryb inspekcji formuł.
 
1
2
3
4
5
6
7
8
9
10
11
A B C D
Region Sprzedawca Typ Sprzedaż
Południe Borowik Napoje 3 571
Zachód Stępień Nabiał 3 338
Wschód Kocoń Napoje 5 122
Północ Kocoń Nabiał 6 239
Południe Zieliński Produkcja 8 677
Południe Stępień Mięso 450
Południe Stępień Mięso 7 673
Wschód Kocoń Produkcja 664
Północ Stępień Produkcja 1 500
Południe Zieliński Mięso 6 596
Region Sprzedawca Typ Sprzedaż
Południe Mięso
Produkcja
Formuła Opis (wynik)
=BD.SUMA(A1:D11;"Sprzedaż";A12:D13) Suma sprzedaży typu Mięso w regionie Południe (14 719).
=BD.SUMA(A1:D11;"Sprzedaż";A12:D14) Suma sprzedaży typu Mięso i Produkcja w regionie Południe (25 560).

Funkcja BD.SUMA używa następujących argumentów.

Formuła z funkcją BD.SUMA

Objaśnienie 1   Zakres, dla którego wykonywane są obliczenia: lista zawierająca liczby przeznaczone do zsumowania.

Objaśnienie 2   Pole: etykieta kolumny przeznaczonej do zsumowania.

Objaśnienie 3   Kryteria: zakres komórek zawierający warunki.

Aby uzyskać więcej informacji, zobacz funkcję BD.SUMA.

PokażDodawanie liczb na podstawie wielu kryteriów za pomocą Kreatora sum warunkowych

Chcąc podsumować wartości na liście (lista: Seria wierszy zawierających powiązane dane lub wyznaczonych do działania jako arkusz danych za pomocą polecenia Utwórz listę.) na podstawie określonych warunków, można użyć Kreatora sum warunkowych. Na przykład, jeżeli lista zawiera wartości sprzedaży uzyskane przez różnych sprzedawców, to dodatek (dodatek: Program uzupełniający, który dodaje niestandardowe polecenia lub funkcje do pakietu Microsoft Office.) Kreator sum warunkowych może pomóc utworzyć formułę służącą do obliczania całkowitej wartości sprzedaży uzyskanej przez jednego sprzedawcę.

  1. Kliknij komórkę na liście.
  2. W menu Narzędzia wskaż polecenie Kreator, a następnie kliknij polecenie Sum warunkowych.

Jeśli w podmenu Kreator menu Narzędzia brakuje polecenia Sum warunkowych, należy załadować dodatek Kreator sum warunkowych.

PokażJak?

  1. W menu Narzędzia kliknij polecenie Dodatki.
  2. Jeśli żądany dodatek (dodatek: Program uzupełniający, który dodaje niestandardowe polecenia lub funkcje do pakietu Microsoft Office.) nie znajduje się na liście w polu Dostępne dodatki, kliknij przycisk Przeglądaj, a następnie zlokalizuj dodatek. 
  3. W polu Dostępne dodatki zaznacz pole wyboru obok dodatku, który chcesz załadować, a następnie kliknij przycisk OK.
  4. W razie potrzeby postępuj według instrukcji wyświetlanych przez program instalacyjny.
  1. Postępuj według instrukcji wyświetlanych przez kreatora.

 Uwaga    Formuły utworzone przez Kreatora sum warunkowych są formułami tablicowymi (formuła tablicowa: Formuła, która przeprowadza wiele obliczeń na jednym lub wielu zestawach wartości, a następnie zwraca jeden lub wiele wyników. Formuły tablicowe są ujęte w nawias klamrowy { }, a wprowadza się je przez naciśnięcie klawiszy CTRL+SHIFT+ENTER.). Po edycji formuł tego typu należy nacisnąć klawisze CTRL+SHIFT+ENTER, aby je zablokować.

 
 
Dotyczy:
Excel 2003