Voorwaardelijke formules maken

Vaak dient u bij het uitvoeren van taken te controleren of voorwaarden waar of onwaar zijn en dient u logische vergelijkingen te maken tussen expressies. U kunt de functies EN, OF, NIET en ALS gebruiken om voorwaardelijke formules te maken.

De functie ALS heeft de volgende argumenten.


Formule met de functie ALS

Formule met de functie ALS

Toelichting 1  logische_test: de voorwaarde die u wilt controleren.

Toelichting 2  waarde_als_waar: de waarde die moet worden weergegeven als aan de voorwaarde wordt voldaan.

Toelichting 3  waarde_als_onwaar: de waarde die moet worden weergegeven als niet aan de voorwaarde wordt voldaan.


Wat wilt u doen?


Een voorwaardelijke formule maken die een logische waarde (WAAR of ONWAAR) oplevert

Gebruik de functies EN, OF en NIET, en operators (operator: een teken of symbool dat het type berekening aangeeft dat in een expressie moet worden uitgevoerd. Er zijn rekenkundige operatoren, vergelijkingsoperatoren, logische operatoren en verwijzingsoperatoren.) om deze taak uit te voeren.

Voorbeeld

Het voorbeeld is mogelijk beter te begrijpen als u het naar een leeg werkblad kopieert.

WeergevenEen voorbeeld kopiëren

  1. Maak een lege werkmap of een leeg werkblad.
  2. Selecteer het voorbeeld in het Help-onderwerp.

 Opmerking   Selecteer geen rij- of kolomkoppen. 

Een voorbeeld selecteren in een Help-onderwerp

Een voorbeeld selecteren in een Help-onderwerp
  1. Druk op CTRL+C.
  2. Selecteer cel A1 in het werkblad en druk op CTRL+V.
  3. Als u afwisselend de resultaten en de bijbehorende formules wilt weergeven, drukt u op CTRL+` (accent grave). U kunt ook op de knop Formules weergeven klikken in de groep Formules controleren op het tabblad Formules.
 
1
2
3
4
A
Gegevens
15
9
8
Raderen
Apparaatjes
Formule Beschrijving (resultaat)
=EN(A2>A3; A2<A4) Is 15 groter dan 9 en kleiner dan 8? (ONWAAR)
=OF(A2>A3; A2<A4) Is 15 groter dan 9 of kleiner dan 8? (WAAR)
=NIET(A2+A3=24) Is 15 plus 9 niet gelijk aan 24? (ONWAAR)
=NIET(A5="Raderen") Is A5 niet gelijk aan "Raderen"? (ONWAAR)
=OF(A5<>"Raderen";A6 = "Apparaatjes") Is A5 niet gelijk aan "Raderen" of is A6 gelijk aan "Apparaatjes"? (WAAR)

Informatie over functies

EN

OF

NIET

Terug naar boven Terug naar boven

Een voorwaardelijke formule maken die tot een andere berekening leidt of tot andere waarden dan WAAR of ONWAAR

Gebruik de functies ALS, EN en OF om deze taak uit te voeren.

Voorbeeld

Het voorbeeld is mogelijk beter te begrijpen als u het naar een leeg werkblad kopieert.

WeergevenEen voorbeeld kopiëren

  1. Maak een lege werkmap of een leeg werkblad.
  2. Selecteer het voorbeeld in het Help-onderwerp.

 Opmerking   Selecteer geen rij- of kolomkoppen. 

Een voorbeeld selecteren in een Help-onderwerp

Een voorbeeld selecteren in een Help-onderwerp
  1. Druk op CTRL+C.
  2. Selecteer cel A1 in het werkblad en druk op CTRL+V.
  3. Als u afwisselend de resultaten en de bijbehorende formules wilt weergeven, drukt u op CTRL+` (accent grave). U kunt ook op de knop Formules weergeven klikken in de groep Formules controleren op het tabblad Formules.
 
1
2
3
4
A
Gegevens
15
9
8
Raderen
Apparaatjes
Formule Beschrijving (resultaat)
=ALS(A2=15; "OK"; "Niet OK") Als de waarde in cel A2 gelijk is aan 15, dan "OK" als resultaat geven. (OK)
=ALS(A2<>15; "OK"; "Niet OK") Als de waarde in cel A2 niet gelijk is aan 15, dan "OK" als resultaat geven. (Niet OK)
=ALS(NIET(A2<=15); "OK"; "Niet OK") Als de waarde in cel A2 niet kleiner dan of gelijk is aan 15, dan "OK" als resultaat geven. (Niet OK)
=ALS(A5<>"RADEREN"; "OK"; "Niet OK") Als de waarde in cel A5 niet gelijk is aan "RADEREN", dan "OK" als resultaat geven. (Niet OK)
=ALS(EN(A2>A3; A2<A4); "OK"; "Niet OK") Als 15 groter is dan 9 en kleiner dan 8, dan "OK" als resultaat geven. (Niet OK)
=ALS(EN(A2<>A3; A2<>A4); "OK"; "Niet OK") Als 15 niet gelijk is aan 9 en 15 niet gelijk is aan 8, dan "OK" als resultaat geven. (OK)
=ALS(OF(A2>A3; A2<A4); "OK"; "Niet OK") Als 15 groter is dan 9 of kleiner dan 8, dan "OK" als resultaat geven. (OK)
=ALS(OF(A5<>"Raderen"; A6<>"Apparaatjes"); "OK"; "Niet OK") Als de waarde in cel A5 niet gelijk is aan "Raderen" of als de waarde in cel A6 niet gelijk is aan "Apparaatjes", dan "OK" als resultaat geven. (Niet OK)
=ALS(OF(A2<>A3; A2<>A4); "OK"; "Niet OK") Als 15 niet gelijk is aan 9 of 15 niet gelijk is aan 8, dan "OK" als resultaat geven. (OK)

Informatie over functies

ALS

EN

OF

Terug naar boven Terug naar boven

 
 
Van toepassing op:
Excel 2007