VERT.ZOEKEN

Zoekt naar een waarde in de eerste kolom van een tabelmatrix en geeft als resultaat een waarde uit dezelfde rij in een andere kolom in de tabelmatrix.

De afkorting VERT in VERT.ZOEKEN verwijst naar verticaal. Gebruik VERT.ZOEKEN in plaats van HORIZ.ZOEKEN als de vergelijkingswaarden zich in een kolom links van de gegevens bevinden die u zoekt.

Syntaxis

VERT.ZOEKEN(zoekwaarde;tabelmatrix;kolomindex_getal;benaderen)

zoekwaarde    De zoekwaarde in de eerste kolom van de tabelmatrix (matrix: wordt gebruikt om enkelvoudige formules te maken die meerdere resultaten geven of die worden toegepast op een groep argumenten die in rijen en kolommen zijn gerangschikt. Een matrixbereik heeft een gemeenschappelijke formule; een matrixconstante is een groep constanten die als argument wordt gebruikt.). Zoekwaarde kan een waarde of een verwijzing zijn. Als zoekwaarde kleiner is dan de kleinste waarde in de eerste kolom van tabelmatrix, geeft VERT.ZOEKEN de foutwaarde #N/B als resultaat.

tabelmatrix    Twee of meer kolommen met gegevens. U kunt een verwijzing naar een bereik of een bereiknaam opgeven. De waarden in de eerste kolom van tabelmatrix zijn de waarden waar zoekwaarde naar zoekt. Dit kunnen tekst, getallen of logische waarden zijn. Bij tekstwaarden wordt geen onderscheid gemaakt tussen hoofdletters en kleine letters.

kolomindex_getal    Het kolomnummer in tabelmatrix van waaruit de overeenkomstige waarde moet worden geleverd. Als kolomindex_getal 1 is, wordt de waarde uit de eerste kolom in tabelmatrix opgehaald. Als kolomindex_getal 2 is, wordt de waarde opgehaald uit de tweede kolom, enzovoort. Als kolomindex_getal:

  • kleiner is dan 1, geeft VERT.ZOEKEN de foutwaarde #WAARDE! als resultaat.
  • groter is dan het aantal kolommen in tabelmatrix, geeft VERT.ZOEKEN de foutwaarde #VERW! als resultaat.

benaderen     is een logische waarde die aangeeft of VERT.ZOEKEN wel of niet exact overeenkomende waarden moet zoeken:

  • Als benaderen WAAR is of wordt weggelaten, wordt er een exact of een niet-exact overeenkomende waarde gevonden. Wanneer er geen exacte overeenkomst wordt gevonden, wordt de volgende hoogste waarde die kleiner is dan zoekwaarde als resultaat gegeven.

De waarden in de eerste kolom van tabelmatrix moeten in oplopende volgorde zijn gesorteerd, anders geeft VERT.ZOEKEN wellicht niet de juiste waarde als resultaat. Zie Gegevens sorteren voor meer informatie.

  • Als benaderen ONWAAR is, wordt er alleen naar een exacte overeenkomst gezocht. In dit geval hoeft u de waarden in de eerste kolom van tabelmatrix niet te sorteren. Wanneer er twee of meer waarden in de eerste kolom van tabelmatrix overeenkomen met de zoekwaarde, wordt de eerst gevonden waarde gebruikt. Wanneer er geen exacte overeenkomst wordt gevonden, resulteert de functie in de foutwaarde #N/B.

Aanvullende informatie

  • Wanneer u in de eerste kolom van tabelmatrix naar tekstwaarden zoekt, dient u ervoor te zorgen dat de gegevens in de eerste kolom van tabelmatrix geen voorloop- of volgspaties en geen niet-afdrukbare tekens bevatten, en dat rechte en gekrulde aanhalingstekens (enkel en dubbel) op consistente wijze worden gebruikt. Anders kan VERT.ZOEKEN een onjuist of onverwacht resultaat opleveren. Zie WISSEN.CONTROL en SPATIES.WISSEN voor meer informatie.
  • Wanneer u naar getal- of datumwaarden zoekt, dient u ervoor te zorgen dat de gegevens in de eerste kolom van tabelmatrix niet zijn opgeslagen als tekstwaarden. VERT.ZOEKEN kan in dat geval een onjuist of onverwacht resultaat opleveren. Zie Als tekst opgeslagen getallen converteren naar getallen voor meer informatie.
  • Als benaderen ONWAAR is en zoekwaarde tekst is, kunt u een vraagteken (?) of een sterretje (*) gebruiken als jokertekens in zoekwaarde. Een vraagteken vervangt een willekeurig teken, een sterretje vervangt een willekeurige tekenreeks. Als u echt een vraagteken of een sterretje wilt zoeken, moet u een tilde (~) voor dat teken typen.

Voorbeeld 1

Het voorbeeld is mogelijk beter te begrijpen als u het naar een leeg werkblad kopieert.

WeergevenEen voorbeeld kopiëren

  1. Maak een lege werkmap of een leeg werkblad.
  2. Selecteer het voorbeeld in het Help-onderwerp.

 Opmerking   Selecteer geen rij- of kolomkoppen. 

Een voorbeeld selecteren in een Help-onderwerp

Een voorbeeld selecteren in een Help-onderwerp
  1. Druk op CTRL+C.
  2. Selecteer cel A1 in het werkblad en druk op CTRL+V.
  3. Als u afwisselend de resultaten en de bijbehorende formules wilt weergeven, drukt u op CTRL+` (accent grave). U kunt ook op de knop Formules weergeven klikken in de groep Formules controleren op het tabblad Formules.

In het voorbeeld wordt in de kolom Densiteit van een atmosferische-kenmerkentabel gezocht naar overeenkomende waarden in de kolommen Viscositeit en Temperatuur. (De waarden verwijzen naar lucht bij 0 graden Celsius op zeeniveau, ofwel 1 atmosfeer.)

 
1
2
3
4
5
6
7
8
9
10
A B C
Densiteit Viscositeit Temperatuur
0,457 3,55 500
0,525 3,25 400
0,616 2,93 300
0,675 2,75 250
0,746 2,57 200
0,835 2,38 150
0,946 2,17 100
1,09 1,95 50
1,29 1,71 0
Formule Beschrijving (resultaat)
=VERT.ZOEKEN(1;A2:C10;2) Gebruikt een benadering van de zoekwaarde en zoekt naar de waarde 1 in kolom A, vindt de hoogste waarde in kolom A die kleiner is dan of gelijk is aan 1, namelijk 0,946, en geeft de waarde uit kolom B in dezelfde rij als resultaat (2,17)
=VERT.ZOEKEN(1;A2:C10;3;WAAR) Gebruikt een benadering van de zoekwaarde en zoekt naar de waarde 1 in kolom A, vindt de hoogste waarde in kolom A die kleiner is dan of gelijk is aan 1, namelijk 0,946, en geeft de waarde uit kolom C in dezelfde rij als resultaat (100)
=VERT.ZOEKEN(,7;A2:C10;3;ONWAAR) Gebruikt een exacte overeenkomst en zoekt naar de waarde ,7 in kolom A. Omdat geen exacte overeenkomst in kolom A wordt gevonden, wordt een fout als resultaat gegeven (#N/B)
=VERT.ZOEKEN(0,1;A2:C10;2;WAAR) Gebruikt een benadering van de zoekwaarde en zoekt naar de waarde 0,1 in kolom A. Aangezien 0,1 kleiner is dan de kleinste waarde in kolom A, wordt er een fout als resultaat gegeven (#N/B)
=VERT.ZOEKEN(2;A2:C10;2;WAAR) Gebruikt een benadering van de zoekwaarde en zoekt naar de waarde 2 in kolom A, vindt de hoogste waarde in kolom A die kleiner is dan of gelijk is aan 2, namelijk 1,29, en geeft de waarde uit kolom B in dezelfde rij als resultaat (1,71)

Voorbeeld 2

Het voorbeeld is mogelijk beter te begrijpen als u het naar een leeg werkblad kopieert.

WeergevenEen voorbeeld kopiëren

  1. Maak een lege werkmap of een leeg werkblad.
  2. Selecteer het voorbeeld in het Help-onderwerp.

 Opmerking   Selecteer geen rij- of kolomkoppen. 

Een voorbeeld selecteren in een Help-onderwerp

Een voorbeeld selecteren in een Help-onderwerp
  1. Druk op CTRL+C.
  2. Selecteer cel A1 in het werkblad en druk op CTRL+V.
  3. Als u afwisselend de resultaten en de bijbehorende formules wilt weergeven, drukt u op CTRL+` (accent grave). U kunt ook op de knop Formules weergeven klikken in de groep Formules controleren op het tabblad Formules.

In dit voorbeeld wordt de kolom Artikel-id van een tabel met babyartikelen doorzocht en worden de waarden in de kolommen Prijs en Winstmarge vergeleken om prijzen en testvoorwaarden te berekenen.

 
1
2
3
4
5
6
A B C D
Artikel-id Artikel Prijs Winstmarge
ST-340 Buggy € 145,67 30%
BI-567 Slabbetje € 3,56 40%
DI-328 Luiers € 21,45 35%
WI-989 Natte doekjes € 5,12 40%
AS-469 Fopspeen € 2,56 45%
Formule Beschrijving (resultaat)
= VERT.ZOEKEN("DI-328";A2:D6;3;ONWAAR) * (1 + VERT.ZOEKEN("DI-328";A2:D6; 4;ONWAAR)) Berekent de verkoopprijs van luiers door het winstmargepercentage op te tellen bij de prijs (€ 28,96)
= (VERT.ZOEKEN("WI-989";A2:D6;3;ONWAAR) * (1 + VERT.ZOEKEN("WI-989";A2:D6;4;ONWAAR))) * (1 - 20%) Berekent de verkoopprijs van natte doekjes door een opgegeven korting van de verkoopprijs af te trekken (€ 5,73)
= ALS(VERT.ZOEKEN(A2;A2:D6;3;ONWAAR) >= 20, "Winstmarge is " & 100 * VERT.ZOEKEN(A2;A2:D6;4;ONWAAR) &"%", "Prijs is lager dan € 20,00") Wanneer de prijs van een artikel hoger is dan of gelijk is aan € 20,00, wordt de tekenreeks "Winstmarge is nn%" weergegeven. Anders wordt de tekenreeks "Prijs is lager dan € 20,00" weergegeven (Winstmarge is 30%)
= ALS(VERT.ZOEKEN(A3;A2:D6;3;ONWAAR) >= 20, "Winstmarge is: " & 100 * VERT.ZOEKEN(A3;A2:D6;4;ONWAAR) &"%";"Prijs is €" &VERT.ZOEKEN(A3;A2:D6;3;ONWAAR)) Wanneer de prijs van een artikel hoger is dan of gelijk is aan € 20,00, wordt de tekenreeks "Winstmarge is nn%" weergegeven. Anders wordt de tekenreeks "Prijs is € n,nn" weergegeven (Prijs is € 3,56)

Voorbeeld 3

Het voorbeeld is mogelijk beter te begrijpen als u het naar een leeg werkblad kopieert.

WeergevenEen voorbeeld kopiëren

  1. Maak een lege werkmap of een leeg werkblad.
  2. Selecteer het voorbeeld in het Help-onderwerp.

 Opmerking   Selecteer geen rij- of kolomkoppen. 

Een voorbeeld selecteren in een Help-onderwerp

Een voorbeeld selecteren in een Help-onderwerp
  1. Druk op CTRL+C.
  2. Selecteer cel A1 in het werkblad en druk op CTRL+V.
  3. Als u afwisselend de resultaten en de bijbehorende formules wilt weergeven, drukt u op CTRL+` (accent grave). U kunt ook op de knop Formules weergeven klikken in de groep Formules controleren op het tabblad Formules.

In dit voorbeeld wordt de id-kolom van een werknemerstabel doorzocht en worden de waarden in andere kolommen vergeleken om de leeftijd te controleren en te testen op foutwaarden.

 
1
2
3
4
5
6
7
A B C D E
ID Achternaam Voornaam Titel Geboortedatum
1 Veninga Tjeerd Vertegenwoordiger 08-12-1968
2 Cool Jeroen Adjunct-directeur 19-02-1952
3 Overeem Pascaline Verkoopmedewerker 30-08-1963
4 Splinter Koos Vertegenwoordiger 19-09-1958
5 Blaauboer Nils Verkoopmanager 04-03-1955
6 Beekman Dick Vertegenwoordiger 02-07-1963
Formule Beschrijving (resultaat)
=INTEGER(JAAR.DEEL(DATUM(2004;6;30);VERT.ZOEKEN(5;A2:E7;5;ONWAAR);1)) Zoekt in het belastingjaar 2004 naar de leeftijd van de werknemer met ID 5. Gebruikt de functie JAAR.DEEL om de geboortedatum van het fiscale jaar af te trekken en geeft met gebruik van de functie INTEGER als resultaat een geheel getal weer (49)
=ALS(ISNB(VERT.ZOEKEN(5;A2:E7;2;ONWAAR)) = WAAR; "Werknemer niet gevonden"; VERT.ZOEKEN(5;A2:E7;2;ONWAAR))

Als er een werknemer met de werknemer-id 5 is, dan wordt de achternaam van de werknemer weergegeven. Anders wordt het bericht 'Werknemer niet gevonden' weergegeven (Blaauboer)

De functie ISNB geeft de waarde WAAR als resultaat wanneer de functie VERT.ZOEKEN de foutwaarde #NB levert

=ALS(ISNB(VERT.ZOEKEN(15;A3:E8;2;ONWAAR)) = WAAR; "Werknemer niet gevonden"; VERT.ZOEKEN(15;A3:E8;2;ONWAAR))

Als er een werknemer met de werknemer-id 15 is, dan wordt de achternaam van de werknemer weergegeven. Anders wordt het bericht 'Werknemer niet gevonden' weergegeven (Werknemer niet gevonden)

De functie ISNB geeft de waarde WAAR als resultaat wanneer de functie VERT.ZOEKEN de foutwaarde #NB levert

=VERT.ZOEKEN(4;A2:E7;3;ONWAAR) & " " & VERT.ZOEKEN(4;A2:E7;2;ONWAAR) & " is een " & VERT.ZOEKEN(4,A2:E7,4,ONWAAR) & "." Voegt de waarden van drie cellen samen tot een volledige zin voor de werknemer met werknemer-id 4 (Koos Splinter is een vertegenwoordiger.)
 
 
Van toepassing op:
Excel 2007