Formules corrigeren

Microsoft Excel bevat diverse hulpprogramma's waarmee u fouten in formules kunt zoeken en corrigeren.

WeergevenVenster Controle

Met de werkbalk (werkbalk: een balk met knoppen en opties die u kunt gebruiken om opdrachten uit te voeren. U kunt een werkbalk weergeven door op ALT en vervolgens op SHIFT+F10 te klikken.) Venster Controle kunt u cellen en hun formules (formule: een opeenvolging van waarden, celverwijzingen, namen, functies of operatoren in een cel die samen een nieuwe waarde produceren. Een formule begint altijd met een gelijkteken (=).) controleren, zelfs als de cellen niet zichtbaar zijn.

Venster Controle

Venster Controle

Deze werkbalk kan net als alle andere werkbalken worden verplaatst of vergrendeld (in dok: op een vaste plaats aan de bovenkant, onderkant of zijkant van het venster. U kunt een taakvenster, werkset, menubalk en alle werkbalken in een dok plaatsen.). U kunt de werkbalk bijvoorbeeld onder in het venster plaatsen. Met behulp van deze werkbalk kunt u de volgende eigenschappen van een cel bijhouden: werkmap, blad, naam, cel, waarde en formule.

U kunt per cel slechts één controle uitvoeren.

WeergevenFoutcontrole voor formules

Net als bij grammaticacontrole worden er in Excel bepaalde regels gehanteerd voor het controleren van formules. Deze regels garanderen niet dat uw werkblad geen fouten bevat, maar ze zorgen er wel voor dat de meestvoorkomende fouten worden achterhaald. U kunt deze regels afzonderlijk in- of uitschakelen.

Fouten kunnen op twee manieren worden gecontroleerd: één tegelijk zoals bij een spellingcontrole, of direct tijdens het werken in het werkblad. Als er een fout is gevonden, wordt er in de linkerbovenhoek van de cel een driehoek weergegeven. Beide methodes beschikken over dezelfde opties.

Cel met een formulefout

Cel met een formulefout

U kunt een fout oplossen of negeren met behulp van de weergegeven opties. Als u een fout negeert, wordt deze in verdere foutcontroles niet meer weergegeven. Alle voorgaande genegeerde fouten kunnen echter wel worden hersteld, zodat ze opnieuw worden weergegeven.

De regels en waarop deze controleren

Foutwaarden als resultaat       In de formule wordt niet de verwachte syntaxis, argumenten (argument: de waarden die bij een functie worden gebruikt om bewerkingen of berekeningen uit te voeren. Voor elke functie kunnen bepaalde typen argumenten worden gebruikt. Veelvoorkomende argumenten voor functies zijn getallen, tekst, celverwijzingen en namen.) of gegevenstypen gebruikt. Mogelijke foutwaarden zijn: #DEEL/0!, #N/B, #NAAM?, #LEEG!, #GETAL!, #VERW! en #WAARDE!. Alle foutwaarden hebben verschillende oorzaken en worden op verschillende wijzen opgelost.

 Opmerking   Als u een foutwaarde direct in een cel typt, wordt deze niet als fout gemarkeerd.

Tekstdatum met 2-cijferig jaartal       De cel bevat een tekstdatum die bij gebruik in formules verkeerd kan worden geïnterpreteerd. De datum in de formule =JAAR("1/1/31") zou bijvoorbeeld 1931 of 2031 kunnen zijn. Gebruik deze regel voor controle van dubbelzinnige tekstdatums.

Getal opgeslagen als tekst       De cel bevat getallen die zijn opgeslagen als tekst. Deze getallen zijn meestal afkomstig uit gegevens die uit andere bronnen zijn geïmporteerd. Getallen die zijn opgeslagen als tekst kunnen onverwachte problemen veroorzaken bij het sorteren en kunnen daarom het beste naar getallen worden geconverteerd.

WeergevenInconsistente formule in bereik

De formule komt niet overeen met het patroon van andere formules in hetzelfde gebied. Vaak beschikken formules alleen over andere verwijzingen dan aangrenzende formules. De formule =SOM(A10:F10) kan bijvoorbeeld worden opgemerkt omdat de verwijzingen van aangrenzende formules één rij wijzigen en deze verwijzing 8 rijen wijzigt.

Formules
=SOM(A1:F1)
=SOM(A2:F5)
=SOM(A10:F10)
=SOM(A4:F4)

Als de verwijzingen die in een formule worden gebruikt niet consistent zijn met de verwijzingen in aangrenzende formules wordt het probleem opgemerkt.

WeergevenFormule slaat cellen in bereik over

De formule bevat mogelijk onjuiste verwijzingen. Als u cellen onder aan of rechts van het bereik toevoegt en de formule naar een cellenbereik verwijst, zijn de verwijzingen mogelijk niet meer correct. De verwijzingen worden door de formule niet altijd automatisch aangepast aan de nieuwe cellen. In deze regel wordt de verwijzing van een formule vergeleken met de aangrenzende cellen. Als de aangrenzende cellen meer cijfers bevatten (en geen lege cellen zijn), wordt het probleem opgemerkt.

De formule =SOM(A2:A4) zou door deze regel worden opgemerkt, omdat A5, A6 en A7 aangrenzend zijn en gegevens bevatten.

Factuur
15.000
9.000
8.000
20.000
5000
22.500
=SOM(A2:A4)

WeergevenNiet-vergrendelde cellen bevatten formules

De formule is niet vergrendeld om deze te beveiligen. Standaard zijn alle cellen ter beveiliging vergrendeld, dus moet de beveiliging van de cel zijn uitgeschakeld. Als een formule beveiligd is, moet de beveiliging worden uitgeschakeld voordat u deze kunt wijzigen. Controleer of het gewenst is dat de cel onbeveiligd is. Als u cellen met formules beveiligt, kunnen deze niet worden gewijzigd en voorkomt u fouten.

WeergevenFormules verwijzen naar lege cellen

De formule bevat een verwijzing naar een lege cel. Dit kan onjuiste resultaten opleveren, zoals in het volgende voorbeeld.

Stel dat u het gemiddelde van de onderstaande getallen wilt berekenen. Als de derde cel van boven leeg is, is het resultaat 22,75. Als de derde cel van boven echter een 0 bevat, is het resultaat 18,2.

Gegevens
24
12
45
10
Formule
=GEMIDDELDE(A2:A6)

WeergevenDe werkbalk Formules controleren

Gebruik de werkbalk (werkbalk: een balk met knoppen en opties die u kunt gebruiken om opdrachten uit te voeren. U kunt een werkbalk weergeven door op ALT en vervolgens op SHIFT+F10 te klikken.) Formules controleren om de relaties tussen cellen en formules grafisch weer te geven of aan te wijzen door middel van blauwe pijlen. U kunt de broncellen (de cellen die gegevens voor een bepaalde cel bevatten) of de doelcellen (de cellen die afhankelijk zijn van de waarde in een bepaalde cel) aanwijzen.

Werkblad met controlepijlen

Werkblad met controlepijlen

WeergevenFormule evalueren

In het dialoogvenster Formule evalueren (werkbalk (werkbalk: een balk met knoppen en opties die u kunt gebruiken om opdrachten uit te voeren. U kunt een werkbalk weergeven door op ALT en vervolgens op SHIFT+F10 te klikken.) Formules controleren ) kunt u de verschillende gedeelten van een geneste formule (formule: een opeenvolging van waarden, celverwijzingen, namen, functies of operatoren in een cel die samen een nieuwe waarde produceren. Een formule begint altijd met een gelijkteken (=).) evalueren door te kijken naar de volgorde waarin de formule wordt berekend. U kunt dit bijvoorbeeld zien in de volgende formule waar de functie GEMIDDELDE(F2:F5) wordt weergegeven als de waarde 80.

=ALS(GEMIDDELDE(F2:F5)>50;SOM(G2:G5);0) als

=ALS(80>50;SOM(G2:G5);0)

Opmerkingen

  • Sommige gedeelten van formules die de functies ALS en KIEZEN gebruiken, worden niet geëvalueerd. In het vak Evaluatie wordt dan de foutwaarde #N/B weergegeven.
  • Als een verwijzing leeg is, wordt er in het vak Evaluatie een nulwaarde (0) weergegeven.
  • De volgende functies worden opnieuw berekend als het werkblad wordt gewijzigd, en kunnen veroorzaken dat de resultaten van het evalueren anders zijn dan wat er in de cel wordt weergegeven. ASELECT, BEREIKEN, INDEX, VERSCHUIVING, CEL, INDIRECT, RIJEN, KOLOMMEN, NU, VANDAAG en ASELECTTUSSEN.
 
 
Van toepassing op:
Excel 2003