ALS

Geeft een bepaalde waarde als resultaat als een voorwaarde die u hebt opgegeven, resulteert in WAAR. Als die voorwaarde resulteert in ONWAAR, geeft de functie een andere waarde als resultaat.

Met ALS kunt u conditionele tests uitvoeren op waarden en formules.

Syntaxis

ALS(logische_test;waarde-als-waar;waarde-als-onwaar)

logische_test     is een waarde of expressie die resulteert in de waarde WAAR of ONWAAR. Zo is A10=100 een logische expressie: als de waarde in cel A10 gelijk is aan 100, resulteert de expressie in de waarde WAAR; in het andere geval is het resultaat ONWAAR. In dit argument kunt u alle vergelijkingsoperatoren gebruiken.

waarde-als-waar     is de waarde die wordt geretourneerd als logische_test WAAR is. Als dit argument bijvoorbeeld de tekenreeks "Binnen het budget" is, en het argument logische_test de waarde WAAR oplevert, geeft de functie ALS de tekst "Binnen het budget" weer. Als logische_test WAAR is, en waarde-als-waar leeg is, resulteert dit argument in de waarde 0 (nul). U kunt het woord WAAR weergeven door de logische waarde WAAR te gebruiken voor dit argument. waarde-als-waar kan ook een andere formule zijn.

waarde-als-onwaar       is de waarde die wordt geretourneerd als logische_test ONWAAR is. Als dit argument bijvoorbeeld de tekenreeks "Budget overschreden" is, en het argument logische_test de waarde ONWAAR oplevert, geeft de functie ALS de tekst "Budget overschreden" weer. Als logische_test ONWAAR is, en waarde-als-onwaar is weggelaten (er staat geen komma achter waarde-als-waar), wordt de logische waarde ONWAAR geretourneerd. Als logische_test ONWAAR is, en waarde-als-onwaar leeg is (er staat een komma achter waarde-als-waar, gevold door het haakje sluiten), wordt de 0 (nul) geretourneerd. waarde-als-onwaar kan ook een andere formule zijn.

Aanvullende informatie

Voorbeeld 1

Het voorbeeld is mogelijk beter te begrijpen als u het naar een leeg werkblad kopieert.

WeergevenWerkwijze

  1. Maak een lege werkmap of een leeg werkblad.
  2. Selecteer het voorbeeld in het Help-onderwerp. Selecteer geen rij- of kolomkoppen. 

Een voorbeeld selecteren in een Help-onderwerp

Een voorbeeld selecteren in een Help-onderwerp
  1. Druk op CTRL+C.
  2. Selecteer cel A1 in het werkblad en druk op CTRL+V.
  3. Als u afwisselend de resultaten en de bijbehorende formules wilt weergeven, drukt u op CTRL+` (accent grave). U kunt ook de optie Formules controleren aanwijzen in het menu Extra en vervolgens op Controlemodus voor formules klikken.
 
1
2
A
Gegevens
50
Formule Beschrijving (resultaat)
=ALS(A2<=100;"Binnen het budget";"Budget overschreden") Als het bovenstaande getal kleiner is dan of gelijk is aan 100, geeft de functie de tekst 'Binnen het budget' weer. Als dit niet het geval is, wordt de tekst 'Budget overschreden' weergegeven (Binnen het budget)
=ALS(A2=100;SOM(B5:B15);"") Als het getal groter is dan 100, wordt het bereik B5:B15 berekend. Als dit niet het geval is, wordt er lege tekst ("") als resultaat gegeven ()

Voorbeeld 2

Het voorbeeld is mogelijk beter te begrijpen als u het naar een leeg werkblad kopieert.

WeergevenWerkwijze

  1. Maak een lege werkmap of een leeg werkblad.
  2. Selecteer het voorbeeld in het Help-onderwerp. Selecteer geen rij- of kolomkoppen. 

Een voorbeeld selecteren in een Help-onderwerp

Een voorbeeld selecteren in een Help-onderwerp
  1. Druk op CTRL+C.
  2. Selecteer cel A1 in het werkblad en druk op CTRL+V.
  3. Als u afwisselend de resultaten en de bijbehorende formules wilt weergeven, drukt u op CTRL+` (accent grave). U kunt ook de optie Formules controleren aanwijzen in het menu Extra en vervolgens op Controlemodus voor formules klikken.
 
1
2
3
4
A B
Werkelijke uitgaven Voorspelde uitgaven
1500 900
500 900
500 925
Formule Beschrijving (resultaat)
=ALS(A2>B2:"Budget overschreden";"OK") Controleert of de eerste rij het budget heeft overschreden (Budget overschreden)
=ALS(A3>B3;"Budget overschreden";"OK") Controleert of de tweede rij het budget heeft overschreden (OK)

Voorbeeld 3

Het voorbeeld is mogelijk beter te begrijpen als u het naar een leeg werkblad kopieert.

WeergevenWerkwijze

  1. Maak een lege werkmap of een leeg werkblad.
  2. Selecteer het voorbeeld in het Help-onderwerp. Selecteer geen rij- of kolomkoppen. 

Een voorbeeld selecteren in een Help-onderwerp

Een voorbeeld selecteren in een Help-onderwerp
  1. Druk op CTRL+C.
  2. Selecteer cel A1 in het werkblad en druk op CTRL+V.
  3. Als u afwisselend de resultaten en de bijbehorende formules wilt weergeven, drukt u op CTRL+` (accent grave). U kunt ook de optie Formules controleren aanwijzen in het menu Extra en vervolgens op Controlemodus voor formules klikken.
 
1
2
3
4
A
Score
45
90
78
Formule Beschrijving (resultaat)
=ALS(A2>89;"A";ALS(A2>79;"B"; ALS(A2>69;"C";ALS(A2>59;"D";"F")))) Kent een letter toe aan de eerste score (F)
=ALS(A3>89;"A";ALS(A3>79;"B"; ALS(A3>69;"C";ALS(A3>59;"D";"F")))) Kent een letter toe aan de tweede score (A)
=ALS(A4>89;"A";ALS(A4>79;"B"; ALS(A4>69;"C";ALS(A4>59;"D";"F")))) Kent een letter toe aan de derde score (C)

In het voorafgaande voorbeeld is de tweede instructie ALS ook het argument waarde-als-onwaar bij de eerste instructie ALS. De derde instructie ALS is het argument waarde-als-onwaar bij de tweede instructie ALS. Als bijvoorbeeld de eerste logische-test (Score >89) WAAR is, wordt 'A' als resultaat gegeven. Als de eerste logische-test ONWAAR is, wordt de tweede instructie ALS geëvalueerd, enz.

De letters worden volgens de onderstaande tabel toegewezen aan getallen.

Score Resultaat
Groter dan 89 A
Van 80 tot 89 B
Van 70 tot 79 C
Van 60 tot 69 D
Kleiner dan 60 F
 
 
Van toepassing op:
Excel 2003