Getallen optellen

Stel dat u de prijzen wilt optellen van alle items die niet te koop staan in een winkel, of de bruto winstmarge voor alle afdelingen die dat jaar hun budget niet halen. Er bestaan verschillende manieren om getallen bij elkaar op te tellen.

Wat wilt u doen?


Getallen in een cel optellen

Gebruik de rekenkundige operator + (plusteken).

Als u bijvoorbeeld de volgende formule opgeeft in een cel:

=5+10

wordt in de cel het volgende resultaat weergegeven:

15

Terug naar boven Terug naar boven

Alle aaneengesloten getallen in een rij of kolom optellen

In het geval van een bereik met aaneengesloten getallen (dat wil zeggen dat er geen lege cellen zijn), kunt u de knop AutoSom Knopafbeelding gebruiken.

  1. Klik in een cel onder de kolom met de getallen of rechts van de rij met de getallen.
  2. Klik op het tabblad Start in de groep Bewerken op AutoSom Knopafbeelding en druk op ENTER.

Terug naar boven Terug naar boven

Niet-aaneengesloten getallen optellen

In het geval van een getallenbereik waarin zich ook lege cellen bevinden, of cellen met tekst in plaats van getallen, kunt u de functie SOM gebruiken in een formule. Zelfs als lege cellen of cellen met tekst zijn ingesloten in het bereik dat in de formule wordt gebruikt, worden deze cellen genegeerd.

Voorbeeld

Het voorbeeld is mogelijk beter te begrijpen als u het naar een leeg werkblad kopieert.

WeergevenEen voorbeeld kopiëren

  1. Maak een lege werkmap of leeg werkblad.
  2. Selecteer het voorbeeld in het Help-onderwerp.

Opmerking    Selecteer geen rij- of kolomkoppen.

Een voorbeeld in een Help-onderwerp selecteren

Een voorbeeld selecteren in een Help-onderwerp
  1. Druk op Ctrl+C.
  2. Selecteer cel A1 in het werkblad en druk op Ctrl+V.
  3. Als u afwisselend de resultaten en de bijbehorende formules wilt weergeven, drukt u op Ctrl+` (accent grave). U kunt ook op het tabblad Formules in de groep Formules controleren op de knop Formules weergeven klikken.
 
1
2
3
4
5
6
7
A B
Verkoper Factuur
Blaauboer 15.000
Blaauboer 9.000
Beekman 8.000
Beekman 20.000
Blaauboer 5.000
Lakowski 22.500
Formule Beschrijving (resultaat)
=SOM(B2:B3;B5) Twee facturen van Blaauboer en één factuur van Beekman worden opgeteld (44.000)
=SOM(B2;B5;B7) Afzonderlijke facturen van Blaauboer, Beekman en Cool worden opgeteld (57.500)

 Opmerking    De functie SOM kan elke combinatie met maximaal 30 verwijzingen naar cellen of bereiken bevatten. De formule =SOM(B2:B3,B5) bevat een verwijzing naar een bereik (B2:B3) een naar één cel (B5).

Terug naar boven Terug naar boven

Getallen optellen op basis van één voorwaarde

U kunt de functie SOM.ALS gebruiken om een totale waarde voor een bereik te berekenen op basis van een waarde in een ander bereik. In het nu volgende voorbeeld, wilt u het totaal weergeven van de waarden in kolom B (Factuur) die overeenstemmen met de waarden in kolom A (Verkoper) voor de verkoper met de naam Blaauboer.

Voorbeeld

Het voorbeeld is mogelijk beter te begrijpen als u het naar een leeg werkblad kopieert.

WeergevenEen voorbeeld kopiëren

  1. Maak een lege werkmap of leeg werkblad.
  2. Selecteer het voorbeeld in het Help-onderwerp.

Opmerking    Selecteer geen rij- of kolomkoppen.

Een voorbeeld in een Help-onderwerp selecteren

Een voorbeeld selecteren in een Help-onderwerp
  1. Druk op Ctrl+C.
  2. Selecteer cel A1 in het werkblad en druk op Ctrl+V.
  3. Als u afwisselend de resultaten en de bijbehorende formules wilt weergeven, drukt u op Ctrl+` (accent grave). U kunt ook op het tabblad Formules in de groep Formules controleren op de knop Formules weergeven klikken.
 
1
2
3
4
5
6
7
A B
Verkoper Factuur
Blaauboer 15.000
Blaauboer 9.000
Beekman 8.000
Beekman 20.000
Blaauboer 5.000
Lakowski 22.500
Formule Beschrijving (resultaat)
=SOM.ALS(A2:A7;"Blaauboer";B2:B7) De facturen van Blaauboer worden opgeteld (29.000)
=SOM.ALS(B2:B7;">=9000";B2:B7) De facturen met bedragen gelijk aan of hoger dan 9.000 worden opgeteld (66.500)
=SOM.ALS(B2:B7;"<9000";B2:B7) De facturen met bedragen lager dan 9.000 worden opgeteld (13.000)

In de functie SOM.ALS worden de volgende argumenten gebruikt


Formule met de functie SOM.ALS

Formule met de functie SOM.ALS
Toelichting 1 Het te evalueren bereik wordt gecontroleerd om te bepalen of een rij aan de criteria voldoet.
Toelichting 2 Criterium is de voorwaarde waaraan de cellen die worden geëvalueerd, moeten voldoen om de rij in de optelling op te nemen.
Toelichting 3 Het bereik dat moet worden opgeteld, bevat cellen met getallen die worden opgeteld mits de rij aan de voorwaarde voldoet.

Terug naar boven Terug naar boven

Getallen optellen op basis van meerdere voorwaarden

Gebruik de functie SOM.ALS om deze taak uit te voeren.

Voorbeeld

Het voorbeeld is mogelijk beter te begrijpen als u het naar een leeg werkblad kopieert.

WeergevenEen voorbeeld kopiëren

  1. Maak een lege werkmap of leeg werkblad.
  2. Selecteer het voorbeeld in het Help-onderwerp.

Opmerking    Selecteer geen rij- of kolomkoppen.

Een voorbeeld in een Help-onderwerp selecteren

Een voorbeeld selecteren in een Help-onderwerp
  1. Druk op Ctrl+C.
  2. Selecteer cel A1 in het werkblad en druk op Ctrl+V.
  3. Als u afwisselend de resultaten en de bijbehorende formules wilt weergeven, drukt u op Ctrl+` (accent grave). U kunt ook op het tabblad Formules in de groep Formules controleren op de knop Formules weergeven klikken.
 
1
2
3
4
5
6
7
8
9
10
11
A B C D
Regio Verkoper Type Omzet
Zuid Blaauboer Dranken 3.571
West Veninga Zuivel 3.338
Oost Beekman Dranken 5.122
Noord Beekman Zuivel 6.239
Zuid Lakowski Fruit 8.677
Zuid Veninga Vlees 450
Zuid Veninga Vlees 7.673
Oost Beekman Fruit 664
Noord Veninga Fruit 1.500
Zuid Lakowski Vlees 6.596
Formule Beschrijving (resultaat)
=SOMMEN.ALS(D2:D11,A2:A11,"Zuid",C2:C11,"Vlees") Som van de vleesverkoop in de regio Zuid (14.719)
=SOM(ALS((A2:A11="Zuid")+(A2:A11="Oost");D2:D11)) De omzet voor de regio's Zuid en Oost wordt opgeteld (32.753)

 Opmerking   De tweede formule in dit voorbeeld moet een matrixformule (matrixformule: een formule waarmee meerdere bewerkingen op een of meer waardensets worden uitgevoerd en die een of meerdere resultaten oplevert. Matrixformules worden ingevoerd tussen accolades { } en uitgevoerd met CTRL+SHIFT+ENTER.) zijn. Kopieer het voorbeeld naar een leeg werkblad en selecteer de formulecel. Druk eerst op F2 en vervolgens op Ctrl+Shift+ENTER. Als de formule geen matrixformule is, wordt de fout #WAARDE! als resultaat gegeven.

Hoe de functies worden gebruikt in het voorgaande voorbeeld

=SOMMEN.ALS(D2:D11,A2:A11,"Zuid",C2:C11,"Vlees")

De functie SOMMEN.ALS wordt in de eerste formule gebruikt om de rijen te vinden met "Zuid" in kolom A en "Vlees" in kolom C. Er zijn drie rijen waarvoor dit het geval is: rij 7, 8 en 11. De functie evalueert eerst kolom A, met de regio's, om alle rijen met "Zuid" te vinden. Vervolgens evalueert de functie kolom C, met het type voedsel, om alle rijen met het type "Vlees" te vinden. Tenslotte, doorzoekt de functie het bereik met de waarden die moeten worden opgeteld, D2:D11, en telt alleen de waarden bij elkaar op die voldoen aan de twee voorwaarden.

=SOM(ALS((A2:A11="Zuid")+(A2:A11="Oost");D2:D11))

De tweede formule, die gebruik maakt van de functies SOM en ALS, is ingevoerd als een matrixformule (door CTRL+SHIFT+ENTER tegelijk in te drukken) waarmee de rijen worden weergegeven waarvoor in kolom A ofwel "Zuid" of "Oost" of beiden wordt weergegeven. Er zijn zeven gevallen waarin dit waar is: in de rijen 2, 4, 6, 7, 8, 9 en 11. Omdat deze formule een matrixformule is, wordt de operator + niet gebruikt om de getallen bij elkaar op te tellen. Deze operator wordt hier gebruikt om twee of meer voorwaarden te controleren, waarbij aan ten minste één voorwaarde moet worden voldaan. Vervolgens wordt de functie SOM gebruikt om de waarden bij elkaar op te tellen die aan deze criteria voldoen.

Terug naar boven Terug naar boven

Getallen optellen op basis van criteria die zijn opgeslagen in een afzonderlijk bereik

Gebruik de functie DBSOM om deze taak uit te voeren.

Voorbeeld

Het voorbeeld is mogelijk beter te begrijpen als u het naar een leeg werkblad kopieert.

WeergevenEen voorbeeld kopiëren

  1. Maak een lege werkmap of leeg werkblad.
  2. Selecteer het voorbeeld in het Help-onderwerp.

Opmerking    Selecteer geen rij- of kolomkoppen.

Een voorbeeld in een Help-onderwerp selecteren

Een voorbeeld selecteren in een Help-onderwerp
  1. Druk op Ctrl+C.
  2. Selecteer cel A1 in het werkblad en druk op Ctrl+V.
  3. Als u afwisselend de resultaten en de bijbehorende formules wilt weergeven, drukt u op Ctrl+` (accent grave). U kunt ook op het tabblad Formules in de groep Formules controleren op de knop Formules weergeven klikken.
 
1
2
3
4
5
6
7
8
9
10
11
A B C D
Regio Verkoper Type Omzet
Zuid Blaauboer Dranken 3.571
West Veninga Zuivel 3.338
Oost Beekman Dranken 5.122
Noord Beekman Zuivel 6.239
Zuid Lakowski Fruit 8.677
Zuid Veninga Vlees 450
Zuid Veninga Vlees 7.673
Oost Beekman Fruit 664
Noord Veninga Fruit 1.500
Zuid Lakowski Vlees 6.596
Regio Verkoper Type Omzet
Zuid Vlees
Fruit
Formule Beschrijving (resultaat)
=DBSOM(A1:D11; "Omzet"; A12:D13) De omzet voor vlees in de regio Zuid wordt opgeteld (14.719)
=DBSOM(A1:D11; "Omzet"; A12:D14) De omzet voor groente en fruit en vlees in de regio Zuid wordt opgeteld (25.560)

In de functie DBSOM worden de volgende argumenten gebruikt.


Formule met de functie DBSOM

Toelichting 1 Het bereik dat moet worden geëvalueerd: de lijst die u wilt optellen.
Toelichting 2 Het veld: de label van de kolom die wordt opgeteld.
Toelichting 3 De criteria: het cellenbereik met de voorwaarden.

Terug naar boven Terug naar boven

Wat is er gebeurd met de wizard Voorwaardelijke som?

Deze invoegtoepassing is niet langer inbegrepen in Excel 2010. In eerdere versies van Excel kon u met de wizard Voorwaardelijke som formules schrijven voor het berekenen van het totaal van waarden die aan opgegeven voorwaarden voldeden. Deze functionaliteit is vervangen door het dialoogvenster Functie invoegen (tabblad Formules, groep Functiebibliotheek) en andere bestaande werkbladfuncties, zoals SOMMEN.ALS en door een combinatie van de functies SOM en ALS samen te gebruiken in een formule. Zie het gedeelte Getallen optellen op basis van meerdere voorwaarden eerder in dit artikel voor meer informatie over het gebruik van deze functies om de voorwaardelijke som van rijen met gegevens te berekenen.

Terug naar boven Terug naar boven

Alleen unieke waarden optellen

Gebruik de functies SOM, ALS en INTERVAL om deze taak uit te voeren.

Het volgende voorbeeld gebruikt:

  • De functie INTERVAL om de unieke waarden in een bereik te identificeren. Als een specifieke waarde voor de eerste keer voorkomt, retourneert deze functie een getal dat gelijk is aan het aantal keer dat die waarde voorkomt. Voor iedere keer dat deze waarde na de eerste keer voorkomt, retourneert deze functie een 0 (nul).
  • De functie ALS om de waarde 1 toe te wijzen als een voorwaarde waar is.
  • De functie SOM om de unieke waarden op te tellen.

Tip    Als u wilt zien hoe een functie stap voor stap wordt geëvalueerd, selecteert u de cel met de formule en klikt u op het tabblad Formules in de groep Formules controleren op Formule evalueren.

Voorbeeld

Het voorbeeld is mogelijk beter te begrijpen als u het naar een leeg werkblad kopieert.

WeergevenEen voorbeeld kopiëren

  1. Maak een lege werkmap of leeg werkblad.
  2. Selecteer het voorbeeld in het Help-onderwerp.

Opmerking    Selecteer geen rij- of kolomkoppen.

Een voorbeeld in een Help-onderwerp selecteren

Een voorbeeld selecteren in een Help-onderwerp
  1. Druk op Ctrl+C.
  2. Selecteer cel A1 in het werkblad en druk op Ctrl+V.
  3. Als u afwisselend de resultaten en de bijbehorende formules wilt weergeven, drukt u op Ctrl+` (accent grave). U kunt ook op het tabblad Formules in de groep Formules controleren op de knop Formules weergeven klikken.
 
1
2
3
4
5
6
7
8
9
10
A
Gegevens
986
456
67
1
34
689
456
56
67
Formule Beschrijving (resultaat)
=SOM(ALS(INTERVAL(A2:A10;A2:A10)>0;A2:A10)) Telt de unieke waarden in de cellen A2:A10 op (2289)

Terug naar boven Terug naar boven

 
 
Van toepassing op:
Excel 2010