Lage en formel

Formler er ligninger som utfører beregninger på verdier i regnearket. En formel begynner med et likhetstegn (=). Formelen nedenfor multipliserer for eksempel 2 med 3 og legger deretter til 5 til resultatet.

=5+2*3

VisLage en enkel formel: =128+345

VisLage en formel som inneholder referanser eller navn: =A1+23

Følgende formler inneholder relative referanser (relativ referanse: Adressen til en celle i en formel basert på den relative plasseringen av cellen som inneholder formelen, og cellen det refereres til. Hvis du kopierer formelen, justeres referansen automatisk. En relativ referanse tar formen A1.) til og navn (navn: Et ord eller en streng med tegn som representerer en celle, et celleområde, en formel eller en konstantverdi. Bruk navn som er lette å forstå. Bruk for eksempel Produkter for områder som er vanskelige å forstå, for eksempel Salg!C20:C30.) på andre celler. Cellen som inneholder formelen, kalles en underordnet celle når verdien i cellen avhenger av verdier i andre celler. Celle B2 er en underordnet celle hvis den inneholder formelen =C2.

Eksempelformel Dette innebærer
=C2 Bruker verdien i celle C2
=Ark2!B2 Bruker verdien i celle B2 på Ark2
=Aktiva-Passiva Trekker fra en celle kalt Passiva fra en celle kalt Aktiva
  1. Klikk i cellen der du vil legge inn formelen.
  2. formellinjen (formellinje: Et felt øverst i Excel-vinduet som du bruker til å skrive inn eller redigere verdier eller formler i celler og diagrammer. Viser konstantverdien eller formelen som er lagret i den aktive cellen.) Formellinje skriver du inn = (likhetstegn).
  3. Gjør ett av følgende:
    • Hvis du vil opprette en referanse, merker du en celle, et celleområde, en plassering i et annet regneark eller en plassering i en annen arbeidsbok. Du kan dra kanten av celleutvalget for å flytte utvalget, eller dra kanthjørnet for å utvide utvalget.

Overordnede celler fargekodes ved hjelp av referansemerking

  • Hvis du vil opprette en referanse til et navngitt område, trykker du F3, merker navnet i boksen Lim inn navn og velger OK.
  1. Trykk ENTER.

VisLage en formel som inneholder en funksjon: =GJENNOMSNITT(A1:B4)

Formlene nedenfor inneholder funksjoner (funksjon: En forhåndsskrevet formel som tar en verdi eller flere verdier, utfører en operasjon og returnerer en verdi eller flere verdier. Bruk funksjoner til å forenkle og forkorte formler i et regneark, spesielt de som utfører lange og sammensatte beregninger.).

Eksempel på formel Formelresultat
=SUMMER(A:A) Legger sammen alle tall i kolonne A
=GJENNOMSNITT(A1:B4) Finner gjennomsnittet av alle tall i området
  1. Klikk i cellen der du vil sette inn formelen.
  2. Når du skal begynne formelen med funksjonen, klikker du Sett inn funksjon Knappesymbolformellinjen (formellinje: Et felt øverst i Excel-vinduet som du bruker til å skrive inn eller redigere verdier eller formler i celler og diagrammer. Viser konstantverdien eller formelen som er lagret i den aktive cellen.) Formellinjen.
  3. Velg funksjonen du vil bruke. Du kan skrive inn et spørsmål som beskriver hva du vil gjøre, i boksen Søk etter en funksjon (for eksempel returnerer "legge sammen tall" funksjonen SUMMER), eller bla gjennom kategoriene i boksen Eller velg en kategori.
  4. Sett inn argumentene (argument: Verdiene som en funksjon bruker til å utføre operasjoner eller beregninger. Argumenttypen en funksjon bruker, er spesifikk for funksjonen. Tall, tekst, cellereferanser og navn er vanlige argumenter som brukes i funksjoner.). Hvis du skal sette inn cellereferanser som et argument, klikker du Skjul dialogboks Knappesymbol for å skjule dialogboksen midlertidig. Merk cellene i regnearket, og trykk deretter Utvid dialogboks Knappesymbol.
  5. Når du har fullført formelen, trykker du ENTER.

VisLage en formel med nestede funksjoner: =HVIS(GJENNOMSNITT(F2:F5)>50, SUMMER(G2:G5),0)

Nestede funksjoner bruker en funksjon som et av argumentene i en annen funksjon. Formelen nedenfor summerer et sett med tall(G2:G5), men bare hvis gjennomsnittet av et annet sett med tall (F2:F5) er større enn 50. I alle andre tilfeller returnerer den 0.

Nestede funksjoner

  1. Klikk i cellen der du vil sette inn formelen.
  2. Når du skal begynne formelen med funksjonen, velger du Sett inn funksjon Knappesymbolformellinjen (formellinje: Et felt øverst i Excel-vinduet som du bruker til å skrive inn eller redigere verdier eller formler i celler og diagrammer. Viser konstantverdien eller formelen som er lagret i den aktive cellen.) Formellinjen.
  3. Velg funksjonen du vil bruke. Du kan skrive inn et spørsmål som beskriver hva du vil gjøre, i boksen Søk etter en funksjon (for eksempel returnerer "legge sammen tall" funksjonen SUMMER), eller bla gjennom kategoriene i boksen Eller velg en kategori.
  4. Sett inn argumentene (argument: Verdiene som en funksjon bruker til å utføre operasjoner eller beregninger. Argumenttypen en funksjon bruker, er spesifikk for funksjonen. Tall, tekst, cellereferanser og navn er vanlige argumenter som brukes i funksjoner.).
    • Hvis du skal sette inn cellereferanser som et argument, klikker du Skjul dialogboks ved siden av argumentet der du vil skjule dialogboksen midlertidig. Merk cellene i regnearket, og trykk deretter Utvid dialogboks .
    • Hvis du vil sette inn en annen funksjon som argument, skriver du inn funksjonen i den argumentboksen du vil bruke. Du kan for eksempel legge sammen SUMMER(G2:G5) i redigeringsboksen sann.
    • Hvis du vil bytte mellom de delene av en formel som blir vist i dialogboksen Funksjonsargumenter, velger du et funksjonsnavn på formellinjen. Hvis du for eksempel klikker HVIS, blir argumentene til HVIS-funksjonen vist.

VisTips!

 
 
Gjelder:
Excel 2003