Visualizzare o nascondere i valori uguali a zero

I valori uguali a zero possono essere visualizzati o nascosti in diversi modi per soddisfare esigenze specifiche, ad esempio nei casi in cui l'utente preferisce visualizzarli all'interno di una cella o quando si utilizza un foglio di lavoro conforme a una serie di standard di formattazione che prevedono invece che vengano nascosti.

Per saperne di più


Visualizzare o nascondere tutti i valori uguali a zero in un foglio di lavoro

  1. Fare clic sul pulsante Microsoft Office Icona del pulsante, quindi su Opzioni di Excel e infine sulla categoria Impostazioni avanzate.
  1. In Opzioni di visualizzazione per il foglio di lavoro selezionare un foglio di lavoro e quindi eseguire una delle operazioni seguenti:
    • Per visualizzare i valori uguali a zero (0) nelle celle, selezionare la casella di controllo Visualizza zero nelle celle con valore zero.
    • Per visualizzare i valori uguali a zero come celle vuote, deselezionare la casella di controllo Visualizza zero nelle celle con valore zero.

Torna all'inizio Torna all'inizio

Utilizzare un formato numero per nascondere i valori uguali a zero nelle celle selezionate

Seguire questa procedura per nascondere i valori uguali a zero nelle celle selezionate. Se in una delle celle viene immesso un valore diverso da zero, il formato del valore sarà simile al formato numero generale.

  1. Selezionare le celle che contengono i valori uguali a zero (0) che si desidera nascondere.
  2. Nel gruppo Celle della scheda Home fare clic su Formato, quindi su Formato celle.
  1. Scegliere Personalizzato dall'elenco Categoria.
  2. Nella casella Tipo immettere 0;-0;;@

 Note 

  • I valori nascosti vengono visualizzati solo nella barra della formula Barra della formula, o nella cella se si applica la modifica nella cella, e non vengono stampati.
  • Nel gruppo Celle della scheda Home fare clic su Formato, quindi su Formato celle.
  • Per visualizzare di nuovo i valori nascosti, selezionare le celle e quindi nel gruppo Celle della scheda Home scegliere Formato e fare clic su Formato celle. Selezionare Generale dall'elenco Categoria per applicare il formato numero predefinito. Per visualizzare di nuovo una data o un'ora, selezionare il formato data o ora appropriato nella scheda Numero.

Torna all'inizio Torna all'inizio

Utilizzare un formato condizionale per nascondere i valori uguali a zero restituiti da una formula

  1. Selezionare la cella contenente il valore uguale a zero (0).
  2. Nel gruppo Stili della scheda Home fare clic sulla freccia accanto a Formattazione condizionale, quindi su Regole evidenziazione celle e infine su Uguale a.
  1. Nella casella a sinistra digitare 0.
  2. Nella casella a destra selezionare Formato personalizzato.
  3. Nella finestra di dialogo Formato celle fare clic sulla scheda Carattere.
  4. Scegliere il bianco nella casella Colore.

Torna all'inizio Torna all'inizio

Utilizzare una formula per visualizzare gli zeri come spazi o trattini

Utilizzare la funzione SE per eseguire questa operazione.

Esempio

Per facilitare la comprensione dell'esempio, è possibile copiarlo in un foglio di lavoro vuoto.

MostraCome copiare un esempio

  1. Selezionare l'esempio in questo articolo. Se l'esempio deve essere copiato in Excel Web App, copiare e incollare una cella alla volta.

 Importante   Non selezionare le intestazioni della riga o della colonna. 

Selezione di un esempio dalla Guida

Selezione di un esempio dalla Guida
  1. Premere CTRL+C.
  2. Creare una cartella di lavoro o un foglio di lavoro vuoto.
  3. Nel foglio di lavoro selezionare la cella A1 e premere CTRL+V. Se si utilizza Excel Web App, ripetere l'operazione di Copia e Incolla per ogni cella nell'esempio.

 Importante   Per il corretto funzionamento dell'esempio è necessario incollarlo nella cella A1 del foglio di lavoro.

  1. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule che restituiscono i risultati, premere CTRL+` (accento grave) oppure fare clic sul pulsante Mostra formule nel gruppo Verifica formule della scheda Formule.

Dopo aver copiato l'esempio in un foglio di lavoro vuoto, è possibile adattarlo in base alle proprie esigenze.


 
1
2
3
4
5

6
7
A B
Dati
10
10
Formula Descrizione (risultato)
=A2-A3 Il secondo numero viene sottratto dal primo (0)
=SE(A2-A3=0;"";A2-A3) Restituisce una cella vuota quando il valore è zero (cella vuota)
=SE(A2-A3=0,"-",A2-A3 Restituisce un trattino quando il valore è zero (-)

Per ulteriori informazioni sull'utilizzo di questa funzione, vedere SE.

Torna all'inizio Torna all'inizio

Nascondere i valori uguali a zero in un rapporto di tabella pivot

  1. Fare clic sul rapporto di tabella pivot.
  2. Nel gruppo Opzioni tabella pivot della scheda Opzioni fare clic sulla freccia accanto a Opzioni, quindi su Opzioni.
  1. Fare clic sulla scheda Layout e formato e quindi eseguire una delle operazioni seguenti:

Modificare la visualizzazione degli errori     Selezionare la casella di controllo Per i valori di errore, mostra in Formato. Digitare nella casella il valore che si desidera visualizzare al posto degli errori. Per visualizzare gli errori come celle vuote, eliminare gli eventuali caratteri presenti nella casella.

Modificare la visualizzazione delle celle vuote     Selezionare la casella di controllo Per le celle vuote, mostra. Digitare nella casella il valore che si desidera visualizzare nelle celle vuote. Per visualizzare le celle vuote, eliminare gli eventuali caratteri presenti nella cella. Per visualizzare gli zeri, deselezionare la casella di controllo.

Torna all'inizio Torna all'inizio

 
 
Si applica a:
Excel 2007