SOMMA

Somma tutti i numeri presenti in un intervallo di celle.

Sintassi

SOMMA(num1;num2; ...)

Num1; num2;...     sono da 1 a 30 argomenti di cui si desidera il valore totale o somma.

Osservazioni

  • I numeri, i valori logici e la rappresentazioni di numeri in formato testo digitati direttamente nell'elenco degli argomenti vengono inclusi nel calcolo. Vedere i primi due esempi che seguono.
  • Se un argomento è costituito da una matrice o da un riferimento, verranno utilizzati solo i numeri presenti nella matrice o nel riferimento, mentre le celle vuote, i valori logici, il testo o i valori di errore verranno ignorati. Vedere il terzo degli esempi che seguono.
  • Gli argomenti rappresentati da valori di errore o da testo non convertibile in numeri generano degli errori.

Esempio

L'esempio può essere più semplice da comprendere se lo si copia in un foglio di lavoro vuoto.

MostraProcedura

  1. Creare una cartella di lavoro o un foglio di lavoro vuoto.
  2. Selezionare l'esempio nell'argomento della Guida. Non selezionare le intestazioni della riga o della colonna. 

Selezionare un esempio dalla Guida

Selezionare un esempio dalla Guida
  1. Premere CTRL+C.
  2. Nel foglio di lavoro, selezionare la cella A1 e premere CTRL+V.
  3. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule che calcolano il risultato, premere CTRL+MAIUSC+8 oppure scegliere Verifica formule dal menu Strumenti, quindi fare clic su Modalità Verifica formule.
 
1
2
3
4
5
6
A
Dati
-5
15
30
'5
VERO
Formula Descrizione (risultato)
=SOMMA(3; 2) Somma 3 e 2 (5)
=SOMMA"5"; 15; VERO) Somma 5, 15 e 1 in quanto i valori in formato testo vengono convertiti in numeri e il valore logico VERO viene considerato uguale a 1 (21)
=SOMMA(A2:A4) Somma i primi tre numeri della colonna (40)
=SOMMA(A2:A4; 15) Somma i primi tre numeri della colonna e 15 (55)
=SOMMA(A5;A6; 2) Somma i valori nelle due ultime righe e 2. I valori non numerici nei riferimenti non vengono convertiti, quindi i valori nella colonna verranno ignorati (2)
 
 
Si applica a:
Excel 2003