SE

Restituisce un valore se la condizione specificata ha valore VERO e un altro valore se essa ha valore FALSO.

Utilizzare la funzione SE per eseguire dei test condizionali su valori e formule.

Sintassi

SE(test; se_vero; se_falso)

Test     è un valore o un'espressione qualsiasi che può dare come risultato VERO o FALSO. Ad esempio, A10=100 è un'espressione logica; se il valore contenuto nella cella A10 è uguale a 100, l'espressione darà come risultato VERO. In caso contrario, l'espressione darà come risultato FALSO. Questo argomento può utilizzare qualsiasi operatore di calcolo di confronto.

Se_vero     è il valore che viene restituito se test è VERO. Ad esempio, se questo argomento è la stringa di testo Nel budget e l'argomento test dà come risultato VERO, allora la funzione SE visualizzerà il testo Nel budget. Se test è VERO e se se_vero è vuoto, questo argomento restituirà 0 (zero). Per visualizzare la parola VERO, utilizzare il valore logico VERO per questo argomento. Se_vero può anche essere un'altra formula.

Se_falso     è il valore che viene restituito se test è FALSO. Ad esempio, se questo argomento è la stringa di testo Fuori budget e l'argomento test dà come risultato FALSO, allora la funzione SE visualizzerà il testo Fuori budget. Se test è FALSO e se se_falso è omesso, ovvero se non c'è un punto e virgola dopo se_vero, verrà restituito il valore FALSO. Se test è FALSO e se se_falso è vuoto, ovvero, se, dopo se_vero, c'è un punto e virgola seguito da parentesi, verrà restituito il valore 0 (zero). Se_falso può anche essere un'altra formula.

Osservazioni

Esempio 1

L'esempio può essere più semplice da comprendere se lo si copia in un foglio di lavoro vuoto.

MostraProcedura

  1. Creare una cartella di lavoro o un foglio di lavoro vuoto.
  2. Selezionare l'esempio nell'argomento della Guida. Non selezionare le intestazioni della riga o della colonna. 

Selezionare un esempio dalla Guida

Selezionare un esempio dalla Guida
  1. Premere CTRL+C.
  2. Nel foglio di lavoro, selezionare la cella A1 e premere CTRL+V.
  3. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule che calcolano il risultato, premere CTRL+MAIUSC+8 oppure scegliere Verifica formule dal menu Strumenti, quindi fare clic su Modalità Verifica formule.
 
1
2
A
Dati
50
Formula Descrizione (risultato)
=SE(A2<=100;"Nel budget";"Fuori budget") Se il numero è inferiore o uguale a 100, la formula visualizza Nel budget. In caso contrario, verrà visualizzato Fuori budget (Nel budget)
=SE(A2=100;SOMMA(B5:B15);"") Se il numero è maggiore di 100, verrà calcolato l'intervallo B5:B15. In caso contrario, verrà restituita una stringa di testo vuota ("") ()

Esempio 2

L'esempio può essere più semplice da comprendere se lo si copia in un foglio di lavoro vuoto.

MostraProcedura

  1. Creare una cartella di lavoro o un foglio di lavoro vuoto.
  2. Selezionare l'esempio nell'argomento della Guida. Non selezionare le intestazioni della riga o della colonna. 

Selezionare un esempio dalla Guida

Selezionare un esempio dalla Guida
  1. Premere CTRL+C.
  2. Nel foglio di lavoro, selezionare la cella A1 e premere CTRL+V.
  3. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule che calcolano il risultato, premere CTRL+MAIUSC+8 oppure scegliere Verifica formule dal menu Strumenti, quindi fare clic su Modalità Verifica formule.
 
1
2
3
4
A B
Spese effettive Spese previste
1500 900
500 900
500 925
Formula Descrizione (risultato)
=SE(A2>B2;"Fuori budget";"OK") Controlla se la prima riga è fuori budget (Fuori budget)
=SE(A3>B3;"Fuori budget";"OK") Controlla se la seconda riga è fuori budget (OK)

Esempio 3

L'esempio può essere più semplice da comprendere se lo si copia in un foglio di lavoro vuoto.

MostraProcedura

  1. Creare una cartella di lavoro o un foglio di lavoro vuoto.
  2. Selezionare l'esempio nell'argomento della Guida. Non selezionare le intestazioni della riga o della colonna. 

Selezionare un esempio dalla Guida

Selezionare un esempio dalla Guida
  1. Premere CTRL+C.
  2. Nel foglio di lavoro, selezionare la cella A1 e premere CTRL+V.
  3. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule che calcolano il risultato, premere CTRL+MAIUSC+8 oppure scegliere Verifica formule dal menu Strumenti, quindi fare clic su Modalità Verifica formule.
 
1
2
3
4
A
Punteggio
45
90
78
Formula Descrizione (risultato)
=SE(A2>89;"A";SE(A2>79;"B";SE(A2>69;"C";SE(A2>59;"D";"F")))) Assegna una lettera al primo punteggio (F)
=SE(A3>89;"A";SE(A3>79;"B";SE(A3>69;"C";SE(A3>59;"D";"F")))) Assegna una lettera al secondo punteggio (A)
=SE(A4>89;"A";SE(A4>79;"B";SE(A4>69;"C";SE(A4>59;"D";"F")))) Assegna una lettera al terzo punteggio (C)

Nell'esempio precedente, la seconda istruzione SE è anche l'argomento se_falso della prima istruzione SE. Analogamente, la terza istruzione SE è l'argomento se_falso della seconda istruzione SE. Ad esempio, se il primo test (Media>89) è VERO, verrà restituito A. Se il primo test è FALSO, verrà calcolata la seconda istruzione SE e così via.

Le lettere vengono assegnate ai numeri secondo il seguente codice.

Se il punteggio è Restituirà
Maggiore di 89 A
Compreso tra 80 e 89 B
Compreso tra 70 e 79 C
Compreso tra 60 e 69 D
Minore di 60 F
 
 
Si applica a:
Excel 2003