Convertire gli orari

MostraConvertire le unità di tempo

Utilizzare la funzione CONVERTI per eseguire questa operazione.

Se questa funzione non è disponibile, installare e caricare il componente aggiuntivo Strumenti di analisi.

MostraProcedura

  1. Scegliere Componenti aggiuntivi dal menu Strumenti.
  2. Nell'elenco Componenti aggiuntivi disponibili, selezionare la casella Strumenti di analisi, quindi fare clic su OK.
  3. Se necessario, seguire le istruzioni del programma di installazione.

Foglio di lavoro di esempio

L'esempio può essere più semplice da comprendere se lo si copia in un foglio di lavoro vuoto.

MostraProcedura

  1. Creare una cartella di lavoro o un foglio di lavoro vuoto.
  2. Selezionare l'esempio nell'argomento della Guida. Non selezionare le intestazioni della riga o della colonna. 

Selezionare un esempio dalla Guida

Selezionare un esempio dalla Guida
  1. Premere CTRL+C.
  2. Nel foglio di lavoro, selezionare la cella A1 e premere CTRL+V.
  3. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule che calcolano il risultato, premere CTRL+MAIUSC+8 oppure scegliere Verifica formule dal menu Strumenti, quindi fare clic su Modalità Verifica formule.
 
1
2
A
Dati
6
Formula Descrizione (risultato)
=CONVERTI(A2;"day";"hr") Converte 6 giorni in ore (144)
=CONVERTI(A2;"hr";"mn") Converte 6 ore in minuti (360)
=CONVERTI(A2;"yr";"day") Converte 6 anni in giorni (2191,5)

 Nota   Per le conversioni che utilizzano un anno, l'anno è considerato di 365,25 giorni.

Dettagli funzione

CONVERTI

MostraConvertire le ore dal formato standard dell'orario (ore:minuti:secondi) a un numero decimale

Utilizzare la funzione INT per eseguire questa operazione.

Foglio di lavoro di esempio

L'esempio può essere più semplice da comprendere se lo si copia in un foglio di lavoro vuoto.

MostraProcedura

  1. Creare una cartella di lavoro o un foglio di lavoro vuoto.
  2. Selezionare l'esempio nell'argomento della Guida. Non selezionare le intestazioni della riga o della colonna. 

Selezionare un esempio dalla Guida

Selezionare un esempio dalla Guida
  1. Premere CTRL+C.
  2. Nel foglio di lavoro, selezionare la cella A1 e premere CTRL+V.
  3. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule che calcolano il risultato, premere CTRL+MAIUSC+8 oppure scegliere Verifica formule dal menu Strumenti, quindi fare clic su Modalità Verifica formule.
 
1
2
3
A
Ora
10:35:00
12:15:00
Formula Descrizione (risultato)
=(A2-INT(A2))*24 Numero di ore dalle 24:00:00 (10,583333)
=(A3-INT(A3))*24 Numero di ore dalle 24:00:00 (12,25)

Dettagli funzione

INT

MostraConvertire le ore da un numero decimale al formato standard dell'orario (ore:minuti:secondi)

Utilizzare l'operatore di divisione (/) e la funzione TESTO per eseguire questa operazione.

Foglio di lavoro di esempio

L'esempio può essere più semplice da comprendere se lo si copia in un foglio di lavoro vuoto.

MostraProcedura

  1. Creare una cartella di lavoro o un foglio di lavoro vuoto.
  2. Selezionare l'esempio nell'argomento della Guida. Non selezionare le intestazioni della riga o della colonna. 

Selezionare un esempio dalla Guida

Selezionare un esempio dalla Guida
  1. Premere CTRL+C.
  2. Nel foglio di lavoro, selezionare la cella A1 e premere CTRL+V.
  3. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule che calcolano il risultato, premere CTRL+MAIUSC+8 oppure scegliere Verifica formule dal menu Strumenti, quindi fare clic su Modalità Verifica formule.
 
1
2
3
A
Ore
10,5833
12,25
Formula Descrizione (risultato)
=TESTO(A2/24; "h:mm") Ore dalle 24:00:00 (10:35)
=TESTO(A3/24; "h:mm") Ore dalle 24:00:00 (12:15:00)

 Nota   È possibile anche applicare il formato dell'orario e della data senza utilizzare la funzione TESTO per specificare il formato. Per visualizzare il numero come un orario, selezionare la cella e scegliere Celle dal menu Formato. Fare clic sulla scheda Numero, quindi su Ora nella casella Categoria. Se si utilizza sia un formato applicato con la funzione TESTO che un formato numero, prevarrà la funzione TESTO.

Dettagli funzione

TESTO

 
 
Si applica a:
Excel 2003