Contare quante volte si presenta un valore

Si supponga di voler determinare quante volte si presenta un testo o un valore numerico specifico. Ad esempio:

  • In un intervallo che contiene i valori numerici 5, 6, 7 e 6 il numero 6 si presenta due volte.
  • In una colonna che contiene "Barbariol", "Giussani", "Giussani" e "Giussani" il testo "Giussani" si presenta tre volte.

È possibile contare quante volte si presenta un valore in diversi modi.

Per saperne di più


Contare quante volte si presenta un valore singolo utilizzando una funzione

Utilizzare la funzione CONTA.SE per eseguire questa operazione.

Esempio

L'esempio può risultare di comprensione più immediata se lo si copia in un foglio di lavoro vuoto.

MostraCome copiare un esempio

  1. Creare una cartella di lavoro o un foglio di lavoro vuoto.
  2. Selezionare l'esempio nell'argomento della Guida.

 Nota   Non selezionare le intestazioni della riga o della colonna.

Selezione di un esempio dalla Guida

Selezione di un esempio dalla Guida
  1. Premere CTRL+C.
  2. Nel foglio di lavoro selezionare la cella A1 e premere CTRL+V.
  3. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule che restituiscono i risultati, premere CTRL+` (accento grave) oppure fare clic sul pulsante Mostra formule nel gruppo Verifica formule della scheda Formule.
 
1
2
3
4
5
6
7
A B
Venditore Fattura
Barbariol 15.000
Barbariol 9.000
Pica 8.000
Pica 20.000
Barbariol 5.000
Giussani 22.500
Formula Descrizione (risultato)
=CONTA.SE(A2:A7;"Barbariol") Numero di voci per Barbariol (3)
=CONTA.SE(A2:A7;A4) Numero di voci per Pica (2)
=CONTA.SE(B2:B7;"< 20000") Numero dei valori di fattura inferiori a 20.000 (4)
=CONTA.SE(B2:B7;">="&B5) Numero dei valori di fattura superiori o uguali a 20.000 (2)

Dettagli funzione

CONTA.SE

Torna all'inizio Torna all'inizio

Contare quante volte si presentano valori numerici multipli utilizzando funzioni

Si supponga di dover stabilire il numero di venditori che hanno venduto un articolo specifico in una determinata area oppure che si desideri sapere quante vendite che superano un determinato valore sono state realizzate da un venditore. Per conoscere questi valori, è possibile utilizzare le funzioni SE e CONTA.NUMERI.

Esempio

L'esempio può risultare di comprensione più immediata se lo si copia in un foglio di lavoro vuoto.

MostraCome copiare un esempio

  1. Creare una cartella di lavoro o un foglio di lavoro vuoto.
  2. Selezionare l'esempio nell'argomento della Guida.

 Nota   Non selezionare le intestazioni della riga o della colonna.

Selezione di un esempio dalla Guida

Selezione di un esempio dalla Guida
  1. Premere CTRL+C.
  2. Nel foglio di lavoro selezionare la cella A1 e premere CTRL+V.
  3. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule che restituiscono i risultati, premere CTRL+` (accento grave) oppure fare clic sul pulsante Mostra formule nel gruppo Verifica formule della scheda Formule.
 
1
2
3
4
5
6
7
8
9
10
11
A B C D
Area Venditore Tipo Vendite
Sud Barbariol Bevande 3571
Ovest Giorgi Latticini 3338
Est Pica Bevande 5122
Nord Pica Latticini 6239
Sud Giussani Prodotti agricoli 8677
Sud Giorgi Carne 450
Sud Giorgi Carne 7673
Est Pica Prodotti agricoli 664
Nord Giorgi Prodotti agricoli 1500
Sud Giussani Carne 6596
Formula Descrizione (risultato)
=CONTA.NUMERI(SE((A2:A11="Sud")*(C2:C11="Carne");D2:D11)) Numero di venditori che hanno venduto carne nell'area meridionale (3)
=CONTA.NUMERI(SE((B2:B11="Pica")*(D2:D11>=1000),D2:D11)) Numero di vendite per un valore maggiore di 1000 realizzate dal venditore Pica (2)

 Note 

Dettagli funzione

CONTA.NUMERI

SE

Torna all'inizio Torna all'inizio

Contare quante volte si presentano testo o valori numerici multipli utilizzando funzioni

Utilizzare le funzioni SE e SOMMA per eseguire questa operazione:

  • Assegnare il valore 1 a ogni condizione che viene soddisfatta utilizzando la funzione SE.
  • Sommare il totale utilizzando la funzione SOMMA.

Esempio

L'esempio può risultare di comprensione più immediata se lo si copia in un foglio di lavoro vuoto.

MostraCome copiare un esempio

  1. Creare una cartella di lavoro o un foglio di lavoro vuoto.
  2. Selezionare l'esempio nell'argomento della Guida.

 Nota   Non selezionare le intestazioni della riga o della colonna.

Selezione di un esempio dalla Guida

Selezione di un esempio dalla Guida
  1. Premere CTRL+C.
  2. Nel foglio di lavoro selezionare la cella A1 e premere CTRL+V.
  3. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule che restituiscono i risultati, premere CTRL+` (accento grave) oppure fare clic sul pulsante Mostra formule nel gruppo Verifica formule della scheda Formule.
 
1
2
3
4
5
6
7
A B
Venditore Fattura
Barbariol 15.000
Barbariol 9.000
Pica 8.000
Pica 20.000
Barbariol 5.000
Giussani 22.500
Formula Descrizione (risultato)
=SOMMA(SE((A2:A7="Barbariol")+(A2:A7="Giussani");1;0)) Numero di fatture per Barbariol o Giussani (4)
=SOMMA(SE((B2:B7<9000)+(B2:B7>19000);1;0)) Numero di fatture con valori inferiori a 9.000 o superiori a 19.000 (4)
=SOMMA(SE(A2:A7="Barbariol";SE(B2:B7<9000;1;0))) Numero di fatture per Barbariol con valore inferiore a 9.000 (1)

 Nota   Le formule contenute in questo esempio devono essere immesse come formule in forma di matrice (formula in forma di matrice: Formula che esegue più calcoli su uno o più insiemi di valori e quindi restituisce un unico risultato o più risultati. Le formule in forma di matrice sono racchiuse tra parentesi graffe { } e vengono immesse premendo CTRL+MAIUSC+INVIO.). Selezionare ogni cella che contiene una formula, premere F2, quindi premere CTRL+MAIUSC+INVIO.

Dettagli funzione

SE

SOMMA

Torna all'inizio Torna all'inizio

Contare quante volte si presentano valori multipli utilizzando un rapporto di tabella pivot

È possibile utilizzare un rapporto di tabella pivot per visualizzare i totali e per calcolare le occorrenze dei valori univoci.

  1. Selezionare la colonna contenente i dati. Verificare che la colonna presenti un'intestazione.
  2. Nel gruppo Tabelle della scheda Inserisci fare clic su Tabella pivot.
  1. Verrà visualizzata la finestra di dialogo Crea Tabella pivot.
  2. Fare clic su Seleziona tabella o intervallo.
  3. Inserire il rapporto di tabella pivot in un nuovo foglio di lavoro a partire dalla cella A1 facendo clic su Nuovo foglio di lavoro.
  4. Fare clic su OK.

Nella posizione specificata viene aggiunto un rapporto di tabella pivot vuoto con l'Elenco campi tabella pivot visualizzato.

  1. Nella sezione dei campi nella parte superiore dell'Elenco campi tabella pivot fare clic tenendo premuto il pulsante del mouse sul nome del campo e quindi trascinare il campo sulla casella Etichette di riga nella sezione dei layout nella parte inferiore dell'Elenco campi tabella pivot.
  2. Nella sezione dei campi nella parte superiore dell'Elenco campi tabella pivot fare clic tenendo premuto il pulsante del mouse sul nome del campo e quindi trascinare nuovamente il campo sulla casella Valori nella sezione dei layout nella parte inferiore dell'Elenco campi tabella pivot.

 Nota   Se i dati contengono numeri, nel rapporto di tabella pivot viene visualizzato il totale delle voci anziché il relativo conteggio. Per passare dalla funzione di riepilogo Somma alla funzione di riepilogo Conteggio, selezionare una cella della colonna e quindi fare clic Impostazioni campo nel gruppo Campo attivo della scheda Opzioni, fare clic sulla scheda Riepiloga per, su Conteggio e infine su OK.

Torna all'inizio Torna all'inizio

 
 
Si applica a:
Excel 2007