CONTA.SE

Conta il numero di celle in un intervallo che soddisfano i criteri specificati.

Sintassi

CONTA.SE(intervallo;criteri)

Intervallo    è l'intervallo di celle dal quale si desidera iniziare a contare le celle.

Criteri    sono i criteri in forma di numeri, espressioni o riferimenti di cella che consentono di determinare quali celle verranno contate. Ad esempio, i criteri possono essere espressi come 32, "32", ">32", "mele" o B4.

Note

Microsoft Excel offre delle funzioni aggiuntive che possono essere utilizzate per analizzare i dati in base a una condizione.

  • Per calcolare una somma in base a una stringa di testo o a un numero incluso in un intervallo, utilizzare la funzione del foglio di lavoro SOMMA.SE.
  • Affinché una formula restituisca uno dei due valori sulla base di una condizione, come un bonus calcolato su un certo numero di vendite, utilizzare la funzione del foglio di lavoro SE.
  • Per contare le celle vuote e quelle non vuote, utilizzare le funzioni CONTA.VALORI e CONTA.VUOTE.

Esempio 1: Formule CONTA.SE più usate

L'esempio può essere più semplice da comprendere se lo si copia in un foglio di lavoro vuoto.

MostraProcedura

  1. Creare una cartella di lavoro o un foglio di lavoro vuoto.
  2. Selezionare l'esempio nell'argomento della Guida. Non selezionare le intestazioni della riga o della colonna. 

Selezionare un esempio dalla Guida

Selezionare un esempio dalla Guida
  1. Premere CTRL+C.
  2. Nel foglio di lavoro, selezionare la cella A1 e premere CTRL+V.
  3. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule che calcolano il risultato, premere CTRL+MAIUSC+8 oppure scegliere Verifica formule dal menu Strumenti, quindi fare clic su Modalità Verifica formule.
 
1
2
3
4
5
A B
Dati Dati
mele 32
arance 54
pesche 75
mele 86
Formula Descrizione dei risultati
=CONTA.SE(A2:A5;"mele") Numero di celle contenente mele nella prima colonna (2)
=CONTA.SE(A2:A5;A4) Numero di celle che contengono pesche nella prima colonna (2)
=CONTA.SE(A2:A5;A3)+CONTA.SE(A2:A5;A2) Numero di celle che contengono arance e mele nella prima colonna (3)
=CONTA.SE(B2:B5;">55") Numero di celle con un valore maggiore di 55 nella seconda colonna (2)
=CONTA.SE(B2:B5;"<>"&B4) Numero di celle che contengono un valore diverso da 75 nella seconda colonna (2)
=CONTA.SE(B2:B5;">=32")-CONTA.SE(B2:B5;">85") Numero di celle che contengono un valore superiore o uguale a 32 e inferiore o uguale a 85 nella seconda colonna (3)

Esempio 2: Formule con la funzione CONTA.SE che utilizzano caratteri jolly e consentono di gestire valori vuoti

Per capire meglio l'esempio è consigliabile copiarlo in un foglio di lavoro vuoto.

MostraProcedura

  1. Creare una cartella o un foglio di lavoro vuoto.
  2. Selezionare l'esempio nell'argomento della Guida. Non selezionare le intestazioni di righe o colonne.

Selezione di un esempio dalla Guida

Selezione di un esempio dalla Guida
  1. Premere CTRL+C.
  2. Nel foglio di lavoro selezionare la cella A1, quindi premere CTRL+V.
  3. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule e viceversa, premere CTRL+( oppure scegliere Verifica formule dal menu Strumenti, quindi Modalità verifica formule.
 
1
2
3
4
5
6
7
A B
Dati Dati
mele
   
arance No
pesche No
   
mele
Formula Descrizione dei risultati
=CONTA.SE(A2:A7;"*le") Numero di celle che terminano con le lettere "ele" nella prima colonna (2)
=CONTA.SE(A2:A7;"??le") Numero di celle che terminano con le lettere "ele" e composte esattamente da 4 lettere nella prima colonna (2)
=CONTA.SE(A2:A7;"*") Numero di celle che contengono del testo nella prima colonna (4)
=CONTA.SE(A2:A7;"<>"&"*") Numero di celle che non contengono testo nella prima colonna (2)
=CONTA.SE(B2:B7;"No") / RIGHE(B2:B7) Il numero medio di No e celle vuote nella seconda colonna formattato come percentuale senza posizioni decimali (33%)
=CONTA.SE(B2:B7;"Sì") / (RIGHE(B2:B7) -CONTA.SE(B2:B7; "<>"&"*")) Il numero medio di Sì escluse le celle vuote nella seconda colonna formattato come percentuale senza posizioni decimali (33%)

 Nota    Per visualizzare il numero come percentuale, selezionare la cella, quindi scegliere Celle dal menu Formato. Scegliere la scheda Numero, quindi fare clic su Percentuale nella casella di gruppo Categoria.

 
 
Si applica a:
Excel 2003