Calcolare la differenza tra due orari

MostraPer presentare il risultato nel formato standard (ore:minuti:secondi)

Utilizzare l'operatore di sottrazione (-) per calcolare la differenza tra gli orari e la funzione TESTO per formattare gli orari.

Le ore non devono mai superare il valore 24 e i minuti e i secondi il valore 60.

Foglio di lavoro di esempio

L'esempio può essere più semplice da comprendere se lo si copia in un foglio di lavoro vuoto.

MostraProcedura

  1. Creare una cartella di lavoro o un foglio di lavoro vuoto.
  2. Selezionare l'esempio nell'argomento della Guida. Non selezionare le intestazioni della riga o della colonna. 

Selezionare un esempio dalla Guida

Selezionare un esempio dalla Guida
  1. Premere CTRL+C.
  2. Nel foglio di lavoro, selezionare la cella A1 e premere CTRL+V.
  3. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule che calcolano il risultato, premere CTRL+MAIUSC+8 oppure scegliere Verifica formule dal menu Strumenti, quindi fare clic su Modalità Verifica formule.
 
1
2
A B
Orario iniziale Orario finale
09/06/07 10:35:00 09/06/07 15:30:00
Formula Descrizione (risultato)
=TESTO(B2-A2;"h") Ore tra due orari (4)
=TESTO(B2-A2;"h:mm") Ore e minuti tra due orari (4:55)
=TESTO(B2-A2;"h:mm:ss") Ore e secondi tra due orari (04:55:00)

 Nota   È possibile anche applicare il formato dell'orario e della data senza utilizzare la funzione TESTO per specificare il formato. Se si utilizza sia un formato applicato con la funzione TESTO che un formato numero, prevarrà la funzione TESTO.

Dettagli funzione

TESTO

MostraPer presentare il risultato in un totale basato su un'unica unità di tempo (120 minuti)

Utilizzare la funzione INT o le funzioni ORA, MINUTO e SECONDO per eseguire questa operazione.

Foglio di lavoro di esempio

L'esempio può essere più semplice da comprendere se lo si copia in un foglio di lavoro vuoto.

MostraProcedura

  1. Creare una cartella di lavoro o un foglio di lavoro vuoto.
  2. Selezionare l'esempio nell'argomento della Guida. Non selezionare le intestazioni della riga o della colonna. 

Selezionare un esempio dalla Guida

Selezionare un esempio dalla Guida
  1. Premere CTRL+C.
  2. Nel foglio di lavoro, selezionare la cella A1 e premere CTRL+V.
  3. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule che calcolano il risultato, premere CTRL+MAIUSC+8 oppure scegliere Verifica formule dal menu Strumenti, quindi fare clic su Modalità Verifica formule.
 
1
2
A B
Orario iniziale Orario finale
09/06/07 10:35:00 10/06/07 15:30:00
Formula Descrizione (risultato)
=INT((B2-A2)*24) Totale ore tra due orari (28)
=(B2-A2)*1440 Totale minuti tra due orari (1735)
=(B2-A2)*86400 Totale secondi tra due orari (104100)
=ORA(B2-A2) Ore tra due orari, quando la differenza non supera 24 (4)
=MINUTO(B2-A2) Minuti tra due orari, quando la differenza non supera 60 (55)
=SECONDO(B2-A2) Secondi tra due orari, quando la differenza non supera 60 (0)

Dettagli funzione

INT

ORA

MINUTO

SECONDO

 
 
Si applica a:
Excel 2003