SZORZATÖSSZEG

Megadott tömbök megfelelő elemeit szorozza össze, majd kiszámolja a szorzatok összegét.

Szintaxis

SZORZATÖSSZEG(tömb1;tömb2;tömb3;...)

Tömb1, tömb2, tömb3...:     Legalább 2, legfeljebb 30 tömb, amelyek szorzatösszegét ki szeretnénk számítani.

Megjegyzés

  • Az argumentumok között szereplő tömböknek azonos méretűeknek kell lenniük. Ha ez nem teljesül, akkor a SZORZATÖSSZEG az #ÉRTÉK! hibaértéket adja eredményül.
  • A SZORZATÖSSZEG a tömbök nem numerikus elemeit nullának tekinti.

Példa

A példa könnyebben megérthető, ha üres munkalapra másoljuk.

MegjelenítésHogyan?

  1. Hozzunk létre egy üres munkafüzetet vagy munkalapot.
  2. Jelöljük ki a példát a súgótémakörben. A sor- és oszlopazonosítókat ne vegyük bele a kijelölésbe.

Példa kijelölése a súgóban

Példa kijelölése a súgóban
  1. Nyomjuk meg a CTRL+C billentyűket.
  2. A munkalapon jelöljük ki az A1 cellát, és nyomjuk meg a CTRL+V billentyűket.
  3. Az eredmények és az azt létrehozó képletek megjelenítése közötti váltáshoz használjuk a CTRL+` (aposztróf) billentyűkombinációt, vagy válasszuk az Eszközök menün a Képletvizsgálat, majd a Képletvizsgálat üzemmód parancsot.
 
1
2
3
4
A B C D
1. tömb 1. tömb 2. tömb 2. tömb
3 4 2 7
8 6 6 7
1 9 5 3
Képlet Leírás (eredmény)
=SZORZATÖSSZEG(A2:B4;C2:D4) Összeszorozza a két tömb megfelelő elemeit, majd összeadja a szorzatokat: 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156)

Megjegyzés

A fenti példa ugyanazt az eredményt adja, mint a tömbként bevitt SZUM(A2:B4*C2:D4) függvény. A tömbök használata más, a SZORZATÖSSZEG függvényhez hasonló műveleteket is lehetővé tesz. Kiszámíthatjuk például az A2:B4 tömb elemei négyzeteinek összegét a =SZUM(A2:B4^2) képlet CTRL+SHIFT+ENTER billentyűk megnyomásával (tömbképletként) történő beírásával.

 
 
Hatókör:
Excel 2003