Trois manières de convertir des nombres en texte

S'applique à
Microsoft Office Excel 2003

Logo Mr. Excel Cet article a été adapté à partir de MrExcel.com. Visitez le site Web de MrExcel.com pour plus de conseils et d'informations.

Existe-t-il un moyen de transformer facilement des nombres existants en texte ? Voici trois réponses à cette question fréquemment posée.

Utiliser la boîte de dialogue Format de cellule

Imaginons que vous disposiez d'une colonne de nombres dans une feuille de calcul. Vous pouvez mettre la colonne au format texte à l'aide de la commande Format > Cellules > Nombre > Texte.

Pour plus d'informations, consultez Utiliser la fonction TEXTE.

Utiliser la fonction TEXTE

Une autre approche consiste à utiliser la fonction TEXTE, qui convertit une valeur en texte dans un format de nombre. Pour cet exemple, supposons que les cellules A2:A100 contiennent des nombres. Pour les convertir en texte, vous pouvez procéder comme suit.

  1. Insérez une colonne B vide temporaire.
  2. Dans la cellule B2, entrez la formule suivante :

=TEXTE(A2;"0")

  1. Copier la formule de la cellule B2 dans les cellules B3:B100.
  2. Vous devez remplacer les formules par des valeurs pour qu'elles puissent être converties au format texte. Sélectionnez les cellules B2:B100.
  3. Utilisez Ctrl+C pour les copier, puis cliquez sur Edition > Collage spécial > Valeurs > OK.

Les entrées de la colonne B sont désormais la version texte des nombres de la colonne A.

  1. Copiez la colonne B dans la colonne A.
  2. Supprimez la colonne B temporaire.

L'élément essentiel de cette technique est la fonction =TEXTE(). Le second paramètre de cette fonction décrit comment les nombres doivent être mis en forme avant d'être convertis en texte. Vous devrez peut-être ajuster ce paramètre en fonction de vos nombres. Par exemple :

  • Le résultat de =TEXTE(123.25;"0") est 123.
  • Le résultat de =TEXTE(123.25;"0.0") est 123.3.
  • Le résultat de =TEXTE(123.25;"0.00") est 123.25.
  • Pour ne conserver que les décimales entrées, utilisez =TEXTE(A2;"Général").

Cette fonction est également excellente pour convertir des dates en dates mises en forme. Si une cellule contient 5/29/2003, l'utilisation de =TEXTE(A2;"j mmmm; aaaa") vous donnera 29 mai 2003.

Pour plus d'informations, consultez la rubrique d'aide TEXTE.

Utiliser l'Assistant Conversion

Une troisième méthode consiste à sélectionner la colonne de nombres et à utiliser la commande Données > Convertir. Dans la Page 1 de l'Assistant, choisissez le type de fichier approprié (il s'agira probablement de Délimité). Dans la Page 2, supprimez les éventuels séparateurs de colonnes qui ont pu apparaître pour conserver les données dans une colonne. Dans la Page 3, cliquez sur Texte sous Format des données en colonne pour indiquer que cette colonne contient du texte.

 Conseil   Une fois toutes les étapes de l'Assistant terminées, il se peut que de petits triangles apparaissent dans une ou plusieurs cellules. Il s'agit d'indicateurs d'erreurs. Si vous le souhaitez, vous pouvez sélectionner la colonne et tous les supprimer en en supprimant un seul. Pour plus d'informations, consultez Pour masquer les valeurs d'erreur et les indicateurs d'erreur dans les cellules.

 
 
S'applique à :
Excel 2003